mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Kfz Spannungsstabilisierung


Autor: Pat Rik (patrik)
Datum:
Angehängte Dateien:
  • preview image for st.JPG
    st.JPG
    76,9 KB, 619 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,
ich versuche eine Platine zu bauen die ich auf meinem Moped einsetzen 
möchte. Sie sollte quasie die Steuerung der Zündung übernehmen.
Es fucnt auch, nur habe ich das übliche Problem dass sich der AVR hin 
und her resetet. Der Grund ist Brown-out. Der ist auf 2,6V eingestellt 
und möchte ihn ungern abstellen. Ich habe mir sehr viele Beiträge zu 
diesem Problem hier im Forum angeschaut und die Tipps ausprobiert, 
leider ohne Erfolg.

Im Anhang ist ein Bild der Schaltung zu finden. Was dort noch fällt sind 
100nF Kondensatoren auf jedem VCC bzw. AVCC. Die habe ich direkt an die 
Pins gelötet. Ich habe verschiedene Kondensatoren am Spannungsregler 
ausprobiert(Elko, Tantal, mit verschiedener Kapazität), 7805 und den 
LM2940, die ungenutzten Pins durch interne Pull-Up's hochzuziehen, alles 
leider ohne Erfolg.

Die Platine ist keine SMD, nur der uC ist SMD. Kurze Beschreibung noch:
P1 ist die Spannungsversorgung, es ist dasselbe Kabel das auch die 
Zündspulen mit 12V versorgt

P6 ist 0V(also der Minuspol der Baterie)

P2, P3 sind die Zündsignale der originalen Steuerung(müsste ein IGBT 
sein der die Spannung auf 0V zieht). R11 und R15 sind mit den Interrupts 
an PD0 und PD1 des uC verbunden.

P7, P8 sind die ausgänge aus den Zündspulen und die IGBT's werden durch 
die Pins PF4 und PF5 gesteuert.

Habe leider keine Ideen mehr was ich noch ausprobieren kann. Es verhält 
sich auch ganz komisch. Manchmal wenn ich ein Kondensator ausgetauscht 
habe oder nachdem ich den Varistor eingebaut habe hat das cca. 1Std 
einwandfrei funktioniert, danach kamen aber immer wieder resets.

Habe leider keine Ideen mehr was ich noch versuchen könnte. Macht das 
vielleicht sinn, einen anderen (Automotive)Spannungsregler zu nehmen?

Oder wäre es möglich, den Ground für IGBT's galvanisch abzutrennen(wenn 
ja wie)?

Oder soll ich mich doch hinsetzen und die Platine aus SMD's bauen?

Danke für eure Tipps.
patrik

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Selbst wenn Deine Schaltung total? richtig sein sollte, kann der Aufbau 
noch falsch sein.

Eine Zündspule ist z.B. ein tückisches Objekt. Eine kleine 
Ortsveränderung und Keramik-Cs am rechten Ort wirken manchmal Wunder. 
Schutzdioden auch.

Autor: Stefan M. (celmascant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was mir Auffallt ist, das du nach dem Spannungsregler keinen 
Ladekondensator mehr hast. Wenn der Regler also mal zu wenig Spannung 
zum Regeln hat, und sind es auch nur ein paar ms, dann springt der 
Unterspannungsschutz (Brown-Out) an. Ich würde nach dem Spannungsregler 
noch einen Kondensator schalten, 470µF so aus dem Bauch raus.
Ist es möglich, das die Spannung ab und an auf unter 7,5V 
zusammenbricht? Ab da kann dein Regler laut Datenblatt nicht mehr 
gescheit Regeln.
Da brauchst du entweder einen anderen Regler oder du musst die Spannung 
schon vorher konstanter halten.

Gruss Stefan

Ach so, am Pin 1 des Spannungsreglers fehlt noh ein 100nF-Kondi. 
Ausserdem würde ich C6 grösser machen. Das hilft auch, Spannungeinbrüche 
zu überstehen.

Noch ein Tip zum Schaltplan zeichenen: Wenn man der Funktion nach von 
Links nach Rechts oder von oben nach unten zeichnet, ist es 
übersichtlicher.
Beim Spannungsregler z.b. dachte ich erstmal, der ist falsch beschalten, 
aber er war nur von rechts nach links gezeichnet... Sowas kann 
werwirren.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
D1 ist überflüssig und der VDR kommt zwischen L1 und die Diode (den 
Fehler seh ich in diesem Forum schon zum zweiten Mal, vorher kommt der 
Schaltungsvorschlag? Die http://dse-faq.elektronik-kompendium.de/ 
beschreibt das noch richtig), aber du hast schon viel getan, um 
Störungen zu verhindern. Aber wenn hier Zündspulen aktiv sind, ist EMV 
natürlich härter, perfekte Masseführung und Abschirmung vor allem 
kapazitiver Einstreuungen sind notwendig.

Der versucht was ähnliches
http://k750.myluna.de/?session=6fe46e252065ed84c95...

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
C1 sollte mal mit 1000µF / Ampere angesetzt werden.

L1 verwende ich 100µH

nach L1 verwende ich eine 15V Schutzdiode gegen Masse so kann dem 
Spannungsregler nichts passieren, als Widerstand wirkt die Drossel 
selber

Vom Ausgang des Spannungsregler eine schnelle Diode zum Eingang des 
Reglers, kleiner zusätzlicher Schutz der einen Rückwärtsstromfluss durch 
den Regler verhindert.

Hinter dem Regler kannst du dann alles weglassen evtl. noch einen 100nF 
Kerko und evtl. einen Elko falls das der Hersteller empfiehlt, diese 
bewegen sich aber eher im Bereich zw. 1 und 10µF.

Dem µC selbst kannst du ja noch 10µH direkt an VCC spendieren damit sich 
dieser nichts über die Leitung einfängt.

Autor: triti (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,
äh, braucht der 7805 nicht 100nF beim Eingang und beim Ausgang und am 
Ausgang noch einen 10-100µF Elko (aber nicht mehr, hab ich irgendwo 
gelesen)?

Zur Entstörung habe ich mal einen Pulvereisenkern mit 25 Windungen CuL 
gewickelt und den vorher in die Plusleitung gegeben. Dann noch einen 
Varistor 14V (weil der gerade da war) und eine 12V Zenerdiode und alles 
zusammen hat eigentlich sehr gut geklappt.
Einer hat mal geschrieben, dass man die Masseleitungen "verzweigt 
führen" soll weil dann weniger Störungen sind (?).

Autor: Sven P. (haku) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stefan M. schrieb:
> Was mir Auffallt ist, das du nach dem Spannungsregler keinen
> Ladekondensator mehr hast. Wenn der Regler also mal zu wenig Spannung
> zum Regeln hat, und sind es auch nur ein paar ms, dann springt der
> Unterspannungsschutz (Brown-Out) an. Ich würde nach dem Spannungsregler
> noch einen Kondensator schalten, 470µF so aus dem Bauch raus.

Der Spannungsregler wird sich bedanken...
Lass das lieber, paar 100nF und evtl. nach Datenblatt was um die 2..10µF 
und gut.

Autor: Stefan M. (celmascant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sven P. schrieb:
> Stefan M. schrieb:
>> Was mir Auffallt ist, das du nach dem Spannungsregler keinen
>> Ladekondensator mehr hast. Wenn der Regler also mal zu wenig Spannung
>> zum Regeln hat, und sind es auch nur ein paar ms, dann springt der
>> Unterspannungsschutz (Brown-Out) an. Ich würde nach dem Spannungsregler
>> noch einen Kondensator schalten, 470µF so aus dem Bauch raus.
>
> Der Spannungsregler wird sich bedanken...
> Lass das lieber, paar 100nF und evtl. nach Datenblatt was um die 2..10µF
> und gut.

Betreib ich seit knapp 3 Jahren in meinem Auto so (jedoch nicht mit MC 
hinten dran) und hatte noch nie Probleme mit dem Regler.

Stefan

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.