mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Opamp schwingt bei Erzeugung einer Referenzspannung


Autor: Andre (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich habe eine Schaltung entworfen, die ein kleines Signal mit einem 
Instrumentenverstärker verstärken soll. Da mir aber nur eine 
Spannungsversorgung von 3,3 V zur Verfügung steht, ziehe ich den 
Referenzeingang des Instrumentenverstärkers auf die Hälfte der 
Betriebsspannung.
Zur Erzeugung dieser Referenzspannung (U_B / 2) benutze ich eine ganz 
einfache Operationsverstärkerschaltung mit dem OPA333 von TI (siehe 
Anhang).

Das Problem ist aber nun, dass die Spannung am OPV-Ausgang schwingt.
Eine Suche in diesem Forum hat ergeben, dass kapazitive Lasten für OPVs 
in der Regel tödlich sind.
Ich verwende allerdings eine relativ hohe kapazitive Last, um die 
Referenzspannung etwas zu glätten.

Nun bin ich schon hingegangen und habe den großen Elko (C5: 4,7 µF) 
abgeklemmt, so dass nur noch 100 nF bleiben. Zudem habe ich direkt an 
den Ausgang einen 50 Ohm Widerstand eingelötet. Die Verbindung zum 
invertierenden Eingang besteht erst hinter dem Widerstand.
Auch das hilft nicht.

Erst wenn ich komplett den Kondensator C4 wegnehme, ist die Spannung 
stabil.

Nun meine Fragen:
Brauche ich überhaupt eine Glättung der Referenzspannung hinten oder ist 
das evtl. sogar unnötig, da meine Versorgungsspannung bereits geglättet 
ist und die Spannung am nichtinvertierenden Eingang über C12 ebenfalls 
stabilisiert wird?

Wie müsste ich die Schaltung modifizieren, damit trotz (hoher) 
kapazitiver Last die Spannung hinten stabil bleibt?

Als Instrumentenverstärker später wird der INA333 eingesetzt, der gerne 
eine niederohmige Quelle für die Referenzspannung hätte. Es ist nur von 
wenigen Ohm die Rede, da ansonsten das CMRR sich massiv verschlechtern 
könnte.
Wenn ich nun aber einen Serienwiderstand an den Referenzspannungsausgang 
einbaue, um das Schwingen zu verhindern, vergrößere ich damit nicht 
meinen Ausgangswiderstand?
Oder macht sich das nicht bemerkbar, da die Kondensatoren am Ausgang 
niederohmig genug sind?

Danke schon mal!

Grüße,
André

Autor: Gast123 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie ist denn die Impedanz des OPV-Ausgangs.. ? Laut Datenblatt 
sicherlich recht niedrig. Und durch die Regelung ist der dynamische 
Widerstand nochmal niedriger.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
C4 und C5 weglassen, C12 auf 4,7-10µF erhöhen und vor + & - des OPV 
einen Serienwiderstand von 1 kOhm schalten (Strombegrenzung wenn Ub weg 
und C12 entlädt sich in den Eingang des OPV).

Autor: Tilo L. (katagia)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kleiner R in Serie zum Ausgang?

Autor: Dieter Werner (dds5)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In verschiedenen Datenblättern zu A/D Wandlern (z.B. ADS1251) schlägt TI 
zum Puffern der Referenz den OPA350 vor.

Da wird direkt an den Ausgang 10µF gegen GND geschaltet und der OP 
verträgt das tatsächlich ohne zu schwingen. Hab's selbst ausprobiert 
weil ich es nicht glauben wollte.

Edit
Es könnte natürlich sein, dass das in der hier gezeigten Schaltung nicht 
funktioniert da die Spannung am Eingang wesentlich stärker 
schwankt/rauscht als die Spannung einer echten Referenzquelle.

Autor: Andre (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem ist, dass die Platine bereits geätzt wurde und eine so große 
Änderung wie das Hinzufügen eines neuen Bauteils kommt daher nicht in 
Frage.
Deswegen muss ich sehen, dass ich mit möglichst kleinen Änderungen 
auskomme.

@Ich
Das klingt vernünftig.
Wie ist das denn generell: Ich benötige die Referenzspannung an mehreren 
Punkten auf meiner Platine für einige Bauteile.
Kann es durch das Weglassen der Kondensatoren am Ausgang passieren, dass 
ich an den unterschiedlichen Punkten dann auch (leicht) unterschiedliche 
Spannungen habe?
Normalerweise würden ja Blockkondensatoren solche Probleme lösen, nur 
geht das ja scheinbar bei mir nicht.

@Tilo Lutz:
Wie bereits in meinem Anfangspost erwähnt, habe ich das bereits 
ausprobiert, jedoch ohne Erfolg. Vielleicht sollte ich den 
Serienwiderstand größer wählen, allerdings benötigt der 
Instrumentenverstärker später eine sehr niederohmige Quelle.

Autor: Ich (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Kann es durch das Weglassen der Kondensatoren am Ausgang passieren, dass
>ich an den unterschiedlichen Punkten dann auch (leicht) unterschiedliche
>Spannungen habe?

Im Normalfall nicht, da von der Referenz keine großen Ströme gefordert 
sein sollten. Einstreuungen sollten auch kein Problem sein durch die 
niedrige Quellimpedanz des OPV.

Autor: dummi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die Verbindung zum invertierenden Eingang besteht erst hinter dem Widerstand.

Das war genau falsch.

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>@Tilo Lutz:
>Wie bereits in meinem Anfangspost erwähnt, habe ich das bereits
>ausprobiert, jedoch ohne Erfolg.

Tilo Lutz meinte, den R direkt zwischen dem OPA-Ausgang und den beiden 
Cs, so dass diese nicht direkt am Ausgang hängen. Da reichen schon 
wenige 10 Ohm. Cs direkt am Ausgang eines OPA-Spannungsfolgers führen 
fast zwangsläufig zum Schwingen.

>Kann es durch das Weglassen der Kondensatoren am Ausgang passieren, dass
>ich an den unterschiedlichen Punkten dann auch (leicht) unterschiedliche
>Spannungen habe?

Unterschiedliche DC-Werte wird es praktisch nicht geben, aber bei 
längeren Leitungen kann es durchaus vorkommen, dass eine von einem 
Nachbarsignal angeregt wird (erst kürzlich so erlebt!). Deshalb ist es 
immer sinnvoll, ein C direkt bei der Senke anzuschließen. Das erfordert 
aber die Entkopplung von den OPA-Pins über besagten Widerstand.

Und: siehe Aussage von dummi (Gast)!

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Kann es durch das Weglassen der Kondensatoren am Ausgang passieren, dass
ich an den unterschiedlichen Punkten dann auch (leicht) unterschiedliche
Spannungen habe?


Nein. Da ist ja ein Draht zwischen und es fliesst kaum Belastungsstrom.
Die Kondensatoren haben nur einen Zweck: So kuze Belastungsspitzen zu 
bedämpfen, die so schnell sind, daß der OpAmp noch nicht nachregeln 
konnte.
Wenn deine Belastung überhaupt nicht impulsförmig ist, brauchst du gar 
keine Kondensatoren, übrigens auch nicht an R1, nur C3. Wenn es eine 
impulsförmige Belastung gibt, probiere aus (Oszilloskop) , wie weit die 
Spannung abweicht und nimm den kleinsten Kondensator, der eine gerade 
akzeptable Delle ergibt.

Siehe http://dse-faq.elektronik-kompendium.de/dse-faq.htm#F.9.2

Autor: Stefan Salewski (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Die Kondensatoren haben nur einen Zweck: So kuze Belastungsspitzen zu
>bedämpfen,

Und sie schließen das Rauschen des OPs kurz und reduzieren es damit.

@MaWin
Ist die Relation zu Manfred aus de.sci.electronics beabsichtigt?

Autor: Andre (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe den Widerstand direkt zwischen OPA-Ausgang und den beiden Cs 
gelötet, das sieht man allerdings in dem Anhang nicht, da das Bild dort 
den Stand vor meiner Änderung zeigt.
Um Missverständnisse zu vermeiden, hänge ich die Beschaltung nach meiner 
Änderung an.

Und dass erst hinter dem Widerstand zurück auf den invertierenden 
Eingang zurückgekoppelt wird, habe ich aus diesem Thread:
Beitrag "OPV-Schaltung schwingt"

Als Grund wird genannt, dass der Spannungsabfall über den zusätzlichen 
Serienwiderstand damit kompensiert wird, was auch einleuchtet.
Davon ab habe ich diese Beschaltung auch schon in einer anderen 
Applikation gesehen.

Ich frage mich nur, wie hoch der Ausgangswiderstand nach so einer 
Beschaltung ist? Wäre er dann in meinem Fall 50 Ohm?
Das wäre absolut inakzeptabel und von daher würde ich dann eher dazu 
tendieren, alle Kondensatoren wegzulassen.

Autor: Henrik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich kann mir kaum vorstellen, dass der Ausgang schwingt.

Was verstehst du denn unter schwingen? 10mVpp? Das könnte schon eine 
Messtoleranz sein bzw eine schlechte Masseverbindung.

Und mit wieviel Strom hast du den AUsgang/TP7 belastet? So ein Schwingen 
kann auch für zu große Last stehen. Hast du zufällig den Versorgungspin 
eines IC daran geschalten? Oder einen realtiv niederohmigen 
Spannungsteiler? 100R/100R? Miss am besten mal den Strom zwischen TP7 
und der Schaltung, wo es hingeht.

Ansosten ist der OPA2333 ja relativ mächtig. Schonmal versucht gar keine 
Caps an den Ausgang zu setzen? Aber 100nF müsste der locker mitmachen.

Autor: Andre (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das letzte was ich getestet habe war die Beschaltung mit dem 
Serienwiderstand und einem 100 nF Kondensator.
Die Amplitude war schon sehr groß, also wir reden hier von 1-2 Vpp. 
Frequenz irgendwo bei 20-30 kHz.
Die Last ist extrem klein, da hängt außer den Kondensatoren sonst nur 
der Instrumentenverstärker dran. Der Eingangswiderstand davon liegt im 
kOhm-Bereich.
Versorgungspin und sonst Spannungsteiler hängen da nicht dran. Wie 
gesagt, nur der Referenzeingang vom Instrumentenverstärker.

Gar keine Kondensatoren an den Ausgang zu hängen ist bis jetzt die beste 
Variante. Damit ist die Spannung nämlich stabil.
Bin eigentlich auch der Meinung, dass er 100 nF mitmachen sollte, vor 
allem weil er laut Datenblatt Unity Gain stabil ist, aber die Praxis 
zeigt leider anderes.

Autor: Stefan Salewski (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>allem weil er laut Datenblatt Unity Gain stabil ist, aber die Praxis
>zeigt leider anderes.

Unity Gain stable bedeutet nur, dass er für Verstärung 1 stabil ist. Mit 
kapazitiver Last direkt am Ausgang sind viele OPs nicht stabil.

Für Deine Anwendung hättest Du besser einen "Virtual Ground" genommen, 
gibt es u.a. von TI. Aber lass doch die Kondensatoren und den Widerstand 
am Ausgang weg, dann sollte es eh funktionieren. Mit Widerstand und 
Kondensatoren natürlich eigentlich auch, aber wer weiß schon was Du 
alles falsch gemacht hast. Ich kann mich auch an viele lustige Dinge in 
meinen Schaltungen errinnern.

Autor: Henrik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe das Datenblatt nochmal angeschaut. Der ist ja wirklich auf 
extrem low noise ausgelegt. Entsprechend kannst du dir das ganze 
rumgehampel mit den Caps schenken. Tu da höchstens 47p oder 100p gegen 
Einstrahlungen ran und fertig. Dann schingt er hoffentlich nicht mehr. 
Falls ja, musst du die Caps ganz weglassen. In den beschriebenen Apps 
ist er auch ohne Caps. Verwunderlich finde ich es allerdings auch, dass 
er mit den 100n nicht zurecht kommt.

Aber wie man Figure 15 sieht, reagiert der OPA echt allergisch auf 
Kapazitäten. Insofern lieber weglassen. Der ist ausreichend stabil.
So eine Kurve ist mir übrigens noch bei keinem OPV Datenblatt 
aufgefallen. Insofern kann dein Problem tatsächlcih etwas speziell sein.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ist die Relation zu Manfred aus de.sci.electronics beabsichtigt?

Du meinst de.sci.joerg ?

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Henrik
>ist er auch ohne Caps. Verwunderlich finde ich es allerdings auch, dass
>er mit den 100n nicht zurecht kommt.

Wieso - 100n sind doch schon ausgesprochen viel für einen OPV-Ausgang.

Vielleicht kann auch hinterm Instrumentenverstärker noch etwas gefiltert 
werden, wenn es denn wirklich nötig sein sollte.
Oder statt eines R eine kleine L reinschalten (nach dem 
Feedback-Anschluß, 10-100µ), dann stört der C danach evtl. auch nicht 
mehr.
Zu groß sollte die L aber auch nicht werden, weil die bekommen dann 
sonst wieder einen recht signifikanten ohmschen Anteil.

Autor: Felix Bonjour (e-b)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Schau dir mal die angehängte App Note an. Die stammt noch aus der Zeit 
wo es BB noch gab. Anstelle der Refernz kannst du deinen Spannungsteiler 
anschliessen.

Cheers,
Felix

Autor: Andre (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für alle Antworten.

Ich habe die Kondensatoren jetzt einfach alle weggenommen und nun ist 
die Referenzspannung stabil.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.