mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 74HC573AM verursacht 100kHz Signal


Autor: Michael M. (mikmik)
Datum:
Angehängte Dateien:
  • preview image for x.PNG
    x.PNG
    4,77 KB, 205 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
wollte mir schnell mal eben einen Pegelwandler zusammenstöpseln, um 
meinen AVR direkt über die serielle zu programmieren. Ich verwende dafür 
einen 74HC573AM (ich weis, das macht man normalerweise mit anderen 
Teilen, aber der lag hier so rum).
Wie auf dem Bild zu sehen ist, kommt das Signal (zB SCK) von einem Pin 
der seriellen, da wo die roten Punkte sind, hängt das Oszi dran.

Das klappt auch alles gut, aber immer nach ein paar Sekunden nachdem ich 
alles aufdreh, kommt die ganze Zeit das ca. 108kHz Signal das am 
OsziBild zu sehen ist von der seriellen und wird auch brav vom 74HC 
wiedergegeben. Hänge ich die Schaltung ab und messe direkt am Pin der 
seriellen ist es weg.

Die massen der VCC (5V) und von der seriellen sind verbunden.
Es passiert bei den Pins 3 (TD) 4 (ER) und 7 (RS).

woher kommt das? wie bekomm ich das weg?
Danke für jeden Tipp.
MM

Autor: kurz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab ich leider nicht ganz verstanden.

Von welchem Pegel willst Du nach wohin wandeln?
Von RS232 nach TTL oder was anderes?

Autor: Peter Dannegger (peda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei CMOS muß jeder Eingang beschaltet werden !!!


Peter

Autor: Michael M. (mikmik)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja, werd ich gleich probieren.
Reicht es wenn ich alle anderen Eingänge auf LOW schalte?

@kurz: ja genau, von RS232 nach TTL

Peter Dannegger schrieb:
> Bei CMOS muß jeder Eingang beschaltet werden !!!
>
>
> Peter

Autor: kurz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für RS232 nach TTL ist dieser Baustein denkbar schlecht geeignet. Du 
betreibst ihn außerhalb der Spezifikationen, und das ist noch die 
höfliche Version.
Das wird nix.

Autor: Michael M. (mikmik)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja ist mir bewusst, dachte halt, dass dieses auftretende Störsignal ein 
gängiges Problem wäre.
Danke trotzdem für die raschen Antworten.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Für RS232 nach TTL ist dieser Baustein denkbar schlecht geeignet. Du
>betreibst ihn außerhalb der Spezifikationen, und das ist noch die
>höfliche Version.

Vergiss die Höflichkeit. Wie kann man auf die beknackte Idee
kommen ein Latch als Pegelwandler für RS232 zu benutzen?
Das ist gelinde gesagt reiner Schwachsinn.

Autor: Michael M. (mikmik)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie gesagt, lag der hier so rum und ausprobieren wird ja noch erlaubt 
sein. Tut mir leid, dass ich Dir damit Deine sicher äußerst wertvolle 
Zeit gestohlen hab.

Ach ja: mit einem 100K R vor dem Latch Eingang läufst jetzt stabil.

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Michael M. schrieb:
> Wie gesagt, lag der hier so rum und ausprobieren wird ja noch erlaubt
> sein. Tut mir leid, dass ich Dir damit Deine sicher äußerst wertvolle
> Zeit gestohlen hab.
Natürlich aknn man alles ausprobieren.
Ist offenbar ja ohnehin Mode geworden, erstmal ausprobieren, dann 
wundern und vielleicht nachdenken und ins Datenblatt der Bauteile 
schauen.

Sorry, da hat auch mein Verständnis seine Grenzen.

> Ach ja: mit einem 100K R vor dem Latch Eingang läufst jetzt stabil.

Und wie lange? Wie lange lassen sich die Schutzdioden und sonstigen 
Strukturen eines 74HC die -12V an den Eingängen bei den maximal 
möglichen 20mA einer RS232 gefallen?
Welchen Weg sucht sich der Strom, wenn die aufgeben?
Direkt zum Ausgang vielleicht und damit zum AVR? Was hält der davon und 
was evtl. angeschlossene Komponenten?

Das unschönde dabei ist, daß bei solchen Mißhandlunegn selten gleich 
Totalausfälle auftreten, oft nur unberechenbares Verhalten.
Macht dann Spaß, tagelang Fehler zu suchen, die man sich mit sowas 
selbst eingebaut hat...

Gruß aus Berlin
Michael

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.