mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik 74hc573 kocht


Autor: Alexis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe grad einen Testaufbau gemacht mit:

AVR -> 74HC573 -> ULN2803 -> 8 LED (je 5mA)

am 74er hab ich OE auf LOW gelegt, LE auf High, somit müsste das Teil 
transparent werden. Es läuft auch alles, das heißt, die Bits wird auf 
den Leds korekt angezeigt. Doch je mehr LED leuchten, umsomehr nimmt die 
Leuchtkraft ab, so als wenn ein gemeinsamer Widerstand verwendet wurde. 
Der ULN wird dabei aber nicht erkennbar warm.
Dagegen wird der 74er ziemlich heiß. Ich nehm doch stark an, dass ich 
die Daten vom 74er direkt an den ULN kann leiten, ohne Widerstände oder?

Gruß
Alexis

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Alexis (Gast)

>Dagegen wird der 74er ziemlich heiß.

Dann ist was faul.

> Ich nehm doch stark an, dass ich
>die Daten vom 74er direkt an den ULN kann leiten, ohne Widerstände oder?

Ja.

MfG
Falk

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

seit Erfindung des Schaltplans kann man selbige aufzeichnen und auch 
hier reinstellen...

Also freundliches Rätselraten: alle Eingänge des 573 liegen auf 
definiertem Potenzial und hängen nicht in der Luft rum?
Betriebsspannung stimmt? GND und Betriebsspannung des 573 sind auch 
wirklich angeschlossen, GND vom 2803 auch?

Die 5mA pro LED schafft übrigens auch ein HC573 selbst.

Gruß aus Berlin
Michael

Autor: Alexis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaltplan existier nicht, wie gesagt es ist nur ein Testaufbau. 
Allerdings funktioniert es mittlerweile. Irgendwer hat beim Aufbau 
vergessen, die Masse anzuschließen....fühl mich grad ein wenig dämlich. 
Danke deshalb für den Tipp.


Gruß
Alexis

Autor: Magnus Müller (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Alexis schrieb:
> Irgendwer hat beim Aufbau vergessen, die Masse anzuschließen....

Alexis schrieb:
> Ich habe grad einen Testaufbau gemacht mit:

Na? WER jat da nun Mist gebaut?

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Magnus Müller schrieb:
> Alexis schrieb:
>> Irgendwer hat beim Aufbau vergessen, die Masse anzuschließen....
>
> Alexis schrieb:
>> Ich habe grad einen Testaufbau gemacht mit:
>
> Na? WER jat da nun Mist gebaut?

Hat er doch eindeutig geschrieben: ein gewisser Alexis Irgendwer... ;-))

Gruß aus Berlin
Michael

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
74HC573 schafft normalerweise 30-35mA pro Pin insgesamt 500mW, also da 
brauchst du wirklich keinen ULN2803 verwenden.

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Thomas O. (kosmos)

>74HC573 schafft normalerweise 30-35mA pro Pin

Aber nicht auf allen Pins gleichzeitig. Die meisten Bustreiber sind auf 
70mA GESAMTSTROM durch Vcc/GND begrenzt.

MFG
Falk

Autor: Thomas O. (kosmos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
habe doch geschrieben max 500mW. Auf jedenfall schafft er deine Leds mit 
5mA

Autor: faustian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du einen Strommesser?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.