mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik MC34063 hoher Stromverbrauch im Leerlauf


Autor: Gregor R. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Ich hab eine recht Komplexe Schaltung mit Grafikdisplay einem ATMEGA32 
einem TPS5430 Schaltregler der mir aus 12V am Eingang 5V macht und zu 
guter letzt einen MC34063 als Kontrastspannungserzeuger für das Display 
(-5V). Ohne den MC34063 hat die Schaltung eine Stromaufnahme von ca. 
13mA bei 12V ohne Angeschlossenes Display (mit Display 45mA). Sobald ich 
den MC34063 an die Schaltung hänge hab ich eine Stromaufnahme von ca. 
150mA ohne Last an dessen Ausgang! Der MC34063 liefert schon brav die 
-12V an seinem Ausgang die dann über einen Einfachen Spannungsteiler die 
Kontrastspannung für das Display von ca. -5V ergeben, jedoch wird dabei 
der Schaltregler und die angeschlossene Induktivität 220mH/100mA sehr 
heiß. Ich hab nun den Fehler gesucht, denn ich hab einen Kurzschluss 
irgendwo auf der Platine vermutet. In meinen Bemühungen den Fehler zu 
finden, hab ich auch den Kondensator am Ausgang ausgelötet und siehe da 
die Schaltung brauch nur mehr 45mA. D.H. wenn man die 13mA 
Grundverbrauch wegrechnet also nur mehr 32mA, was ja ganz ordentlich 
ist. Sobald der Kondensator wieder eingelötet ist, steigt der Verbrauch 
wieder auf über 150mA an. Ich verwende einen niederohmigen Tantalelko 
mit 100uF und 16V.
Die Schaltung hab ich nach dem Schaltplan des Elektronikhändlers (im 
Anhang) nachgebaut, der den Materialsatz anbietet. Hier konnte ich auch 
nichts auffälliges Entdecken, da der Schaltplan im Prinzip genau der 
Schaltung im Datenblatt entspricht.


Hat jemand eine Idee wie ich den Stromverbrauch des MC34063 drosseln 
könnte. Es wäre nämlich vorteilhaft, da die Schaltung in einem mobilen 
Gerät anwendung finden sollte.

Autor: Bernd Rüter (Firma: Promaxx.net) (bigwumpus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kannst Du den ganzen Blödsinn nicht einfach wegwerfen und einen ICL7660 
nehmen?
Da gibt es selbst hier im Board sicher mehrere Threads zur Erzeugung der 
Konstratspannung von LCDs.
Wieviel Strom bauchst Du denn ?

BTW - wie hast Du den Tantal-Elko angeschlossen ? Wie hast Du die 
Markierungen interpretiert ?

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Gregor R. schrieb:

> hab ich eine Stromaufnahme von ca. 150mA ohne Last an dessen Ausgang!

150mA klingt nach einer falsch dimensionierten Spule.

> hab ich auch den Kondensator am Ausgang ausgelötet und siehe da
> die Schaltung brauch nur mehr 45mA.

Das ist klar, ohne den Kondensator bekommt das IC keine Betriebsspannung 
und startet nicht.

Die Spule ist mit 100mA auch viel zu schwach, bzw. der 0,27Ohm 
Widerstand viel zu klein.

> Hat jemand eine Idee wie ich den Stromverbrauch des MC34063 drosseln
> könnte.

Schau mal hier: MC34063

Autor: Gregor R. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

@Bernd Rüter

An strom brauch ich eigentlich verschwindend kleine 3-5mA soviel die 
Kontrastregelung benötigt.
Bei den Tantalelkos wird immer der Pluspol mit einem Strich 
gekennzeichnet.
Klingt komisch, ist aber so :)

@Benedikt K.

Werde morgen auspobieren ob eine Spule hift, die mehr strom verträgt.

Lg Gregor

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Probier erst einmal, R1 so zu dimensionieren, dass die Spule nicht in 
Sättigung kommt. Bei einer 100mA Spule also 3,3 Ohm. Ist einfacher als 
eine Monsterspule für 1A. Vielleicht reicht das schon - wenn dann die 
Spannung nicht mehr reicht, dann könnte es helfen, C1 zu reduzieren, auf 
1nF oder darunter.

Im Materialsatz steht übrigens 400mA. Aber auch das passt nicht, denn R1 
ist auf über 1A dimensioniert. Dieser R1 ist nicht bloss ein 
Kurzschlussschutz, der sollte an die Spule angepasst sein.

Autor: Gregor R. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Hab wie A.K. vorgeschlagen hat einen größeren Widerstandswert verwendet. 
Da ich keinen 3,3Ohm bei mir rumliegen hatte hab ich einen 4,7Ohm 
Widerstand verwendet. Die Schaltung funktioniert einwandfrei. Der 
MC34063 braucht jetzt auch nur mehr 12mA anstatt 150 am Anfang.

Vielen Dank, ihr habt mir sehr geholfen!

Autor: Ingolf O. (headshotzombie)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier mal die durchgerechnete Schaltung mit den Werten für einen Strom 
von 10mA bei 12V Eingangs- und 5V Ausgangsspg.! Schaltreglerfrequenz: 
40kHz

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ingolf O. schrieb:
> Hier mal die durchgerechnete Schaltung mit den Werten für einen Strom
> von 10mA bei 12V Eingangs- und 5V Ausgangsspg.!

Das hat mit obiger Schaltung aber wenig gemeinsam, denn obige Schaltung 
macht 5V -> -12V...

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für eine korrekte Dimensionierung bei derart niedrigem Strom ist die 
Induktivität von L unweigerlich viel zu klein, folglich ist der 
Stromanstieg viel zu gross. Das ist aber nicht zwangsläufig ein Problem, 
weil er bei korrekter Dimensionierung von Rsc (R1) dann in jedem Zyklus 
gegen dessen Limit läuft und weit früher abschaltet. Folglich liegt die 
Frequenz effektiv weit höher als dimensioniert und es funktioniert 
möglicherweise trotzdem, solange die effektive Frequenz im zulässigen 
Rahmen liegt. Letztlich kann dann noch die durch Ct (C1) fest 
vorgegebene Abschaltzeit eine Rolle spielen.

Autor: Ollz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Der MC34063 liefert schon brav die -12V an seinem Ausgang die dann über
> einen Einfachen Spannungsteiler die Kontrastspannung für das Display von
> ca. -5V ergeben,

Und im Spannungsteiler gehen weitere mA verloren. Berechne das Ding 
direkt für -5V.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Soll heissen: R4 drastisch verkleinern, auf 1K oder 2K2 oder so. Dann 
sind die -5V mit dem Poti direkt einstellbar.

Autor: Ingolf O. (headshotzombie)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das ich das mit den Daten falsch herausgelesen habe, ist mein Fehler, 
denn ich mit dieser Berechnung wieder gutmachen möchte!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.