mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Kontrast Probleme / Übersprechen bei einem GLCD


Autor: Kai B. (kaib) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

hab mir letztens ein ALPS Display(LSWAG8238A 320x240) bei Ebay sehr 
günstig ersteigert.

Da es keine Daten zu dem Teil gibt habe ich die Anschlussbelegung soweit 
herausgemessen und es tut sich auch was(sieht man ja).

Allerdings scheint es hier Probleme mit dem Kontrast zu geben.
Beim oberen Bildabschnitt sieht man das übersprechenen (ein Ähnlicher 
effekt wie Beitrag "Re: Grafikfähiger LCD Controller für 320x240 LCD mit 4 Graustufen") doch 
recht deutlich.
Werden hier nun blos 2-3 Zeilen Text dargestellt verschwindet der Text 
nahezu. Werden alle Zeilen beschrieben wird fast alles weis.
Die Erzeugung der Kontrastspannungen erfolgt mit einem 324 auf dem 
Display hier konnte ich feststellen das die Spannungen sehr stark ändern 
(Spannung der Vn Pins). Die Spannung bricht teils um gut 1Volt wenn ich 
mich jetzt noch recht erinnere zusammen, was meiner Meinung nach 
vielleicht doch etwas viel ist.

Beim zweiten Bildabschnitt verhält sich das Display genauso komisch (es 
werden keine Graustuffen genutzt auch wenn es so aussieht!)

Die +5Volt / Negative Spannung sind übrigens sind stabil.
Die LCD Segment / Zeilen Treiber sind HD61104/5.

Scheint also wohl etwas mit den Kontrastspannungen nicht in Ordnung zu 
sein, oder?
Oder liegt es wie im ober genannten Thread daran das das Display murks 
ist.

MfG Kai

Autor: Benedikt K. (benedikt) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. Blau/weiße Displays sind prinzipiell schon deutlich schlechter als 
z.B. schwarz weiße. Ich verwende diese daher nie, denn man sieht beim 
Übergang von blau nach weiß bzw. umgekehrt dazwischen schwarz/violett, 
was nicht wirklich schön aussieht.
2. Prüf mal nach ob das Display einen getrennten Vee und Vo Anschluss 
hat. Also einen Pin der an den Vee/GND Anschluss des 324 geht und ein 
zweiten der nur zur Einstellung des Kontrastes dient. An diesem liegt 
dann eine etwas positivere Spannung. Wenn Vee fehlt, bzw. mit Vo 
verbunden ist, dann kann es Probleme geben, denn der 324 ist kein 
Rail2Rail OP.

Autor: Kai B. (kaib) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Benedikt danke für eine Antwort

Also die VEE Verschaltung ist hier etwas komisch gemacht.
VEE geht nicht direkt zum Stecker sondern zuvor nocheinmal zu einem 
Transistor wohl und VEE erst mit DISP_ON dazuzuschalten.
Dann zu einem weiteren Transostor wie im Datenblatt angegeben. Aber der 
Widerstand an der Basis ist nach aussen geführt zumindest meine ich das 
gemessen zu haben somit könnte das schon problematich sein. Müsste ich 
morgen nocheinmal ein bissel Testen.

Ansonsten kommt die Touchmatrix runter und das Teil in Schublade.
Hab ja auch so wenig Displays welche ungenutz rumliegen xD

MfG Kai

Autor: Kai B. (kaib) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
So grad nocheinmal herumprobiert und den zusätzlichen Transistor 
überbrückt der die Negative Spannung mit dem DISP_ON Signal hinzuschält 
und nun siehts viel besser aus.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.