mikrocontroller.net

Forum: Compiler & IDEs AVR32 Studio Debugging-Problem


Autor: Mathias U. (munter)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag,

Hard- Software:

-AVR32 Studio 2.2.0

-JTAGICE mkII
-EVK1100 mit 32UC3A0512-U

"
AVR32 Studio has checked your system to ensure the proper versions of 
required utilities are in place.

avr32program: Found version 4.0.0
avr32gdbproxy: Found version 4.0.0
avr32-gdb: Found version 6.7.1.atmel.1.0.4
avr32-g++: Found version 4.3.2
avr32-gcc: Found version 4.3.2
avr32-as: Found version 2.19.atmel.1.0.1.20081016
avr32-nm: Found version 2.19.atmel.1.0.1.20081016
avrfwupgrade: Found version 1.1.3

You are using the MinGW version of the AVR32 Utilities and AVR32/GNU 
Toolchain.

Have fun!
"


Also die Installation scheint erstmal zu funktionieren, ich kann auch 
Demoprogramme auf den AVR32 laden...

Ich habe folgendes Problem:
Beim Versuch nach der Anleitung "AVR ONE! Quick-start Guide" 
(http://www.atmel.com/dyn/resources/prod_documents/.... )
das Beispiel DIP204 zu debuggen tritt bei mir ein Fehler auf. Ich habe 
zwar keinen AVR-One, aber die Anleitung sollte trotzdem funktionieren.
Ich möchte bei der Debug-Config "Buffered AUX Trace" verwenden.
Er sagt mir " [Trace]: This configuration does not support AUX Trace". 
Die Einstellungen sind alle so gemacht, wie in der Anleitung.
Und beim Starten des Debug-Vorganges bekomme ich eine Warnmeldung --> 
siehe Bild.

Der Debugger läuft los...jedenfalls läuft das Programm los. Laut 
Anleitung soll man jetzt den Joystick drücken, damit irgendwann der 
Trace-Buffer voll wird.
Laut Anleitung sollen 6* Drücken reichen...tia, aber auch nach 30mal tut 
sich bei mir nichts.

Hat einer eine Idee, woran es liegen könnte?
Vielen Dank

Mathias

Autor: sepp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Hat einer eine Idee, woran es liegen könnte?

>Ich habe zwar keinen AVR-One, aber die Anleitung sollte
>trotzdem funktionieren.

Sicher?

Die "Buffered AUX Trace" funktionalität wird AFAIK nicht vom Jtag Ice 
MKII unterstützt. Die ist ein Feature des AVR ONE.

>Er sagt mir " [Trace]: This configuration does not support AUX Trace".
Die Meldung kommt mit Sicherheit nicht von ungefähr...

Sepp

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.