mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AT90S4414 Probleme


Autor: Harald (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

Vieleicht hat jemand von euch eine Idee was ich falsch mache....

Ich habe versucht einen AT90S4414 (TQFP) auf einer Platine mit Keramic 
Resonator bzw, mit Quarz 4 MHz und 22 / 27pF zu programmieren.
Zu Beginn war der Quarz mit 22pF eingelötet. Anschließend die 27er. Ich 
hab, um dies als Fehler auszuschließen zum Schluss einen Keramik 
Resonator eingebaut.

Es war nur der ISP Stecker und der Taktgeber eingelötet. Versorgung über 
den Programmierer (MysmartUSB MK2). Spannung lag am MC an und die Mosi, 
Miso... richtig angeschlossen.

Das Programmiertool "myAVR_ProgTool" hat erkannt, dass der MC 
angeschlossen ist und hat auch gemäutert, wenn ich einen anderen 
ausgewählt hab.
Das Flashen aber hat nicht funktioniert - Prüfsummenfehler.
Beim Einlesen hat er auch nur Blödsinn hingeschrieben.
Den Mc hab ich dann auch noch getauscht, ohne Erfolg.
Fusebits kann ich ja keine setzen und internen Oszi hat er ja auch nicht 
oder?
Bin mir sicher, dass ich nichts falsch gemacht hab.
Ich hab mein Layout hinzugefügt (sorry JPG), alles was rot ist wurde 
eingebaut. Vieleicht liegts auch am Programmiergerät, bin für jeden Tip 
dankbar....

Ich hab 50 Stk von dem rumliegen.....

Danke im Vorraus für eure Bemühungen..

: Gesperrt durch Moderator
Autor: H.J.Seifert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oh oh, was für ein schlechtes Layout :-)
Ein 100nF direkt an Vcc/Gnd ist Pflicht. Und den Reset sollte auch min. 
mit 10k gegen Vcc beschalten.

Autor: Harald (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

Der 100nF wäre rechts eingeplant.
Da ja momentan keine Belastung dran hängt, dachte ich mir kann ich ihn 
derweil weglassen.
Zum Flashen wird der Reset ja sowieso geschalten, und sollte daher 
eigentlich für mein Problem irrelevant sein.

Autor: Krach-Bumm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe das gleiche Problem, wäre schön wenn hier einer noch einen Tip zur 
Lösung reinstellt statt über das Layout zumerkern.

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Habe das gleiche Problem,

Also gleiche Platine, gleicher Controller und gleicher Programmer?

>...statt über das Layout zumerkern.

Auch wenn es die Fehlerursache sein könnte?

MfG Spess

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Krach-Bumm schrieb:
> Habe das gleiche Problem, wäre schön wenn hier einer noch einen Tip zur
> Lösung reinstellt statt über das Layout zumerkern.

Mehr als wahrscheinlich nicht.

Mach bitte einen eigenen Thread auf, statt eine 4 Jahre alte Leiche
auszugraben, und beschreibe möglichst detailliert dein Problem.

Autor: Julius (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich glaube der MK2 Programmer von myAvr unterstützt mit der aktuellen 
Firmware keine abgekündigten Controller mehr aber soweit ich mich 
erinnere konnet man für den Fall ein downgrade der firmware einspielen 
schau mal in den downloads von myavr oder funk den support an...

Gruß

Dieser Beitrag ist gesperrt und kann nicht beantwortet werden.