mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik EA DOGM132 verblasst


Autor: Sven B. (svenba)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Habe ein EA DOGM132-5 Grafikdisplay und betreibe es mit 3,3V.
Also 8 Kondensatoren angeschlossen, 1uf Tantal-Elkos, richtig gepolt 
(denke ich). Initialisierung läuft anscheinend soweit, kann nur noch 
nicht alle Spalten (Pages) beschrieben.

Jetzt ist mir beim testen aufgefallen, dass das Display immer ab ca 2 
Minuten anfängt, zu verblassen, bis dann nach 5 Minuten nichts mehr 
lesbar ist...

Hat da jemand ne Idee??

Autor: Bernhard M. (boregard)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie in:
Beitrag "Re: DOG LCD 128x64 Initialisierung ATmega8 (Assembler)"

Hilft die Lösung von dort auch?

Autor: Knut Ballhause (Firma: TravelRec.) (travelrec) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ersetze die Tantals mal durch 100nF Keramikpillen. Die kann man nicht 
falsch polen und die funktionieren auch (getestet). Damit kannst Du eine 
Fehlerquelle ausschließen. BTW: braucht man bei 3.3V nicht 9 Cs?

Edit: Nee, 8 Cs passt schon, 9 bei 2.4...3.3V.

Autor: Martin Thomas (mthomas) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Evtl. nicht mehr neuester Stand, da meine DOGM GLCD-Basteleien schon 
eine Weile her sind: die ersten Modul-Datenblätter zum DOGM128 von EA 
liessen in Sachen Kondensatorpolung ein oder zwei Fragen offen. Im 
Datenblatt des verwendeten Controllers (ST7565) wurden diese aber 
beantwortet. Wie Travel Rec. vermute ich auch einen Fehler in der 
Erzeugung der Kontrastspannung, also entweder Hardware (Kondensatoren) 
oder Software (Initialisierung/Einstellung "electronic volume"). Würde 
aber erstmal die Polung der vorh. Kondensatoren prüfen und bei den 
empfohlenen 1uF bleiben.

Autor: Sven B. (svenba)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi Leute!

Danke für die Hilfe.
Hatte ca. 5 Minuten nach Erstellung des Threads auf "Thread löschen" 
geklickt, weil ich die Lösung schon gefunden hab...Hat wohl nicht 
geklappt...

Ein Kondensator war leider doch verpolt (CAP1n /1p). Umgedreht und alles 
toll.

Aber wo ich grad eure Aufmerksamkeit hab; habt ihr nen Tipp für mich, wo 
ich so´n Bitmap2LCD Konverter her bekomme? Hab jetzt schon einige 
probiert und versuchs grad mit "Bitmap2LCD Basic".
Damit krieg ich aber immer ein Bild, welches auf dem Kopf steht oder 
alles verdreht hat usw...

Autor: Sven B. (svenba)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja... Hartnäckigkeit zahlt sich aus...

Bitmap2LCD ist gut geeignet für das DOGM132-5 !!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.