mikrocontroller.net

Forum: FPGA, VHDL & Co. Update auf ISE 11.4 unter Linux


Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich habe gerade meine ISE unter Linux auf die Version 11.4 geupdated. 
(System Edition)

Das Update lief durch, ich habe das Programm neu gestartet und was 
passiert?
"About" sagt mir immer noch, dass die Version 11.3 läuft. Gehe ich 
nochmal auf die Updatefunktion sucht er ein bisschen und ist dann 
fertig.
Auch der System Generator unter Matlab meint, dass er alt ist! Der ist 
aber noch bei Version 11.1. Der hat das letzte Update schon verschlafen 
;)

Seltsamer weise sagt mir Help/XInfo aber, dass er geupdated hat.

Hat irgendjemand eine Idee? Bin gerade nicht all zu motiviert, den 
ganzen Brocken nochmal zu installieren! :(

Danke schon mal!
  Max

Autor: Thomas R. (tinman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es ist schlechte angewohnheit "auf die neueste version updaten", das ist 
kein kernel, der muss ich jeder 20min gepatched werden :)

Anscheinend hast du eineige sachen durcheinander, ob motiviert oder 
nicht, neu - sauber isntallieren würde nicht schaden.

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Leider wird mir das auch nicht viel bringen. Auf der XILINX-Seite heißt 
es:

New installations require the ISE Design Suite 11.1, available at the 
Xilinx Product Download and Licensing Site. You will then need to 
install the ISE Design Suite 11.4 update described above.

Autor: Max (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zur info, falls jemand über das gleiche Problem stolpern sollte:
Es wird alles gut, wenn man sich das Update manuell runterlädt und 
installiert! ;)

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falls noch jemand Hinweise für den Cable Treiber für das USB Kabel hat.
Dann bitte melden. Ich habe von 11.1 zu 11.4 geupdatet und das ging ohne 
Probleme.

Autor: Alejandro P. s. (ale500)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@René

Welche version von GNU/Linux verbändest du ?

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OS:  opensuse 11.2  32bit

Hardware: Spartan3AN700 Entwicklungsboard.
          Onboard ist der Xilinx USB Programmier.


Ich weiss ich muss den Cabeldriver von Xilinx herrunterladen.


http://www.xilinx.com/support/answers/22648.htm

Auf der Seite ist ein Link und dort kommt man zu den Quellcode von dem 
Cabeltreiber.

install_drivers.tar.gz

Dannn bin ich hängengeblieben beim Configurieren. Ich glaube modpost war 
bei mir icht verfügbar. Das habe ich auch nicht zum Nachinstallieren 
gefunden.

Autor: Alejandro P. s. (ale500)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei Kernels > 2.6.24 oder 2.6.25 es compiliert nicht mehr. (Es geht bei 
Centos 4.6 (fxload ist vorinstalliert) und 5.3 (fxload fehlt), nicht bei 
Ubuntu 9.x und OpenSuSe 11.x :-()

guck auf die Fehlermeldungen und du wirst finden daß ein Paar Symbolen 
nicht mehr da sind :-(.

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja so ungefähr hatte ich auch den Eindruck.
Dass Variablen fehlen oder irgend ein Patch.

Ich nutze zum Programmieren das Tool xc3sprog und den JTAG von Olimex 
ARM-USB-OCD.
http://sourceforge.net/projects/xc3sprog/

Das geht richtig gut. Dieses Tool könnte Xilinx ruhig mal unterstützen 
als ständig nur veraltete Treiber anzubieten.

Mein Antrieb:
Wenn ich jetzt zum Spartan6 aufsteigen will, ist an den 
Entwicklungsboards kein JTAG herausgeführt, sondern nur noch die Xilinx 
hauseigene Variante On-Board. Es gibt auf den Board einen unbestückten 
Connector, der von der Größe her der JTAG sein könnte. Alles heiße 
Varianten. Es wäre schon schön auch das Xilinx Kabel benutzen zu können.
Auch um in höhere Tools, wie Chipscope oder EDK, später auch mal aufzu 
steigen.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab im Momment das Problem, das ich ISE zwar installiert habe 
(Debian+GNOME), ich aber beim besten Willen nicht erkenne kann wie man 
das jezt startet...
Legt die Installationsroutine einen Link im /bin Verzeichnis an oder so 
und wie heißt der?

Autor: Maik H. (littlechip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die "Startdatei" ist $XILINX/bin/lin/ise oder $XILINX/bin/lin64/ise.

Unter Ubuntu9.10 64 laeuft das Update einwandfrei, nur die EDK 
Grafikbugs sind noch vorhanden, aber lassen sich ja umgehen...


Gruss

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
es wird ein Verzeichnis /opt/xilinx/11.1/ angelegt.

in das Verzechnis /opt/Xilinx/11.1/ISE/bin/lin wechseln

und mit
./ise

die Ise Starten.

Am besten einem Link au dem Desktop erzeugen.
Sonst wird es auf die Dauer zu aufwendig.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ahhh.. Vielen Dank, das war mir irgendwie durch die Lappen gegangen :)
Mal sehen wie sich ISE unter Linux schlägt jezt muß ich nur den 
CableDriver noch installiert bekommen.

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du das hinbekommst, bitte Info hier zurück.

Ich nutze eine Lösung wie ich oben im thread beschrieben habe.
ISE unter Linux läuft sehr vernünftig. Nur der Cabeltreiber ist eine 
Schwachstelle.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
René D. schrieb:
> Wenn du das hinbekommst, bitte Info hier zurück.
>
> Ich nutze eine Lösung wie ich oben im thread beschrieben habe.
> ISE unter Linux läuft sehr vernünftig. Nur der Cabeltreiber ist eine
> Schwachstelle.
Tja... nun bin ich an einem Punkt wo ich nicht weiterweiss.

Grundlage ist folgender UG
http://www.xilinx.com/support/documentation/user_g... (Seite 
15+16)

Folgendes hab ich gemacht:
- Datei runtergeladen und entpackt
- Paket Fx load installiert
- in der Install Datei TP_Arch64 weil er bei mir den Befehl 'arch' nicht 
erkennt (ebenso die Echo ausgabe auskommentiert)
- Linux Source Paket installiert und entpackt
- Symbolischen Link /usr/src/linux erzeugt auf die Sourcen

Ja... und da endet es dann. mit einem haufen an Fehler (siehe Anhang). 
Vieleicht sieht ja jemand wie das zu beheben ist.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi .. schrieb:

> Tja... nun bin ich an einem Punkt wo ich nicht weiterweiss.

Das scheint mir das zu sein, was weiter oben schon geschrieben steht:
ab einer bestimmten Kernelversion lässt sich der Treiber nicht mehr
compilieren.

Mir ist so, als gäbe es irgendwo einen Opensource-Ersatz für den
Xilinx-Treiber, der protokollkompatibel ist, aber ein kompletter
Rewrite.  Den kann man sogar übers Netz benutzen (nutzt irgendeinen
TCP-Port), damit habe ich vor einiger Zeit schon mal einen alten
Toshiba Libretto unter FreeBSD als JTAG-Knecht für ein CPLD betrieben,
angesteuert von einem ISE (wird noch ein 9.x gewesen sein), das auf
einem Linux-Rechner lief.

Der konkrete Name dieses Treibers ist mir entfallen, müsste sich aber
zu Hause irgendwo finden lassen.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn das auch mit den USB Versionen funktioniert wäre das natürlich eine 
Alternative, wäre nett wenn du nochmal nach schauen könntest.

Autor: Wolfgang R. (portside)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Benutze immer noch 10.3 aber mit dem Cable geht das in 11.x noch 
einfacher da dort für USB schon die libusb voreingestellt ist sonst mit
export XIL_IMPACT_USE_LIBUSB=1.
Wenn die Einstellungen für fxload in /etc/udev/rules.d stimmen 
xusbdfwu.rules sollte es laufen.
Keine Treiber mehr sondern Userspace libusb IO.

Fürs Parallelkabel nutzt man die Lösung von 
http://www.rmdir.de/~michael/xilinx/

Ob das alles bei der SingleUserStarterEdition läuft muss man testen.

Treiber module kann man in die Tonne klopfen wenn sie nicht gewartet 
werden, die Änderungen im Kernel sind permanent.

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wolfgang Rapp schrieb:

> Fürs Parallelkabel nutzt man die Lösung von
> http://www.rmdir.de/~michael/xilinx/

Ja, das ist das Teil, das ich da auch benutzt habe.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit dem Hinweis das das ganze mit LibUSB funktionieren soll hab ich 
einfach mal Mutig mein Board angeschlossen. Lampe leuchtet und IMPACT:
AutoDetecting cable. Please wait.
PROGRESS_START - Starting Operation.
 OS platform = i686.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
File version of /opt/Xilinx/11.1/ISE/bin/lin/xusbdfwu.hex = 1030.
File version of /usr/share/xusbdfwu.hex = 1030.
 Using libusb.
 Kernel release = 2.6.26-2-686.
 Max current requested during enumeration is 74 mA.
Type = 0x0004.
 Cable Type = 3, Revision = 0.
 Setting cable speed to 6 MHz.
Cable connection established.
Soweit sogut (bis auf Lib USB mußte ich nix ändern/installieren).

Nun ist er aber bei der JTAG Chain irgendwie überfordert:
Attempting to identify devices in the boundary-scan chain configuration...
INFO:iMPACT - Current time: Di Dez 15 17:41:26 2009
// *** BATCH CMD : Identify 
PROGRESS_START - Starting Operation.
Identifying chain contents...'0': : Manufacturer's ID = Xilinx xcf04s, Version : 15
INFO:iMPACT:1777 - 
Reading /opt/Xilinx/11.1/ISE/xcf/data/xcf04s.bsd...
INFO:iMPACT:501 - '1': Added Device xcf04s successfully.
----------------------------------------------------------------------
----------------------------------------------------------------------
'1': : Manufacturer's ID = Xilinx xc3s700a, Version : 0
INFO:iMPACT:1777 - 
Reading /opt/Xilinx/11.1/ISE/spartan3a/data/xc3s700a.bsd...
INFO:iMPACT:1353 - ACD entry  BOOTSTS_ADDRESS not found for device family xc3s700a.
INFO:iMPACT:2488 - The operation did not complete successfully.
PROGRESS_END - End Operation.
Elapsed time =      0 sec.
INFO:iMPACT - Current time: Di Dez 15 17:42:15 2009
// *** BATCH CMD : ReadUsercode -p 1 
INFO:iMPACT:583 - '1': The idcode read from the device does not match the idcode in the bsdl File.
INFO:iMPACT:1578 - '1':  Device IDCODE :        00000000000000000000000000000000
INFO:iMPACT:1579 - '1': Expected IDCODE:    00000101000001000110000010010011
INFO:iMPACT - Current time: Di Dez 15 17:42:22 2009
Hm...

Autor: Jörg Wunsch (dl8dtl) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ohne behaupten zu wollen, das bis zu Ende zu verstehen ;-), kann es
sein, dass du versuchst, das falsche der beiden Devices zu flashen?
Wimre kann man nicht das FPGA selbst flashen, sondern man muss den
Boot-ROM befüllen, von dem aus das FPGA dann den Bitstrom lädt.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich versuch gar nix zu Flashen, das ist es ja. Der Boundary Scan stellt 
erstmal fest welche Devices alle in der Kette sind und stellt diese dann 
dar (zumindest war es unter WinXP so) nun wird mir aber halt nurnoch der 
Config PROM angezeigt ebr nicht mehr der FPGA (zumindest vorher konnte 
ich den unabhängig "flashen")

Autor: Neuman (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Läubi .. (laeubi)
Kannst du noch etwas genauer den Vorgehen beschreiben?
Als einfach Bord ran und..


Was hast du genau installiert oder ist mir hier was entgangen?

Ich will morgen es auch  nachvollziehen.
Leider bin ich heute unterwegs.

Danke im Vorraus

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Läubi,

wie bist du so weit gekommen?

Ich habe das skript   xusbdfwu.rules auch in meiner Installation im 
Verzeichnis 
/opt/Xilinx/11.1/ISE/bin/lin/install_script/install_drivers/linux_driver 
s/pcusb  gefunden.

Die rules bedienen Hexfiles in dem Verzeichnis /usr/share diese Hexfiles 
waren auch nicht dort. Diese habe ich aus dem Verzeichnis 
/opt/Xilinx/11.1/ISE/bin/lin/install_script/install_drivers/linux_driver 
s/pcusb  dorthin copiert.

Leider reicht es noch nicht aus. Wie hast du es installiert?

lsusb meldet.
Bus 001 Device 006: ID 03fd:000d Xilinx, Inc.


usb-drivers meldet eben Driver=(none)

T:  Bus=01 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#=  6 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS=64 #Cfgs=  1
P:  Vendor=03fd ProdID=000d Rev= 0.00
C:  #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 0 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)


Rene

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
- ISE 11.1 Installation runtergeladen
- Installiert (ohne cabledriver)
- Update
- LibUSB über apt-get installiert
- Impakt gestartet, dort alles auf Default gelassen

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ach ja Board anstecken natürlich noch ;)
Meines hat so ein Integriertes JTAG Kabel.

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
noch irgendwas mit export oder fxload getrieben?

Waren die Hex files bei dir gleich in /usr/share oder hast du diese auch 
per Hand dahin copiert?

Noch irgend was mit Userrechten oder neu gebootet?

>export XIL_IMPACT_USE_LIBUSB=1.
>Wenn die Einstellungen für fxload in /etc/udev/rules.d stimme



Ja mein board hat auch so einen Embedded JTAG.

kannst du die Outputs von den  Befehlen lsusb und usb-drivers.

Der zweite braucht root Rechte.

Danke.

Rene

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
fxload hatte ich vorher installiert, aber weiß nicht ob das überhaupt 
benötigt wird.
Nutzen tue ich das ganze unter einem ganz normalem user account.
laeubi@Laeubi:~$ lsusb
Bus 005 Device 006: ID 03fd:0008 Xilinx, Inc. 
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 1241:1503 Belkin Keyboard
Bus 002 Device 003: ID 05fe:0011 Chic Technology Corp. Browser Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

usb-drivers kennt er bei mir als Befel leider nicht muß ich dafür noch 
etwas installieren? Hab mal USB View installiert das sagt folgendes:
XILINX    
Manufacturer: XILINX 
Speed: 480Mb/s (high)
USB Version:  2.00
Device Class: 00(>ifc )
Device Subclass: 00
Device Protocol: 00
Maximum Default Endpoint Size: 64
Number of Configurations: 1
Vendor Id: 03fd
Product Id: 0008
Revision Number:  0.00

Config Number: 2
  Number of Interfaces: 1
  Attributes: 80
  MaxPower Needed:  74mA

  Interface Number: 0
    Name: (none)
    Alternate Number: 0
    Class: ff(vend.) 
    Sub Class: 00
    Protocol: 00
    Number of Endpoints: 2

      Endpoint Address: 02
      Direction: out
      Attribute: 2
      Type: Bulk
      Max Packet Size: 512
      Interval: 0ms

      Endpoint Address: 86
      Direction: in
      Attribute: 2
      Type: Bulk
      Max Packet Size: 512
      Interval: 0ms

Autor: Maik H. (littlechip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also unter Ubuntu 9.10_64 funktioniert es wie folgt

 Xilinx ISE installieren/updaten
 $ sudo ln -s /usr/bin/evince /usr/bin/acroread damit kann die ISE die 
.pdfs oeffnen
 $ sudo apt-get install libusb-dev fxload
 'export XILINX=/opt/xilinx/11.1/ISE' in die /etc/bash.bashrc 
hinzufuegen
 'export XIL_IMPACT_USE_LIBUSB=1' in die /etc/bash.bashrc hinzufuegen
 'source $XILINX/settings64.sh' in die /etc/bash.bashrc hinzufuegen
 $ sudo cp $XILINX/bin/lin64/*.hex /usr/share/
 $ sudo cp $XILINX/bin/lin64/xusbdfw.rules 
/etc/udev/rules.d/50-xusbdfw.rules
 $ sudo nano /etc/udev/rules.d/50-xusbdfw.rules und ‘$TEMPNODE’ durch 
‘$tempnote’ ersetzen (das muesste Ubuntu/Debian spezifisch sein)
 sudo /etc/init.d/udev restart
 USB-Cable aus-/einstecken (die Lampe sollte nun orange/gruen leuchtten)
 $ . ~/.bashrc

Ich benutze das USB-Cable 1 und 2, laeuft einwandfrei

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe es getestet und es läuft immer noch nicht.


>Little Chip
Danke  für deine ausführliche Beschreibung.
sudo /etc/init.d/udev restart
Ging nicht. Dafür habe ich neu gebootet.

cp $XILINX/bin/lin64/xusbdfw.rules
/etc/udev/rules.d/50-xusbdfw.rules
Hier hatte ich die Regel nicht umbenannt. Die 50- als präfix habe ich 
ergänzt.


>Läubi
Der Befehl heißt usb-devices  war mein Fehler.

USB View hat die gleichen Info.

Der USB-JTAG hat zwischen uns beiden unterschiedliche Produkt IDs.
Ich habe:
ID 03fd:000d Xilinx, Inc.

Du hast:
ID 03fd:0008 Xilinx, Inc.

Little Chip hat auch zwei verschiedene Kabel.

Bei mir meldet  usb-devices  Driver=(none)


Es ist ein udev Problem, hier muss ein Treiber stehen. Und danach sind 
die ganzen Änderungen im bash interessant.
Leider bin ich kein udev Experte.

Autor: Wolfgang R. (portside)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In den ezusbfx2 muss Firmware geladen werden. Dies wird durch das script 
xusbdfw.rules über das Device FS und Hotplug automatisiert, jedesmal 
wenn das Kabel am USB eingesteckt wird. Die Pfade von xusbdfw sind 
entsprechend der Installation anzupassen oder die HEX Dateien kopieren.
fxload wird auf alle Fälle benötigt, denn dies erledigt die eigentliche 
Arbeit. Nach fxload bekommt das Kabel eine andere Product-Id.
Der Order in welchen xusbdfw.rules zu kopieren ist kann 
Distributionsabhängig sein.Immer Vorsicht bei S..U..S..E da geht fast 
nichts nach Standard oder Suse-Config machts zunichte.
Natürlich kann man jedesmal die Firmware HEX Dateien mit fxload  zu Fuss 
oder Hand laden.

export XIL_IMPACT_USE_LIBUSB=1 braucht es wohl ab 11.1 nicht mehr, dies 
ist schon voreingestellt

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
beim Einstecken sollte udev fxload starten, so verstehe ich die Regel.
Das habe ich von Hand durchgeführt.


/sbin/fxload -v -t fx2 -I /usr/share/xusb_emb.hex
no device specified!
usage: /sbin/fxload [-vV] [-l] [-t type] [-D devpath]
                [-I firmware_hexfile] [-s loader] [-c config_byte]
                [-L link] [-m mode]
... [-D devpath] overrides DEVICE= in env
... device types:  one of an21, fx, fx2, fx2lp
... at least one of -I, -L, -m is required

Wie kann ich ein device spezifizieren?



In der Regel steht:
BUS=="usb", ACTION=="add", SYSFS{idVendor}=="03fd", 
SYSFS{idProduct}=="000d", RUN+="/sbin/fxload -v -t fx2 -I 
/usr/share/xusb_emb.hex -D $tempnote"

Was ist die Temp die Variable $tempnote oder $TEMPNODE. Diese kann ich 
nirgends finden. Das ist noch der Knackpunkt.

Autor: Wolfgang R. (portside)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>
> Der USB-JTAG hat zwischen uns beiden unterschiedliche Produkt IDs.
> Ich habe:
> ID 03fd:000d Xilinx, Inc.
>
> Du hast:
> ID 03fd:0008 Xilinx, Inc.
>

03fd:0008 sollten alle Kabel nach erfolgreichem Laden der Firmware 
haben,
ohne firmware ist die Product-id 0007 0009 000d 000f 0013 0015 je nach 
Kabel und es wird unterschiedliche Firmware ???.HEX geladen, siehe 
xusbdfw .

/sbin/fxload -v -t fx2 -I /usr/share/xusb_xup.hex -D 
/proc/bus/usb/xxx/yyy
lädt z.B. 0009 Kabel

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
/sbin/fxload -v -t fx2 -I /usr/share/xusb_emb.hex -D 
/proc/bus/usb/001/011

und die Grüne Lampe leuchtet auf dem board und die Produkt ID ist auch 
0008.


Impact habe ich noch nicht ausprobiert. Doch ich bin guter Hoffnung.

Danke Wolfgang.




Es ist die   Variable $tempnote oder $TEMPNODE  was ist das?

Autor: Wolfgang R. (portside)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>
> Es ist die   Variable $tempnote oder $TEMPNODE  was ist das?

Der ganze Pfad /proc/bus/usb/xxx/yyy
da yyy bei jedem neuen einstecken hochzählt, xxx  sollte einer der USB 
Hubs sein

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt habe ich Fehler Nummer eins gefunden.
Das Filesystem wird beim Booten  nicht gemountet.

Ich habe in in /etc/init.d/boot.d/S11boot.localfs

die Zeile

mount usbfs

gleich an den Anfang dieser Datei geschrieben. Am Ende wird udev geladen 
dann muss spätestens das usbfs gemountet sein.

Jetzt stimmt auch lsusb und die LED auf dem Board wird auch zu 
geschaltet.


Nur Impact zickt noch rum.
Mal sehen, ob ich das noch hinbekomme.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also bei mir funktiniert jezt auch wieder alles, hab ISE nochmal neu 
installiert, da war wohl im Zuge meiner fruchtlosen Versuche irgendwas 
verdreht. Das HEX hatte ich wohl schon drauf da das Baord vorher an 
meinem alten Windows hing.

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also fxload lässt sich von Hand laden.
Zuerst dachte ich udev funktioniert ordentlich. Doch denkste.
Beim Booten ging immer wieder die LED auf dem Board an. Das geht nur 
wenn die Firmware bereits geladen ist. Dann stimmt auch die Vendor und 
Product ID. Wenn der JTAG einmal stromlos geschalt wird, durch kappen 
der Stromverosgung,dann wird er nicht gefunden.
Also udev funktioniert nicht.

Des weiteren habe ich nicht die Datei /usr/local/lib/libusb-driver.so

dafür aber folgende Dateien
/usr/lib/libusb-1.0.so.0
/usr/lib/libusb-1.0.so.0.0.0


Dann geht folgendes script noch in die Hose:
/opt/Xilinx/11.1/ISE/bin/lin/install_script/install_drivers 
./install_drivers

checking for WinDriver root directory... 
/opt/Xilinx/11.1/ISE/bin/lin/install_script/install_drivers/linux_driver 
s/windriver32
checking for linux kernel source... found at /usr/src/linux
checking for lib directory... ln -sf $(ROOT_DIR)/lib/$(SHARED_OBJECT).so 
/usr/lib/$(SHARED_OBJECT).so
checking which directories to include... 
-I/lib/modules/2.6.31.5-0.1-desktop/source/include
checking linux kernel version... 2.6.31
checking for modules installation directory... /lib/modules/misc
checking for gcc kernel version... 4
checking output directory... LINUX.2.6.31.i386
checking target... LINUX.2.6.31.i386/windrvr6.ko
checking for usb support... hello.c:1:28: error: linux/autoconf.h: No 
such file or directory
no
checking for regparm kernel option... 
/usr/src/linux-2.6.31.5-0.1/scripts/Makefile.modpost:43: 
include/config/auto.conf: No such file or directory
make[1]: *** No rule to make target `include/config/auto.conf'.  Stop.
make: *** [modules] Error 2
0
checking for right linked object... windrvr_gcc_v3.a
checking for modpost location... not found
configure: error: can't find modpost at /usr/src/linux/scripts
make: *** Keine Regel, um »clean« zu erstellen.  Schluss.
make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden. 
Schluss.
make: *** Keine Regel, um »install« zu erstellen.  Schluss.
--make windrvr install rc= 2
--install_windrvr6 rc = 2
--Module windrvr6 is not running.
--Module xpc4drvr is not running.
--Note: By default, the file permission of /dev/windrvr6 is enabled for 
the root user only
  and must be changed to allow access to other users.

--real rc=2

--Driver installation failed.

--Return code = 1

Autor: Wolfgang R. (portside)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>
> Des weiteren habe ich nicht die Datei /usr/local/lib/libusb-driver.so
>

Dies ist das Ergebnis nach make von der Software aus

http://www.rmdir.de/~michael/xilinx/

Ist an einen Ort kopiert wo man normalerweise die üblichen Verdächtigen 
findet. Nach /usr/lib ist natürlich auch  möglich aber nach eventuellem 
Systemupdate wieder verschwunden

Und nix mit dem install-drivers Quatsch. Das geht gaaar nicht Baby.

Würde mich schon interessieren welche Distri das udev schrottet. Tippe 
mal aud SUSE.

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
opensuse 11.2 32 bit habe ich.
Was habt Ihr denn so?

Autor: D. I. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also unser admin hat das zeug unter opensuse 11 auf 32bit und 64bit zum 
laufen gebracht, aber ka wie

Autor: Maik H. (littlechip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
RHEL5/CentOS, das macht am wenigsten Probleme, auch was den 
Xilinx/Mentor/Cadencet Support angeht.

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Little Chip schrieb:
> Also unter Ubuntu 9.10_64 funktioniert es wie folgt
>
>  Xilinx ISE installieren/updaten
>  $ sudo ln -s /usr/bin/evince /usr/bin/acroread damit kann die ISE die
> .pdfs oeffnen
>  $ sudo apt-get install libusb-dev fxload
>  'export XILINX=/opt/xilinx/11.1/ISE' in die /etc/bash.bashrc
> hinzufuegen
>  'export XIL_IMPACT_USE_LIBUSB=1' in die /etc/bash.bashrc hinzufuegen
>  'source $XILINX/settings64.sh' in die /etc/bash.bashrc hinzufuegen
>  $ sudo cp $XILINX/bin/lin64/*.hex /usr/share/
>  $ sudo cp $XILINX/bin/lin64/xusbdfw.rules
> /etc/udev/rules.d/50-xusbdfw.rules
>  $ sudo nano /etc/udev/rules.d/50-xusbdfw.rules und ‘$TEMPNODE’ durch
> ‘$tempnote’ ersetzen (das muesste Ubuntu/Debian spezifisch sein)
>  sudo /etc/init.d/udev restart
>  USB-Cable aus-/einstecken (die Lampe sollte nun orange/gruen leuchtten)
>  $ . ~/.bashrc
>
> Ich benutze das USB-Cable 1 und 2, laeuft einwandfrei



Ich habe versucht mich an diese Skript zu halten. Ein kleiner Bug ist 
die Kleinschreibung Xilinx im Pfad. besser:
  'export XILINX=/opt/Xilinx/11.1/ISE' in die /etc/bash.bashrc

Mein aktuelles System ist Ubuntu9.10 32 bit und sollte sich zum 64bit 
nicht groß unterscheiden. Leider habe ich noch nicht den erhoffen 
Erfolg. Ich hänge an dem Problem, dass das Verzeichnis /proc/bus/usb 
leer ist.

Eine Ergänzung in fstab brachte keinen Erfolg.
none            /proc/bus/usb             usbdevfs        defaults   0 
0

Weiter wird im Netz
https://lists.ubuntu.com/archives/ubuntu-users/200...
das Anpassen der Datei  /etc/init.d/mountdevsubfs.sh empfohlen. Diese 
befindet sich erst gar nicht in meinem Dateisystem.
Nach Suchen im Netz habe ich sie gefunden.
http://ubuntuforums.org/showthread.php?t=655071
Auch dieses Skript läuft nicht vollständig.



red@PC-black:/etc/init.d$ ./mountdevsubfs.sh
.: 24: Can't open /lib/init/mount-functions.sh

Hier wird auch erwähnt, dass diese Methode obsolete ist.
https://lists.ubuntu.com/archives/ubuntu-users/200...

Falls jemand Hinweise hat.;-> Bitte posten.

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn du so ein Onboard Teil hast, dan häng es einmalig an einen WinPC 
sodass du die korrekte Firmware drauf hast. Ab da mußt du dich 
eigentlich um nix mehr kümmern:

> ISE 11.1 Installation runtergeladen
> Installiert (ohne cabledriver)
> Update
> LibUSB über apt-get installiert
> Impact gestartet, dort alles auf default gelassen

Fertig.

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läubi .. schrieb:
> Wenn du so ein Onboard Teil hast, dan häng es einmalig an einen WinPC
> sodass du die korrekte Firmware drauf hast. Ab da mußt du dich
> eigentlich um nix mehr kümmern:


Mein Win Rechner habe ich geerdet. Umstecken ist auch doof.

Ich habe gerade gelesen. Die neue Methode ist Hotplug.
/etc/hotplug  doch wie geht es weiter?

Ich hoffe Wolfgang hat noch ein paar Ideen.

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Einhängepunkt heißt jetzt:
 sudo /sbin/fxload -v -t fx2 -I /usr/share/xusb_emb.hex -D 
/dev/bus/usb/001/004

Doch wie geht es mit udev richtig?

Autor: Maik H. (littlechip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
René D. schrieb:
>
>   'export XILINX=/opt/Xilinx/11.1/ISE' in die /etc/bash.bashrc
>

ja, ich hab das Verzeichniss bei der Installation umbenannt :)



Was fuer ein Kabel hast du da eigentlich?

Gruss

Autor: Wolfgang R. (portside)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
René D. schrieb:
>> Wenn du so ein Onboard Teil hast, dan häng es einmalig an einen WinPC
>> sodass du die korrekte Firmware drauf hast. Ab da mußt du dich
>> eigentlich um nix mehr kümmern:
>

Das bringt gar nix!!! Die Firmware muss immer in den EZUSBFX2 gerladen 
werden
Mit WIN$$$ wird höchsten einmalig der CPLD aktualisiert

>
> Mein Win Rechner habe ich geerdet. Umstecken ist auch doof.
>
> Ich habe gerade gelesen. Die neue Methode ist Hotplug.
> /etc/hotplug  doch wie geht es weiter?
Wirds wahrscheinlich nicht mehr geben; alles udev

fstab???
sysfs                   /sys                    sysfs   defaults 
0 0
proc                    /proc                   proc    defaults 
0 0


kein /proc/bus/usb das muss im Kernel aktiviert sein

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Little Chip schrieb:

> Was fuer ein Kabel hast du da eigentlich?

Ich habe das Standardentwicklungsboard von Digilent für den Spartan 
3AN700. Da ist der USB-JTAG on board.

Zum Programmieren nutze ich bis jetzt den USB-Jtag ARM-USB-OCD von 
Olimex. Der läuft zwar nicht mit Impact doch mit 
http://sourceforge.net/projects/xc3sprog/


Ich habe heute sogar meinen FPGA mit Impact programmiert. Also wenn es 
läuft, dann auch bei mir. Jetzt müssen nur die richtigen Schlaufen 
zusammen gehäkelt werden.

meine fstab
proc            /proc           proc    defaults        0       0
none            /proc/bus/usb             usbdevfs        defaults   0 
0

sysfs fehlt. Gut das könnte ich noch probieren.

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Little Chip schrieb:
> Also unter Ubuntu 9.10_64 funktioniert es wie folgt
>
>  Xilinx ISE installieren/updaten
>  $ sudo ln -s /usr/bin/evince /usr/bin/acroread damit kann die ISE die
> .pdfs oeffnen
>  $ sudo apt-get install libusb-dev fxload
>  'export XILINX=/opt/xilinx/11.1/ISE' in die /etc/bash.bashrc
> hinzufuegen
>  'export XIL_IMPACT_USE_LIBUSB=1' in die /etc/bash.bashrc hinzufuegen
>  'source $XILINX/settings64.sh' in die /etc/bash.bashrc hinzufuegen
>  $ sudo cp $XILINX/bin/lin64/*.hex /usr/share/
>  $ sudo cp $XILINX/bin/lin64/xusbdfw.rules
> /etc/udev/rules.d/50-xusbdfw.rules
>  $ sudo nano /etc/udev/rules.d/50-xusbdfw.rules und ‘$TEMPNODE’ durch
> ‘$tempnote’ ersetzen (das muesste Ubuntu/Debian spezifisch sein)
>  sudo /etc/init.d/udev restart
>  USB-Cable aus-/einstecken (die Lampe sollte nun orange/gruen leuchtten)
>  $ . ~/.bashrc
>
> Ich benutze das USB-Cable 1 und 2, laeuft einwandfrei

Little Chip da muss heißen durch '$tempnode' ersetzen.

Jetzt leuchtet auch bei mir nach dem Booten die LED!!!

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt meinen dritten Linuxrechner wo ich das Kabel installieren 
will. Auf Ubuntu habe ich es lauffähig bekommen.

Jetzt habe ich ein Laptop mit SuSE 11.2 32bit.
die udev Regel ist angepasst und die LED leuchtet auch entsprechen lsusb 
meldet das Kabel korrekt.

Bus 001 Device 004: ID 03fd:0008 Xilinx, Inc.


Nur Impact findet das Kabel nicht.

Impact scheißt eine Fehlermeldung raus. Doch in hotplug hat es auch 
nichts zu suchen??

Ich muss dazusagen, dass ich die /etc/bash.bashrc nicht geändert habe 
sondern die Befehle von Hand gestartet habe.



--File /etc/hotplug/usb/xusbdfwu.fw/xusbdfwu.hex does not exist.
--Error getting file version for 
/etc/hotplug/usb/xusbdfwu.fw/xusbdfwu.hex.
--Updating xusbdfwu.hex file.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xlp.hex does not exist.
--Error getting file version for 
/etc/hotplug/usb/xusbdfwu.fw/xusb_xlp.hex.
--Updating xusb_xlp.hex file.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_emb.hex does not exist.
--Error getting file version for 
/etc/hotplug/usb/xusbdfwu.fw/xusb_emb.hex.
--Updating xusb_emb.hex file.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xpr.hex does not exist.
--Error getting file version for 
/etc/hotplug/usb/xusbdfwu.fw/xusb_xpr.hex.
--Updating xusb_xpr.hex file.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xup.hex does not exist.
--Error getting file version for 
/etc/hotplug/usb/xusbdfwu.fw/xusb_xup.hex.
--Updating xusb_xup.hex file.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xp2.hex does not exist.
--Error getting file version for 
/etc/hotplug/usb/xusbdfwu.fw/xusb_xp2.hex.
--Updating xusb_xp2.hex file.
--File /etc/hotplug/usb/xusbdfwu.fw/xusb_xse.hex does not exist.
--Error getting file version for 
/etc/hotplug/usb/xusbdfwu.fw/xusb_xse.hex.
--Updating xusb_xse.hex file.
cat: /etc/hotplug/usb.usermap: Datei oder Verzeichnis nicht gefunden

Autor: René D. (Firma: www.dossmatik.de) (dose)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich wollte schreiben.

Impact schmeißt eine Fehlermeldung raus.


Jetzt funktioniert es. Ohne, dass ich was geändert habe.
Ich habe  diesmal ohne angestecktem Kabel gebootet.

Es gibt doch noch Wunder.

Autor: Thomas Reinemann (Firma: abaxor engineering) (abaxor)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

soeben habe ich das Wunder auch vollbracht und die Erinnerungen sind 
noch frisch

libusb installieren
libubs-devel installieren
fxload installieren
libusb-driver downloaden, compilieren, installieren
exoprt LD_PRELOAD=/usr/lib/libusb-driver.so
ISE installieren oder Kabel-Treiber installieren mit 
install_drivers.tar.gz
exoprt LD_PRELOAD=/usr/lib/libusb-driver.so in settingsXX.sh aufnehemen

siehe auch
http://svenand.blogdrive.com/archive/55.html

Tom

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [vhdl]VHDL-Code[/vhdl]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.