mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik JTagICE mk2-cn zerschossen - Ideen?


Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bevor ich jetzt das große Durchklingeln starte - hat das zufälligerweise 
schon mal jemand geschafft?

Fehlersituation war folgende: Das Target wurde unter Spannung gesetzt 
und die Programmierstrippev (ISP 6pol) war gesteckt. Leider war der 
Programmer aus und auch nicht mit dem Host-USB verbunden. Seit diesem 
Vorfall dem leuchtet die ganz linke LED dauernd, sobald der Programmer 
eingeschaltet wird. Vorher war das nur bei angeschlossenem und 
versorgtem Target der Fall. USB-Seitig ist das Gerät noch da, aber alles 
was Kommunikation mit dem Target erfordert, geht nicht mehr.

Grüße,
  Holger

Autor: Thomas R. (tinman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eigentlich ab rev 3. sollten die nicht so schnell kaputt gehen, rev 4 
die ich habe stören solche "ups" geschichten überhaupt nicht.

Was hin sein kann sind U10 und U11, guck dir auch F2, alles andere ist 
vom vusb versorgt.

Autor: Holger (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas,

danke für die Kommentare.
Leider hat meine Platine (fast) keinen Bestückungsdruck, daher kann ich 
Deine Teilebezeichungen im Moment nicht nachvollziehen. Die 
Hardwarerevision habe ich aus dem gleicehn Grund auch noch nicht 
rausbekommen.

Ich habe mal ein Foto der Platine angehängt - eventuell kannst Du mir 
mal kurz verbal beschreiben, welche Bauteile Du meinst.

Grüße,
  Holger

Autor: Thomas R. (tinman) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der JTAG ICE MKII-CN den ich mente sieht eher so aus

http://www.mikrocontroller.net/attachment/38681/ds...

(wobei das ist auch rev3.0B - danach kammen noch paar änderungen die für 
mehr "sicherheit" sorgen)

Das was du hast ist zwar auch ein clone, das ist aber nicht der "JTAG 
ICE MKII-CN"

Was du hast ist link 2. vom http://enshop.avrvi.com/ , der "JTAG ICE 
MKII-CN" ist link 1.

Wie auch immer, da hilft nur jetzt durchklingeln. Was ich jetzt schon 
sehe ist das die buffer ICs an den gleichen vcc hängen was gleichzeitig 
vtarget ist?

Übrigens, kannst die chinesen vom avrvi fragen, vllt bekommst du auch 
den schaltplan - sollte kein gehemniss sein eigentlich.

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
check mal die SMD dioden vom gleichrichter. die vierte sieht irgendwie 
komisch aus.

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> check mal die SMD dioden vom gleichrichter. die vierte sieht irgendwie
> komisch aus.
Ist optisch und elektrisch gut, sieht nur auf dem Foto seltsam aus.

> Was ich jetzt schon
> sehe ist das die buffer ICs an den gleichen vcc hängen was gleichzeitig
> vtarget ist?
Nein, scheint nicht der Fall zu sein. Irgendwie hängt keiner von den ICs 
an der VTarget.

Das 74HC125 Gemüse ist aber trotzdem irgendwie mein Favorit, vielleicht 
tausche ich die einfach mal, bevor ich lange suche. Vielleicht ist ja 
auch irgend was Elektrostatisches passiert, und ich denke, es lag am 
spannungslosen Einschalten...

Grüße,
  Holger

Autor: Thomas Decker (t0mmy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oder der Atmega im mkII hat seine Daten verloren? Ich hatte das schon 
paarmal mit dem usbProg, den musste ich neu flashen, damit er wieder 
ging.

Autor: Holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So - inzwischen sind die 74hc angekommen und eingelötet - und siehe da, 
er programmiert wieder wie gehabt :)

Rückblickend betrachtet wars wohl doch ein ESD-Schaden, bei den offen am 
Kabel liegenden Ein- und Ausgängen der 74hc125er nicht unbedingt 
verwunderlich.

Grüße und danke für die Tipps,
  Holger

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.