mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STM32: Programm hängt


Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich arbeite momentan mit einem STM32F103 (100Pin) und benutze dazu 
Ride7/RLink.
In meinem Programm benutze ich u.a. die 3-SPI-Schnittstellen, 2 USARTs 
sowie 3 Timer. Das Programm an sich läuft. Aber nach einiger Zeit 
'hängt' es sich auf. Die Interrupts für die Timer kommen, allerdings 
nicht mehr zuverlässig. Die while-Schleife in main() wird überhaupt 
nicht mehr ausgeführt. Nach einem Reset läuft alles wieder. Es sieht so 
aus, als wenn das Programm irgendwo in einer Schleife hängt. Der Versuch 
das Debuggen mit Debug|Stop anzuhalten, um so zu sehen wo das Programm 
hängt, funktioniert nicht.
Ich suche nun schon eine ganze Zeit nach der Ursache, habe allerdings 
bisher nichts finden können.
Vielleicht hat ja jemand einen Tipp oder hatte selbst schon dieses 
Problem.

Gruß Tom

Autor: Glaskugelputzer (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Fehler liegt in Programzeile 42.

Autor: T.S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey,

ich mache auf gerade ein Layout mit einem STMF103T8. Ich kann dir leider 
nicht helfen, aber du vielleicht mir. Was muss man machen, damit man via 
JTAG den uC-Flash programmieren kann. Boot 0 und 1 habe ich auf GND 
gelegt. Das bringt aber nur was zum Laden vom Flash, nicht zu laden in 
den Flash.

Besten Dank für jeden Tipp

Autor: Bernd O. (bitshifter)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tom schrieb:
> Hallo,
>
> ich arbeite momentan mit einem STM32F103 (100Pin) und benutze dazu
> Ride7/RLink.
> In meinem Programm benutze ich u.a. die 3-SPI-Schnittstellen, 2 USARTs
> sowie 3 Timer. Das Programm an sich läuft. Aber nach einiger Zeit
> 'hängt' es sich auf. Die Interrupts für die Timer kommen, allerdings
> nicht mehr zuverlässig. Die while-Schleife in main() wird überhaupt
> nicht mehr ausgeführt. Nach einem Reset läuft alles wieder. Es sieht so
> aus, als wenn das Programm irgendwo in einer Schleife hängt. Der Versuch
> das Debuggen mit Debug|Stop anzuhalten, um so zu sehen wo das Programm
> hängt, funktioniert nicht.
> Ich suche nun schon eine ganze Zeit nach der Ursache, habe allerdings
> bisher nichts finden können.
> Vielleicht hat ja jemand einen Tipp oder hatte selbst schon dieses
> Problem.
So ein Problem hatte ich auch mal. Die Lösung war, den Quelltext zu 
ändern. Vermutlich liegt es bei Dir auch an der Interruptsperre in Zeile 
418. Wenn's immer noch nicht funktioniert, dann einfach bei Zeile 1 
anfangen und das Programm Schritt für Schritt bis zum Ende durchgehen.

Bitte auf keinen Fall Quelltext posten - der stört nur bei der 
Fehlersuche!

Gruß,
Bernd

Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

danke schön für die vielen hilfreichen Kommentare! Ich bin von diesem 
Forum eigentlich konstruktivere Beiträge gewöhnt.
Mir ist natürlich klar, dass man ohne Quelltext nicht sehr weit kommt. 
Nur hat dieser momentan ca. 10.000 Zeilen. Und die wollte ich nicht 
posten. Mir ging es bei meiner Frage auch vorrangig darum ob jemand 
schon einmal Probleme mit der genannten Peripherie hatte. Ich nutze ja 
doch eine ganze Menge davon. Und ich könnte mir vorstellen, dass es da 
zu Seiteneffekten kommt.

Gruß Tom

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.