mikrocontroller.net

Forum: Platinen Eagle: Warum "Wire überlappt Pin"?


Autor: Klemm (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich wollte eigentlich nur die Leitung oben an den Transistor 
anschließen, aber selbst wenn ich einen Junction-Punkt-Setze, sagt der 
ERC immer noch "Wire überlappt Pin". Warum? Angeschlossen ist ja, ich 
bekommen entspr. Luftlinien auf dem Board (das hier ist nur ein 
Ausschnitt)

Ich hoffe, die Datei wird nicht gelöscht.. wie soll ich das sonst 
demonstrieren..?

Autor: Calogero Digangi (Firma: swissgrd.va) (cdg)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
1. falsches Bildformat

nun zur Frage:
nimm es wörtlich und Du findest den Fehler

oder, die grüne Netzlinie überdeckt die rote Pin-Linie

cdg

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aus dem Grund immer erst eine Rastereinheit in Pinrichtung vom Bauteil 
wegfahren, dann der Richtungswechsel...

Ralf

Autor: Klemm (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Es ist nicht das falsche "Bildformat" - ich habe die Datei mit Absicht 
als Eagle-Datei hier reingesetzt, damit man das Problem in Eagle sehen 
kann. Dann sieht man auch gleichzeitig, dass die vorgeschlagene Lösung 
nicht funktioniert.. (zumindest bei mir nicht)

Ich hab schon viele wirklich überlappte Wires und fehlende Verbindungen 
mit dem ERC gefunden.. aber das hier ist irgendwie anders.

Anbei nochmal für die "Bildergucker"

Autor: Uhu Uhuhu (uhu)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Für die ganz Schlauen: Auch das Hochziehen des Wire hilft nichts.

@Klemm: Hast du dir mal das Symbol näher angesehen?

Autor: Klemm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
was hab ich übersehen?

Autor: Klemm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bzw. wie meintest Du das / was genau soll ich mir ansehen?

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Innenleben der Lib.

Autor: Uwe ... (uwegw)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Lass dir mal den Layer "Pins" anzeigen. Dann siehst du, dass es in 
Wirklichkeit 3 bzw 4 Anschlüsse sind. Das liegt daran, dass man in Eagle 
nicht einen Anschluss im Symbol mehreren Pins im Package zuweisen kann. 
Darum muss man hier alle Drain bzw Source getrennt anschließen.

Dein Problem hat damit allerdings (wahrscheinlich) nichts zu tun, das 
müsste eigentlich so gehen. Es klappt bei mir, wenn ich die Leitungen 
zur Seite wegführe.

Autor: Ralf (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Dein Problem hat damit allerdings (wahrscheinlich) nichts zu tun, das
> müsste eigentlich so gehen. Es klappt bei mir, wenn ich die Leitungen
> zur Seite wegführe.
Doch, weil ich basierend auf dem Bild:

Beitrag "Re: Eagle: Warum "Wire überlappt Pin"?"

vermute, dass einfach mehrere Pins auf den gleichen Koordinaten 
liegen...

Ralf

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann kann man den Fehler aber einfach wegdrücken.

Autor: Klemm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ah ja.. also gut. Dann weiß ich jetzt warum und "billige" die Meldung 
einfach. danke.

Autor: Jörn Paschedag (jonnyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klemm schrieb:
> ah ja.. also gut. Dann weiß ich jetzt warum und "billige" die Meldung
> einfach. danke.

Kannste natürlich machen. Imho ist die Lib einfach falsch, denn source 
bzw drain bestehen aus 3 bzw 4 pins, aber es wird jetzt nur jeweils 1 
pin verbunden.
Schau mal das Beispiel von uwegw und ändere die library entsprechend ab 
(besser in eigener lib).
Manchmal ist es hilfreich die Pins layer 93 sichtbar zu machen ;-)

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörn Paschedag schrieb:
> Imho ist die Lib einfach falsch, denn source
> bzw drain bestehen aus 3 bzw 4 pins, aber es wird jetzt nur jeweils 1
> pin verbunden.

Solange die alle im Package richtig herausgeführt sind, ist alles in 
Ordnung.

Autor: Jörn Paschedag (jonnyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uhu Uhuhu schrieb:
> Solange die alle im Package richtig herausgeführt sind, ist alles in
> Ordnung.

Wohl nicht so ganz, denn das bedeutet noch lange nicht, das sie auch 
angeschlossen sind. Bei eagle ist pin gleich pad und im symbol ist auf 
Anhieb nicht ersichtlich das für drain/source mehrere Anschlüsse im .sch 
erforderlich sind, damit die auch im .brd angeschlossen werden. (Es sei 
denn, der pin-layer ist eingeschaltet, damit man es sieht, aber selbst 
dann haut es nicht hin). Vermutlich hat sich der Konstrukteur gedacht, 
das ein einzelnes SO8-Bein wohl etwas miekrig für 10A Strom ist ;-)

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jörn Paschedag schrieb:
> ... das sie auch angeschlossen sind.

Das meinte ich damit.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.