mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik THS3201 - GHz Verstärker Offset Problem


Autor: Michael O. (mischu)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich setze den THS3201 von TI in einer Schaltung als Verstärker ein.
http://focus.ti.com/lit/ds/symlink/ths3201.pdf

Der Rückkoppelungspfad ist mit 768 Ohm als Rückkoppelwiderstand und 357 
Ohm nach Masse beschaltet, der positive Eingang mit 1k nach Masse. Es 
werden keine Signale eingespeist. Verstärkung ca. 3.

Laut Datenblatt soll bei einer symmetrischen Versorgung die "Input 
Offset Voltage" < 4mV sein. Bei Verstärkung von 3 würde ich also maximal 
12mV Offset am Ausgang erwarten. Meine maximale tolerierter Offset liegt 
im Bereich 15mV.

Allerdings habe ich keine symmetrische Versorgungsspannung sondern -3,3V 
und +12V um den Aussteuerungsbereich von 0 .. 9V zu nutzen.

Ich beobachte am Ausgang ein Offset mit folgender positiver 
Temperaturabhängigkeit:

 T      Uin+    Uin-    Uout
 0°C    1,7mV   6,5mV   28mV
34°C    2,5mV   8,2mV   36,7mV
61°C    3,7mV  10,5mV   52mV

Eine Simulation mit TINA zeit mir aber eine negative 
Temperaturabhängigkeit in der Größenordnung von max 30mV Offset am 
Ausgang.

Jetzt bin ich verwirrt!!!
Frage:
1. Woher kommt der Effekt?  (Ich nehme an, dass die unterschiedlichen 
Technologien Stromeingang / Spannungseingang nicht vollständig 
symmetrisch sind und für die symmetrische Versorgung optimiert sind)

2. Was kann ich dagegen unternehmen?

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Uin- ist bei diesem OPV ein Stromeingang, weil es ein CurrentFeedback 
OPV ist (CFA). D.h., Du kannst schon mal zusätzliche Spannungsabfälle 
über das Rückkopplungsnetzwerk bekommen. Und die betragen auch schon 
einige mV, wenn man mal die Stromangaben (incl. Temperaturdrift) des DB 
in Spannung über die R's umrechnet. Da alles mit plus/minus angegeben 
wird, kann es sich in ungünstigen Fällen ganz blöd addieren.
Zweitens gelten die Offset Angaben bei Ucm=0V (CommonMode), was 
bedeutet, daß beide Eingänge auf 0V liegen, also genau in der Mitte zw. 
+ und -. Dies gilt bei symmetrischer Versorgung. Dein Mitte wäre 
eigentlich bei rund +4,5V, bist also mit deiner realen Mitte (0V - 
Masse) rund 4,5V unter der wirklichen Versorgungsmitte. Da könnte sich 
also einiges verschieben.
Simuliere doch mal mit |-Ub|=|+Ub|

Autor: Michael O. (mischu)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Das sieht dann so aus, wie im Anhang bezeichnet.
Allerdings ist das wie schon beschrieben die falsche Charakteristik.

Die Offsetspannung von 35 bis 50mV erhalte ich mit unterschiedlichen 
Aufbauten derselben Schaltung. Die Temperaturabhängigkeit ist nur mit 
einer Schaltung gemessen.

Mit dem Doppel-OPAMP THS3202 sieht das Ergebnis noch 10 Größenordnungen 
schlimmer aus. Der hat um die 250mV DC-Offset in einer vergleichbaren 
Konfiguration!!!

Sprich: Machen kann ich herzlich wenig dagegen.
Habe schon mal versucht per Widerstand einen kleinen positiven Strom in 
den CFA "-" Eingang zu schieben. Damit ist der Offset für einen 
Betriebsfall änderbar.

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was soll's denn werden? Man verwendet keine GHz Verstaerker um bei 
300MHz mal 3 zu Verstaerken.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Langer Tag schrieb:
> Was soll's denn werden? Man verwendet keine GHz Verstaerker um bei
> 300MHz mal 3 zu Verstaerken.

Die Anmerkung habe ich nicht verstanden! Ich benötige vor allen Dingen 
das dU/dt und einen großen Aussteuerungsbereich.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Was soll's denn werden? Man verwendet keine GHz Verstaerker um bei
>300MHz mal 3 zu Verstaerken.

So??? 300MHz mal 3 sind doch schon fast 1GHz GBW *), die man nötig 
hätte. Wenn der OPV deutlich drüber liegt, wird auch die Signalqualität 
deutlich davon profitieren.

*) bei CFA wird zwar nicht so sehr mit der GBW gerechnet, weil es da 
diesen Zusammenhang kaum gibt, aber egal ...

@ Michael O.
simulierst Du das ganze nur? Oder ist das auch real gemessen?
Aber egal - grundsätzlich sind CFA's nicht gerade symmetrische Dinger, 
so daß die beiden Eingänge in ihren Driften sich vernmutlich kaum so 
toll aufheben werden, wie es bei VFA's üblich ist.

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,

der 1k Widerstand am "+" Eingang ist viel zu hochohmig. Dafür ist das 
Teil nicht gebaut.

Kai Klaas

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>der 1k Widerstand am "+" Eingang ist viel zu hochohmig. Dafür ist das
>Teil nicht gebaut.

das war auch mein 1. Gedanke. Im DB steht sowas von ca. 40µA input bias 
current.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jens G. schrieb:
> simulierst Du das ganze nur? Oder ist das auch real gemessen?
Die Temperaturabhängigkeit oben habe ich an einem realen Messaufbau 
ermittelt. Also Schaltung habe ich aufgebaut.

Jens G. schrieb:
> So??? 300MHz mal 3 sind doch schon fast 1GHz GBW *), die man nötig
> hätte. Wenn der OPV deutlich drüber liegt, wird auch die Signalqualität
> deutlich davon profitieren.

Der THS hat laut Datenblatt folgende Werte:
Unity-Gain Bandwidth: 1.8 GHz The THS3201 is a wideband, high-speed
·Unity-Gain Bandwidth: 1.8 GHz
·High Slew Rate: 6700 V/µs (G = 2 V/V, RL = 100 Ω, 10-V Step)
·IMD3: –78 dBc at 20 MHz: (G = 10 V/V, RL = 100 Ω, 2-VPP Envelope)
·Noise Figure: 11 dB (G = 10 V/V, RG = 28 Ω, RF = 255 Ω)

AC PERFORMANCE / Small-signal bandwidth, -3 dB (V Typ O = 200 mVPP)
G = +1, RF = 1.2 kΩ      1.8 GHz
G = +2, RF = 768 Ω       850 MHz
G = +5, RF = 619 Ω       565 MHz
G = +10, RF = 487 Ω      520 MHz

Mit G = +3 liege ich also noch deutlich über 300MHz.

Kai Klaas schrieb:
> der 1k Widerstand am "+" Eingang ist viel zu hochohmig. Dafür ist das
> Teil nicht gebaut.
Die Offsetdrift beobachte ich auch, wenn ich den "+" Eingang gegen Masse 
kurzschließe, dann mit einem etwas anderen initialen Offset.
Allerdings ist der Hinweis gut! Warum benötigt der CFA mit seinem 
Voltage Input eine derart niedrigen Eingangsimpedanz?


Allerdings verstehe ich die Diskrepanz zwischen dem Simulations-Modell 
und der Realität nicht. Die Temperaturkoeffizienten sind exakt 
gegenteilig - Simulation behauptet negative Abhängigkeit, Realität zeigt 
positive Abhängigkeit. Irgend welche Ideen?

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Irgend welche Ideen?

nimm doch mal zum Vergleich eine symmetrische Spannungsversorgung

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
faraday schrieb:
>>Irgend welche Ideen?
>
> nimm doch mal zum Vergleich eine symmetrische Spannungsversorgung

Schaum mal hier 
Beitrag "Re: THS3201 - GHz Verstärker Offset Problem"
Da habe ich eine symmetrische Betriebsspannung verwendet.

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich kenne TINA nicht und nehme an, daß alle Diagramme Simulationen sind.
Nimm doch dann mal einen anderen low offset+drift OPA und schau, was die 
Schaltung macht. Vielleicht liegt's ja nicht am THS.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@faraday
Ich habe sowohl gemessen als auch simuliert.

Auf meiner Testschaltung ist nur der THS mit ein paar Widerständen 
drauf. Diese schaltung zeit eine stärkere Temperaturdrift als im 
Datenblatt beschrieben. Was rätst Du mir genu - soll ich den THS auf dem 
Aufbau weglassen und nur die paar Widerstände messen?

Oder meinst Du ich sollte TINA überprüfen, ob die Simulation für 
beliebige OPAMPs identisch aussieht?

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fuer schnelle Anwendungen sollte man nicht mehr OpAmps probieren. Da hat 
man ganz andere Verstaerker, die haben ueblicherweise 50 Ohm, ode 
sonstwie eine definierte Impedanz. Oder man macht's von vorneweg mit 
Tansistorstufen. Was soll's denn werden ?

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Langer Tag schrieb:
> Fuer schnelle Anwendungen sollte man nicht mehr OpAmps probieren. Da hat
> man ganz andere Verstaerker, die haben ueblicherweise 50 Ohm, ode
> sonstwie eine definierte Impedanz. Oder man macht's von vorneweg mit
> Tansistorstufen. Was soll's denn werden ?

Was soll man denn stattdessen verwenden?
Diskrete GHz Transistorstufen?
Na, den Entwicklungsaufwand möchte ich mir garnicht vorstellen!! 
Zusätzlich wird man doch niemals an die Qualität eines integrieten 
Verstärkers heran kommen aufgrund viel größerer Dimensionen und damit 
einhergehender parasitärer Elemente (Kapazität / Induktivität).

Es soll ein einfacher Spannungsverstärker (Faktor 3-4) mit > 300MHz 
Bandbreite und einem Swing von 0..10 V werden.

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
10V Swing ist ueppig, speziell an 50 Ohm. das waeren dann +-100mA. Das 
kann der THS3201 grad noch an +-5V. 10Vpp sind uebrigens 250mW oder 
+24dBm.
Das scheint mir relstiv viel zu sein. Worum geht's denn ?

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,

>Allerdings verstehe ich die Diskrepanz zwischen dem Simulations-Modell
>und der Realität nicht. Die Temperaturkoeffizienten sind exakt
>gegenteilig - Simulation behauptet negative Abhängigkeit, Realität zeigt
>positive Abhängigkeit. Irgend welche Ideen?

Wenn du das Datenblatt genau anschaust, findest du, daß der 
Temperatur-Koeffizient der Offsetspannung positives wie negatives 
Vorzeichen haben kann. Was Figure 23 dagegen zeigt, ist nur der typische 
Verlauf.

Auch die Simulationssoftware wird nur ein bestimmtes Vorzeichen 
simulieren. Du kannst das ja einstellen. Und da kann es schon sein, daß 
der eine eine negative und der andere eine positive Abhängigkeit zeigt.

>Warum benötigt der CFA mit seinem Voltage Input eine derart niedrigen 
>Eingangsimpedanz?

Weil diese Eingangsimpedanz mit der Eingangskapazität des Chips einen 
Tiefpaß bildet. Bei 1pF und 50R ergibt das eine Grenzfrequenz von 
3,2GHz, also akzeptabel. Bei 1k sind es dagegen 160MHz. Wenn jetzt deine 
Quelle ebenfalls recht hochohmig ist, siehst du von deinem 1,8GHz 
Verstärker nicht mehr sehr viel.

Noch ein Tipp: Erwarte nicht 100%ige Absolution von einer 
Simulationssoftware. Die macht immer irgendwo irgendwelche Fehler und 
arbeitet nur in bestimmten Bereichen genügend genau. Filterkurven lassen 
sich schön berechnen, und ähnliches Gedöns, wo man für den OPamp ein 
nahezu ideales Verhalten annehmen kann. Aber je mehr man von dem Modell 
verlangt die Hyperfeinstruktur der Innenschaltung des OPamp exakt 
nachzubilden, um so mehr gibt das dann einen Schuß ins Blaue.

Kai Klaas

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Oder meinst Du ich sollte TINA überprüfen, ob die Simulation für
>beliebige OPAMPs identisch aussieht?

na ja wäre schon interessant, ob die Ergebnisse bei einem anderen Typ 
ähnlich sind, falls Du einen da hast.
Und Kai hat das mit der Simulation schon gut getroffen.
Was ich aber meinte war, daß Du in Deine Testschaltung einen wirklich 
guten (evtl. nicht so schnellen) OPA einsetzen solltest und mal gucken 
sollst, wie die Temp.drift so aussieht. Oft sind die fertigen ICs 
wirklich 1a und das drumherum schlecht(er). Ich habe schon oft aus 
Ratlosigkeit den IC gewechselt um dann doch irgendwann zu merken, daß 
der Fehler in der Peripherie lag.
Ich habe jedenfalls festgestellt, daß die Parameter im Datenblatt 
eigentlich immer stimmen, wobei dann aber meist auch Randbedingungen 
existieren.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kai Klaas schrieb:
> Wenn du das Datenblatt genau anschaust, findest du, daß der
> Temperatur-Koeffizient der Offsetspannung positives wie negatives
> Vorzeichen haben kann. Was Figure 23 dagegen zeigt, ist nur der typische
> Verlauf.

Danke! Das ist ein wichtiger Punkt.
D.h. es gibt dann keinen eindeutigen Temperaturgang und er muss auch 
nicht einmal monoton sein.

Kai Klaas schrieb:
> Noch ein Tipp: Erwarte nicht 100%ige Absolution von einer
> Simulationssoftware. Die macht immer irgendwo irgendwelche Fehler und
> arbeitet nur in bestimmten Bereichen genügend genau. Filterkurven lassen
> sich schön berechnen, und ähnliches Gedöns, wo man für den OPamp ein
> nahezu ideales Verhalten annehmen kann. Aber je mehr man von dem Modell
> verlangt die Hyperfeinstruktur der Innenschaltung des OPamp exakt
> nachzubilden, um so mehr gibt das dann einen Schuß ins Blaue.

Ja, das ist mir soweit auch klar, dass eine Simulation nur eine 
idelaisierte Abbildung der Realität ist. Sämtliche Parameterstreuungen 
der Fertigung können nicht berücksichtigt werden. Da hilft dann 
vielleicht eine Monte-Carlo Simulation (für den Hersteller) aber das 
bringt einem bei der Optimierung der konkreten Schaltung nicht viel 
weiter.

Ich probiere es mit einer DC-Offsetkorrektur, indem ich einen Strom der 
über einen 180k - 220k Widerstand aus der +12V Versorgung in den 
negativen Stromeingang eingespeist wird. Die Drift besteht, ich kann sie 
aber in meinem Arbeitspunkt um die 0V verschieben.

Kai Klaas schrieb:
> Weil diese Eingangsimpedanz mit der Eingangskapazität des Chips einen
> Tiefpaß bildet. Bei 1pF und 50R ergibt das eine Grenzfrequenz von
> 3,2GHz, also akzeptabel. Bei 1k sind es dagegen 160MHz. Wenn jetzt deine
> Quelle ebenfalls recht hochohmig ist, siehst du von deinem 1,8GHz
> Verstärker nicht mehr sehr viel.

Die Quelle treibt mit ca. 50 Ohm, die 1k sind nur zum halten des 
Potentials gedacht falls die Quelle entfernt wird. Nein - es ist kein 50 
Ohm Kabel und ich brauchte den Abschluss dort nicht.

faraday schrieb:
> as ich aber meinte war, daß Du in Deine Testschaltung einen wirklich
> guten (evtl. nicht so schnellen) OPA einsetzen solltest und mal gucken
> sollst, wie die Temp.drift so aussieht. Oft sind die fertigen ICs
> wirklich 1a und das drumherum schlecht(er). Ich habe schon oft aus
> Ratlosigkeit den IC gewechselt um dann doch irgendwann zu merken, daß
> der Fehler in der Peripherie lag.

Ich weiss was du meinst. Damals im Praktikum habe ich einen VCO (3,2 
-4,2GHz) auf einem Testboard aufbauen und vermessen dürfen. Das war eine 
dreilagige Platine mit einseitiger Teflonauflage, damit man mit 
möglichst geringen dielektrischen Verlusten messen kann.
Ich habe bei dem THS3201 gemäß Datenblatt die Innenlagen um den 
Feedbackpfad freigestellt, da alleine die Pads des IC's und der 
Widerstände zu den Innenlagen schnell eine parasitäre Kapazität von 
500fF - 1pF aufbauen. Damit die Rückkoppelung belastend führt dies zu 
einer erhöhung der Verstärkung bei hohen Frequenzen.
Das HF-Signal sieht auch gut aus (Anstiegszeit < 2ns (0..10V) / 
Abfallzeit < 1,5ns 10V..0V).
Mir ist auch klar, dass die Widerstände einen Tk haben, aber der sollte 
nicht so drastisch sein. Zumal kein Widerstände zu einer der 
Versorgungen geht sondern wenn überhaupt nach Masse. Ein Offset sollte 
so definitiv nicht entstehen!!

Autor: faraday (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eigentlich macht der THS doch alles wie im DB:
Input bias current (-)= +/-80µA max
Input bias current drift (-) = +/- 0,3µA/°C  typ
das ergibt doch an 360 Ohm bei Annahme von Ib(-) ca. 27µA und V=3
Uout = +/- 28mV +/- 0,3 mV/°C
auch bei geerdetem (+).
Oder habe ich was übersehen?
dann bleibt Dir m.E.nur noch Kompensation oder kleinere Widerstände 
übrig.

Autor: Michael O. (mischu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
faraday schrieb:
> eigentlich macht der THS doch alles wie im DB:
> Input bias current (-)= +/-80µA max
> Input bias current drift (-) = +/- 0,3µA/°C  typ
> das ergibt doch an 360 Ohm bei Annahme von Ib(-) ca. 27µA und V=3
> Uout = +/- 28mV +/- 0,3 mV/°C
> auch bei geerdetem (+).
> Oder habe ich was übersehen?
> dann bleibt Dir m.E.nur noch Kompensation oder kleinere Widerstände
> übrig.

Manchmal sieht man die Lösung vor lauter Tomaten auf den Augen nicht!
Ich denke das war es. Gestern habe ich in diesem Schaltungsteil die 
Verstärkung verändert und habe eine niedrigere Drift beobachtet.

Ich habe versucht mich an die im Datenblatt vorgeschlagenen Werte für 
die Rückkoppelung zu halten. Dann muss ich da wohl noch runter.

Danke allen für die Hilfe!

Autor: Kai Klaas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Michael,

bist du denn an DC überhaupt interessiert? Wenn nicht, füge doch ein 
paar Kondensatoren ein und mache einen Wechselspannungsverstärker 
daraus.

>Ich habe versucht mich an die im Datenblatt vorgeschlagenen Werte für
>die Rückkoppelung zu halten. Dann muss ich da wohl noch runter.

Das ist eher nicht zu empfehlen, weil dann in der Regel die 
Geschwindigkeit leidet und die Schwingneigung steigt. Bei einem 
Current-Feedback Verstärker können sogar kleine Änderungen hier ganz 
verheerende Auswirkungen haben. Das würde ich mir dreimal überlegen...

Eine bessere Option ist wahrschweinlich, einen anderen OPamp zu 
verwenden. MAXIM hat da gute Versionen, die gerade im Hinblick auf 
deinen Offset überlegen sind. Auch ANALOG DEVICES zieht langsam nach und 
hat ganz interessante Teile.

Kai Klaas

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.