mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik "Stromausfall" bei Spannungswandler + Spannungsregler


Autor: andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe folgendes Problem:
Ich hab eine Platine zur Spannungsversorgung auf der ein LM2576-ADJ 
sitzt, der mir eine Spannung von ca. 7V erzeugt (Eingangsspannung ca 
16V).
An den 7V vom Spannungswandler sitzt ein LM2940 (5V Spannungsregler, 
Low-Drop). Beide Bauteile sind entsprechend dem Datenblatt beschalten.
Die 7V betreiben 2 Servos, die 5V sind für den Microcontroller 
(ATmega16) und ein LCD Display.
Die meiste Zeit funktioniert die Schaltung tadellos, allerdings kommt es 
manchmal zu "Stromausfällen" bei der 5V Quelle. (Sprich: Display aus, µC 
tut nichts mehr usw.)
Geh ich nurn mit einem Spannungsmessgerät an die Kontakte der 5V Quelle 
seh ich noch kurz keine oder eine geringe Spannung bevor die Spannung 
auf einmal wieder da ist.
Nun die Frage: hat jemand eine Ahnung was das sein könnte und was man 
dagegen machen kann?
Es ist immer das selbe: Spannung weg -> Spannungsmessgerät anlegen -> 
Spannung wieder da
Legt man das Spannungsmessgerät nicht an bleibt die Spannung weg (kommt 
also nicht nach einiger Zeit von allein wieder).
Langsam bin ich echt ratlos - wäre toll wenn mir jemand helfen kann!
Vielen Dank schonmal

Andy

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Schaltregler regelt nicht so schnell nach,
wenn ein Servo anläuft kann der kurz wie ein Kurzschluss wirken und die 
Ausgangsspannung (und damit Eingangsspannung des 2940) bricht zusammen, 
vielleicht sogar auf 0V. Damit bricht auch die Ausgangsspannung der 5V 
kurz zusammen, und wenn der uC keine brown out detection programmiert 
hat (die beim ATMega16 ja durchaus einschaltbar wäre), dann hängt er 
sich ggf. auf. Manchmal ist der Spannungseinbruch auch so fies, daß 
nicht mal die eingebaute brown out detection hilft und man externe 
bausteine braucht.

Ich würde deine Schaltung sowieso umbauen:

Den 2576 auf 5.7V stellen, der füllt einen Elko aus dem Servos betrieben 
werden, und von dort geht eine Diode (0.7V Spannungsverlust) auf einen 
zweiten Elko, aus dem der ATmega16 versorgt wird, ohne weiteren 
Spannnungsregler. Der zweite Elko muss so gross sein, daß in den kurzen 
Spannungseinbrücken der AVR eben aus diesem Elko versorgt werden kann 
ohne das dessen Spannung unter 4.5V fällt.

Autor: andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
danke für die schnelle Antwort. Brown-out Detection ist aktiv (auf 
2,7V).
Was ich nicht versteh ist warum dann auch das Display aus bleibt (auch 
die Displaybeleuchtung). Die müsste doch nach so einem Spannungseinbruch 
wieder an gehen oder? Das sie aus bleibt kann ja nur bedeuten das die 
Spannung ausfällt und auch weg bleibt.
Und warum funktioniert alles wieder wenn ich versuch die Spannung zu 
messen?

Den 2576 auf 5,7V umstellen geht leider nicht die Servos brauchen eine 
so hohe Spannung um entsprechend Leistung zu bringen.

Autor: avion23 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deine Meßspitzen bilden eine Kapazität, der Spannungsregler läuft dann 
wieder an. Kann es sein, dass du deinen Wandler oder Regler nicht 
richtig abgeblockt hast?

Autor: andy (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
wies aussieht haben wir den Fehler gefunden. Ist wohl einfach nur ein 
Wackelkontakt auf der Platine der zufällig durch die Messspitzen behoben 
wurde.
Trotzdem vielen Dank für eure Hilfe!

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.