mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik cny70 funktioniert nicht wie er sollte


Autor: HighVoltage (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
ich möchte den cny70 als liniensensor für meinen Roboter verwenden, ich 
habe ihn so angeschlossen wie im flgenden Schaltbild, jedoch passiert 
etwas anderes als ich mir gedacht habe: Wenn ich sehr nahe am boden bin 
dann sind alle werte gleich auch wenn da eine unterscheidliche farbe 
ist, jedoch wenn ich mit den sensoren raufgehe dann wird die spannung 
Vout größer und bei engeren abständen wieder kleiner
wieso ist das denn so`?

Autor: spess53 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Vout größer und bei engeren abständen wieder kleiner
>wieso ist das denn so`?

Falsches Datenblatt. Ist aber nicht deine Schuld. Es gibt/gab das Teil 
in zwei Ausführungen. Suche dir das passende Datenblatt aus.

MfG Spess

Autor: HighVoltage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
muss ich da vielleicht irgend ne zusätzliche Beleuchtung einfügenm, denn 
ich habe ihn nach dem richtigen Plan angeschlossen, aber es passiert das 
selbe, ich weiß nicht worans liegt, das ganze passiert bei 3 Sensoren 
gleich, also wirds wahrscheinlich nicht am sensor liegen sonder an der 
dimensionierung, oder liege ich da fasch?

Autor: Otto (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
47k als Pull-Up sind ein wenig viel, versuche es mit 4k7

Otto

Autor: TrippleX (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Je kleiner dein Abstand oder umso heller dein Untergrund umso niedriger
wird die Spannung an Vout.
Das kommt daher da der interne Fototransistor im CNY70 mehr Licht
empfängt und somit besser durchsteuert und als Folge dessen fließt
mehr Strom, dann fällt auch mehr Spannung am Widerstand R2 ab
und somit sinkt das Potenzial Vout.


Der CNY70 ist nur für wenige Milimeter gedacht, in meinen Linienroboter
funktioniert das.

Autor: HighVoltage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein auch nicht, jetzt komm ich nicht unter die 3 V, aber es tut sich 
sehr wenig was wenn ich von schwarz auf weiß geh

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

...liegen sonder an der dimensionierung, oder liege ich da fasch?...

Ich habe diese Teile auch schon mal in den Fingern gehabt. Und ehrlich 
gesagt finde ich die Dinger grottenschlecht. Der optimale Abstand 
beträgt 0,3mm. Evtl. hilft es , wenn du den Strom durch die Diode 
grösser machst. Also den Vorwiderstand auf 180 oder 150R verkleinern.

MfG Spess

Autor: HighVoltage (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nein die 47k stimmen schon, aber auf dieser seite bsplsweise steht 3-6mm 
und das haut auch bei denen hin
http://www.test1.steele-online.de/index.php?option...

frage is halt wieso es bei denen hinhaut

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.