mikrocontroller.net

Forum: Platinen VIAS mit GND verbinden


Autor: H. X. (atombombi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

ich habe auf meiner LP Vias erstellt. Nun möchte ich diese Vias (alle) 
mit dem GND polygon verbinden.

1. Ich kann allen VIAs nicht den gleichen Namen geben. Wie könnte ich 
das hinbekommen? Wenn ich "group" mach und dann "signal gnd" eingeb, 
dann kann ich die Vias nicht umbenennen.
2. Ein Via kann ich in GND umbenennen. Nur wenn ich jetzt zu testzwecken 
das GND Polygon herum lege, dann entseht zwischen dem Via und dem 
Polygon keine Verbindung. Ich kann das spaciing nicht auf Null stellen. 
Wie kann ich die Vias und das GND polygon miteinander verbinden?

3. Kennt jemand ein gutes Tutorial, mit dem man Eagle Board Erstellen 
schnell bzw gut lernen kann? ich habe noch kein gefunden, was auf die 
Probleme eingeht.

Vielen Dank

: Verschoben durch Moderator
Autor: Pragmatiker (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf die schnelle? Bastel ne kurze Leiterbahn dran. die nennste dann GNd 
und die verbindet eagle mit der Massefläche.

Autor: Emperor_L0ser (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,
eigentlich ist es ganz einfach:
Masse-Polynome erstellen, das Polynom mit "Name" in "GND" umbenennen.
Vias erstellen und jedem Via mit "Name" den Namen "GND" geben.

Was auch immer bei dir nicht funktioniert hat.

mfg Emperor_L0ser

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Holger Z. (atombombi)

>1. Ich kann allen VIAs nicht den gleichen Namen geben.

doch, das kann man. Und man MUSS es auch, wenn die an Masse angebunden 
werden sollen.

>das hinbekommen? Wenn ich "group" mach und dann "signal gnd" eingeb,
>dann kann ich die Vias nicht umbenennen.

Musst du einzeln machen. Mit NAME

>2. Ein Via kann ich in GND umbenennen. Nur wenn ich jetzt zu testzwecken
>das GND Polygon herum lege, dann entseht zwischen dem Via und dem
>Polygon keine Verbindung. Ich kann das spaciing nicht auf Null stellen.

Spacing ist vollkommen egal. ISOLATE, WIDTH und die Clearance im DRC 
sind entscheidend.

>Wie kann ich die Vias und das GND polygon miteinander verbinden?

Vias mit GND benennen.

>3. Kennt jemand ein gutes Tutorial, mit dem man Eagle Board Erstellen
>schnell bzw gut lernen kann? ich habe noch kein gefunden, was auf die
>Probleme eingeht.

Das Tutorial von Cadsoft ist recht gut. Man muss es halt mal lesen und 
durcharbeiten.

MFG
Falk

P S Die Wunderpille zum blitzartigen Lernen komplexer Dinge, wie z.B. 
Layoutprogramme, gibt es nicht.

Autor: madler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Am einfachsten geht das wenn Du es gleich beim Erstellen der vias so 
machst: in der Board-Ansicht in die Kommandozeile
via 'gnd'
eingeben, vias setzen, gluecklich sein :)

Autor: Klaus (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
madler schrieb:
> Am einfachsten geht das wenn Du es gleich beim Erstellen der vias so
> machst: in der Board-Ansicht in die Kommandozeile
> via 'gnd'
> eingeben, vias setzen, gluecklich sein :)

Voll korregt, alda! :-)

Autor: H.Joachim Seifert (crazyhorse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ansonsten (man braucht eigentlich immer viele davon :-)): Nachdem eins 
Gnd heisst, kann man auch den Copy-Befehl anwerfen und man setzt die 
dann dahin, wo man sie haben will.

Autor: Michael Sauron (Firma: www.das-labor.org) (laborsauron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oder folgendes in die Kommandozeile Tippen :
change name gnd
und dann einfach die vias nacheinander anklicken

wenn sie sich immer noch nicht mit dem polygon verbinden, dann klick mal 
auf ratsnest

Autor: H. X. (atombombi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielen Dank für die schnellen Antworten. Nur gibt es da ein Problem:


wie madler vorher gesagt hat, soll ich in die Kommandozeile

via 'gnd'

eingeben. Hab ich geamcht und danach die Vias auch über die 
Kommandozeile eingegeben. Wenn ich nun auf die Vias klick, dann haben 
die immer noch den Namen S$1...bis S$.. oder so. Wenn ich nachträglich 
die Namen ändere, dann verbindet Eagle die Vias mit Airwires. Und dass 
ist ja nicht Sinn und Zweck. Wenn ich nun das Polygon auf den Top layer 
zeichne und dieses mit GND benenne, dann sind immer noch Lücken/ 
Abstände zwischen den Vias und dem Polygon.

Setz ich die Vias per Hand, dann übernimmt jedes VIA brav den Name GND. 
Aber von Hand wollt ich die nicht setzten, da es zuviele sind und die 
genauen Maße eingehalten werden müssen.


Geb ich den Befehl von Michael Sauron

change name gnd

ein, dann bringt er mir die Fehlermeldung, dass es den Befehl Name nicht 
gibt.

Was mach ich falsch?

Autor: Aldo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Versuche es ohne "change", also so wie von Emperor_L0ser oben 
geschrieben:
name gnd
Dann der Reihe nach alle Vias durchklicken.

via 'gnd'
sollte aber normalerweise ebenso klappen...


Ich mache es meist so wie H.joachim Seifert (crazyhorse). Ein Via auf 
GND setzen und dann dieses immer wieder kopieren, wenn ein weiteres 
benötigt wird.

Autor: Michael Sauron (Firma: www.das-labor.org) (laborsauron)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Geb ich den Befehl von Michael Sauron
>change name gnd
>ein, dann bringt er mir die Fehlermeldung, dass es den Befehl Name nicht
>gibt.

Hab ich grad mal probiert, da bricht eagle wohl mit seinem eigenen 
Konzept
Gruppen von VIAS umzubenennen ist mir auch nicht gelungen

als würgarround kannst folgendes machen:
1)Tippe    name gnd
2)klicke das erste via an
3)DAs via wird nun unbenannt (erkennbar ist das leider nicht, wenn noch 
kein objekt den namen gnd hat)
4)Ruf den Letzten Befehl nochmal auf (Pfeil nach oben)(enter)
5)klicke das nächste via an
6)nun Fragt eagle , ob die Signale verbunden werden sollen. (enter)
7) gehe zu schritt 4

Autor: Kevin K. (nemon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
H. X. schrieb:
> dann verbindet Eagle die Vias mit Airwires. Und dass
> ist ja nicht Sinn und Zweck.

drück mal ratnets

Autor: H. X. (atombombi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also, erstmal vielen Dank für die Hilfe.

Das Problem bei der ganzen Sache mit VIA kopieren und neu einfügen ist, 
dass die Vias eine sehr genau Position einnehmen müssen und bei 80 Vias 
macht das einzelne Anklicken dann keinen Spass mehr.

Ich hab jetzt einfach die Grenzen vür die Abstände auf 0 gesetzt. So 
müsste nun GND mit dem Via verbunden sein. Zum Glück gibt es auf der 
Seite keine weiteren Signale. (Ist aber eiegtnlich keine geschickte 
Lösung)

eine Gruppe von Vias umbennen ist mir auch noch nicht gelungen. Falls 
ees jemanden gelungen ist, da würd ich mich um einen Tip freuen.

Danke nochmal

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.