mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Transistor Rechnungen klappen nicht :/


Autor: Steven B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Servus ihr,
gleich mal vorweg, ich bin noch nicht so lange am Elektronik-Basteln.

Ich hab mir hier gerade eine recht simple Schaltung aufgesteckt.
Eigentlich nur ne simple Emitterschaltung, in der ich einen Transistor 
als Schalter verwenden möchte. Dieser soll später mal vom Controller 
angesteuert werden.
Die Schaltung ist wirklich minimal, also Transistor, Basiswiderstand, 
und im Collectorzweig eben die LED und einen Vorwiderstand.
Die Basis wird von 5V angesteuert, die später mal vom Controller kommen, 
der Collector liegt an 9,2V (blöde Zahl, aber das Netzteil gibt genau 
soviel her).

Meine Rechnungen zur Dimensionierung:

9,2V - 2v (fallen an der LED ab) - 0,7 (fallen am Transistor ab) = 6,5V 
(die am Vorwiderstand übrig bleiben)

Die LED soll mit 30ma betrieben werden, macht also für den 
Vorwiderstand:

6,5V / 0,03A = 220ohm (ziemlich genau)

Ok, also hab ich nen 220er Widertsand verbaut.
Fehlt noch der Wert für den Basiswiderstand.

0,03A / 100 (sehr niedrig gewählter Wert für die Gleichstromverstärkung) 
= 0,3mA.

5V (Spannung vom Controller) / 0,3mA ~ 16kOhm

Kommt mir sehr sehr hoch vor?!

Hab jetzt 3,3k verbaut, also eh schon viiiieeelll niedriger.
Trotzdem messe ich eine Uce von 5,2V und am Vorwiderstand der LED hab 
ich nur 1,8V.

=> Der Transistor hat alles andere als gut durchgeschalten.

Und hier bin ich mit meinem Latein am Ende.
Wie gesagt, so viel Ahnung hab ich von Elektronik nicht, bin eher 
Programmierer. Aber die Artikel zum Transistor hab ich mir durchgelesen 
und auch Rechenbeispiele hier im Forum angeschaut.

Soll ich den Basiswiderstand noch mehr verkleinern? ABer ich bin ja eh 
scho weit unter dem errechneten Wert??
Vielleicht weis ja jemand weiter,
Danke,
Steve

: Verschoben durch Admin
Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steven B. schrieb:

> 9,2V - 2v (fallen an der LED ab)

Wo hast du die 2V her?

LED haben große Streuungen. Wenn du die 2V aus irgendeiner Literatur 
hast: So pauschal kann man das nicht sagen.


> Hab jetzt 3,3k verbaut, also eh schon viiiieeelll niedriger.
> Trotzdem messe ich eine Uce von 5,2V und am Vorwiderstand der LED hab
> ich nur 1,8V.

Aha.
Deine LED hat gar nicht 2V, sondern nur 1.8V

> => Der Transistor hat alles andere als gut durchgeschalten.

Doch hat er.
Aber du hast keine 2V Abfall an der LED sondern nur 1.8V

Rechne dir aus welchen Widerstand du brauchst, wenn du die LED direkt an 
deine 9.2V hängen willst (bei 30mA) und miss dort mal die Spannung über 
der LED nach. Da wirst du die 1.8V wiederfinden.

Autor: Steven B. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die 2V mess ich an der LED während sie leuchtet.

Aber selbst wenn nur 1,8V abfallen würden: die Spannung am R müsste doch 
viel höher sein.
Ich mein, wenn von 9,2V mehr als die hälfte noch an der CE-Strecke 
abfällt, sowas is doch ned richtig durchgeschalten? Wenn ich die 
CE-Strecke mal als Widerstand betrachte, der müsste bei Schalterbetrieb 
doch nahezu 0 werden (bischen was fällt natürlich immer an der Diode 
ab).

Und wieso folgerst du aus den 1,8V am Rvor dass meine LED nur 1,8V 
hätte?
Die Spannung am R muss doch nicht gleich der Spannung an der LED sein, 
ist doch ne Reihenschaltung. Die Spannung am R geteilt durch R gibt mir 
doch den Strom vor mit dem meine LED leuchtet, richtig?

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und du hast auch ganz sicher eine Emitterschaltung?
http://www.phyta.net/images2/emitterschaltung.gif

Autor: Luge (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja, emitter an masse, led und Rvor im collectorzweig.
Achja, sry vergessen, es handelt sich um nen bc337!

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt bin ich verwirrt.

Kanst du mal eine Zeichnung machen.
Was hast du wie verschaltet, welche Spannungen misst du wo?

Autor: hp-freund (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe mal verschiedene bc337 Datenblätter durchgesehen.
Der BC337 von Siemens/Infinion hat eine andere Anschlußfolge als die 
Anderen!
Kennst Du den Hersteller des Transistors?

http://www.datasheetcatalog.com/datasheets_pdf/B/C...

Autor: Peter Roth (gelb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Steven B. schrieb:

> Hab jetzt 3,3k verbaut, also eh schon viiiieeelll niedriger.
> Trotzdem messe ich eine Uce von 5,2V und am Vorwiderstand der LED hab
> ich nur 1,8V.

Du hast vielleicht Kollektor und Emitter vertauscht (Arbeitet wie ein 
Transistor, aber mit viel schlechterer Stromverstärkung)

Grüße, Peter

Autor: Michael U. (amiga)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Kollektor und Emitter vertauscht?

Gruß aus Berlin
Michael

Autor: faustian (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"Und du hast auch ganz sicher eine Emitterschaltung?"

Bevor sich jemand auf den Fuss getreten fuehlt: Die Begriffe 
"Emitterschaltung", "Emitterbasisschaltung", "Basisschaltung" und 
"Emitterfolger" sorgen gerne fuer viel Verwirrung....

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.