mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik STK500 + AVR-USB-JTAG USB JTAG


Autor: Andi Windi (nappy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

erst einmal Danke an alle die sich die Mühe machen diesen Beitrag zu 
lesen um mir weiter zu helfen.

Ich habe ein STK500 und weil ich keinen rs232 port an meinem laptop 
habe, habe ich noch zusätzlich diesen AVR-USB-JTAG
http://www.embeddedview.com/shop/product_info.php?...

Ich habe dafür auch die passenden Treiber und das AVR Studio 4 
installiert.

Leider schaffe ich es aber nicht das das AVR Studio das angesteckte 
Board findet.

Meine Vorgehensweise:

SPROG3 mit ISP6PIN verbunden
Laptop per USB mit dem AVR USB JTAG und diesen an ISP10PIN

AVR Studio auf das "AVR" Symbol geklickt.
Plattform: STK 500
Port: COM 4 (das ist er bei mir)

EDIT:

ich verwendet einen ATMEGA8515L der auf SCKT3000D3 eingesteckt ist.
Den Platz für diesen µC und die Verbindung von SPROG3 (passend zu 
SCKT3000D3) zu ISP6PIN habe ich dem STK 500 User Guide entnommen.

und auf Connect geklickt.

Leider findet er das Board nicht.

Ich habe gelesen das ISP10PIN zum Programmieren von externen AVRs 
gehört, jetzt bin ich mir nicht einmal sicher ob es mit meiner Hardware 
überhaupt funktioniert.

Vielen Dank im Vorraus

Autor: g457 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich das richtig sehe dann hat der m8515L kein JTAG, ergo wirst Du 
mit einem JTAG-Adapter nicht weit kommen.

Falls doch dann müsstest Du den JTAG-Adapter auf den JTAG-Header stecken 
(so vorhanden, im handbuch zum STK500 find ich nichtsdergleichen, ggf. 
richtig(tm) verkabeln). ..und wenn ichs dann noch richtig(tm) sehe, dann 
müsstest Du beim AvrStudio den 'JTAG ICE' einstell und nicht das 
STK500..

HTH

Autor: Andi Windi (nappy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke HTH für deine rasche Antwort.

Ich muss auch gar nicht debuggen können,
ich möchte vorerst einmal nur den µc beschreiben können.

Weiters war auch noch ein ATMEGA16 16PU 0625J dabei.
Sollte ich vielleicht diesen Probieren?

Hatte es auch schon mit JTAG ICE probiert, hat aber auch nicht 
funktioniert.

Autor: g457 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich muss auch gar nicht debuggen können

'JTAG' heisst nicht automatisch debuggen.. :-) Das kann (bei Chips, die 
es unterstützen) auch 'boundary scan' (da kommt der JTAG eigentlich her) 
und insbesondere 'in system programming' sein. Nur kann der m8515L 
soweit ich sehe gar nichts davon. Der m16 dagegen kann alle dreie. Jetzt 
musst Du nur noch rauspfriemeln, wo auf dem STK500 der TAP (das ist der 
'JTAG-Port') erreichbar ist, im Handbuch finde ich wie gesagt nichts 
dazu. Möglicherweise musst Du da ein paar Strippen ziehen.

Und dann ist der Adapter hoffentlich nicht beschädigt worden als er auf 
dem ISP-Header gesteckt hat.

Viel Erfolg!

Autor: Martin e. C. (eduardo)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
damit du mit dem STK500 über JTAG irgend ein Microcontroller 
programieren kannst, brauchst du ein Adapter der ist bzw. war im mein 
STK 500 dabei, siehe Bilder.

Gruß
Martin

Autor: visitor (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der JTAG Adapter muss nicht zwingend beim STK500 bei sein ! Ich habe 
zwei private und zwischenzeitlich auch schon 5 Stk500 Kits für die Firma 
bestellt und in keinem war dieser Adapter bei !!!
So einen Adapter habe ich nur beim JTAG ICE MK2 dabei gehabt !!!

Autor: Martin e. C. (eduardo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tja dann habe ich glück gehabt bei meinem STK500 war dabei :-)

Autor: Andi Windi (nappy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Über die rs232 schnittstelle meines alten pc's (den ich nicht mehr habe) 
habe ich den controller schon beschrieben.

Dh. für mich wird es wohl die einfachste Lösung sein wenn ich mir so 
einen
http://www.amazon.de/2direct-USB-Seriell-Adapter-K...
Adapter kaufe.

Das müsste dann doch funktionieren oder?

Autor: Amegon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht vom Bild her genau nach dem USB seriell adapter aus, de ncih von 
delock habe, und der klappt. Wenn du den mittlerweile geholt hast, achte 
nur darauf den unter systemsteuerung umszustellen auf eine niedrige com 
nummer, weil das avrstudio nur die ersten paar abfragt, wie es scheint.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.