mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATTiny13 EMV Schutz bei Servo-Ansteuerung


Autor: John Schmitz (student)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

habe einen ATTiny13 zur Servoansteuerung programmiert.

Funzt wunderbar, habe allerdings das Problem, dass bei schnellen 
Ausschlagswechseln (Vollausschläge) sich der ATTiny13 nach dem 4-ten 
oder 5-ten Mal aufhängt. Hänge ich den Servo ab und den Ausgang ans 
Scope habe ich keine Probleme, an der Programmierung liegt's nicht.

Ich habe ohne Rücksicht auf EMV den MC und das Servo parallel ans 5 Volt 
Labornetzgerät gehängt. Die Steuerleitung des Servos direkt an den PWM 
Pin des MC.

Da ich von EMV keine Ahnung habe, wo überall muss ich was an Vorsorge 
zur Entstörung treffen ? 100 nF zwischen VCC und GND am MC ist wohl nur 
der Anfang - oder ?

Danke im voraus.

Autor: nachtischgall (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ja. du kannst dir ja mal die versorgunngsspng ansehen. wird einbrechen, 
wenn der servo strom zieht. entsprechend pugffern!

Autor: Kluchscheißernder Nixwisser (kluchscheisser)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> sich der ATTiny13 nach dem 4-ten oder 5-ten Mal aufhängt.

Gegen "Aufhängen" hilft schonmal BOD. Das muss man allerdings auch 
einschalten.

> Ich habe ohne Rücksicht auf EMV den MC und das Servo parallel ans 5 Volt
> Labornetzgerät gehängt.

Dir wird, wie bereits genannt, die Versorgungsspannung einbrechen. Da 
könnte das Entkoppeln der Versorgungsspannung für den AVR helfen 
(Schottky-Diode in die Plus-Leitung zum AVR, Elko und Kerko nach GND).

> Die Steuerleitung des Servos direkt an den PWM Pin des MC.

Da hänge ich gern einen Widerstand von 1 k in Reihe.

Autor: Michael M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab jeweils ein LC aus 330Ohm ferrit und 1µF vor µC und servo. davor 
sitzt noch 1µF direkt zwischen den polen der versorgung.

Autor: Michael M. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nachtischgall schrieb:
> ja. du kannst dir ja mal die versorgunngsspng ansehen. wird einbrechen,
> wenn der servo strom zieht. entsprechend pugffern!
das ist kein gangbarer weg.
die versorgungen müssen entkoppelt sein.

Autor: John Schmitz (student)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Klasse Tips - Problem ist gelöst!

BOD 4,3 V eingeschaltet - Durchbruch - maßgebliche Verbesserung. Mag 
sein, dass er nun rebootet - merkt man aber nicht.

Nur noch ganz seltene Hänger als Resultat.

Dann beide Kondensatoren eingelötet und Versorgungsspannungen 
voneinander getrennt (d.h. schon gleiche Quelle - aber Zuleitung zum 
Servo als "Hauptleitung" und dann Abzweigung zum MC.

Seitdem kein einziger Ausfall.

Danke an Euch Alle.

Grüße

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.