mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik drehahlabhängiges Pfeifen(Brummen) im AutoLautsprecher


Autor: Julian R. (tuefftler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,
seit vier Tagen arbeite ich schon an unserem Auto. Eigentlich war die 
Aufga nichts großes, einen Verstärker an den alten Autoradio klemmen, 
Boxenkabel und Boxen installieren und fertig.

Leider funktioniert es dann doch nicht so ganz. Bei stehendem 
Motor(Lichtmaschiene) funkieoniert alles, sobald aber der Motor läuft, 
hört mann in den Boxen ein unerträgliches, drehzahlabhängiges Pfeifen.


     Am Verstäker, oder Spannungsversorgung des Verstärkers, kann es 
nicht liegen, da ich einen anderen(über 230V betriebenen aktiv 
Lautsprecher) schon angeklemmt hab und sich das gleiche Problem ergab.
     Mein Handy hab ich auch schon an den Verstärker angeschlossen, da 
konnte ich kein Pfeifen feststellen.
     Eine Massenschleife habe ich auch schon verhindert, doch da wurde 
das Pfeifen sogar noch schlimmer.


Mir fehlen die ideen, was ich noch machen könnte. Ach ja, die Kabel vom 
Radio zum Verstärker sind Koaxial Antennenkabel, doppelt geschirmt.

Über Ideen und Vorschläge wär ich erfreut.

Autor: Erba57 Ba (orfix) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo  Julian,

was hast du denn für ein auto, verstärker,radio...

vor deinen umbau war der radioempfang, mp3 wiedergabe ohne pfeifen?
ich würde mal sagen dein verstärker ist nicht EMV fest.

mfg orfix

Autor: Sascha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Julian,

das pfeifen wird wahrscheinlich nicht so simpel zu beseitigen sein da es 
sehr viele Ursachen haben kann.

Hier mal ein paar Vorschläge was Du prüfen kannst:

 - Benutze vom Radio zum Verstärker ordentliche Chinch-Kabel (würde ich 
als erstes machen da steckt vermutlich das größte Problem)
 - Für die Remoteleitung ein richtiges Kabel verwenden ca. 1,5 mm² -2,5 
mm²
 - Das Autoradio zusätzlich mit einem Kabel auf die Karosserie 
anschließen (Masse)
 - Nochmals alle kontakte der Masseleitungen überprüfen
 - Viele gehen auch noch hin und schließen das Radio am 
Verstärkerverteilerpunkt an und klemmen es vorne ab.
 - Entstörfilter fürs Radio einbauen

Viel Erfolg!

Sascha

Autor: Timon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wo haste denn die die Boxenkabel verlegt? wenn da viele Stromleitungen 
von der Boardspannung des Autos langgehen kann das auch schon zu 
störungen führen...

Gibt auch Kondensatoren die man direkt an die Lima anschließt um da vor 
ort schon nen Filter zu errichten aber vom hören sagen hat das bei 
vielen leuten eher nix gebracht...

Lg

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast eine Masseschleife. Die einfachste Lösung ist ein 
Audioübertrager, alles andere ist viel Aufwand.

Autor: MarioT (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das beste Du nimmst alle Masse Radio, Verstärker usw. von einem Punkt. 
Ist natürlich schwer möglich. Versuche mal die Signale potentialfrei zu 
übertragen. Weiß jetzt gar nicht ob es da was zu kaufen gibt.

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Ach ja, die Kabel vom
>Radio zum Verstärker sind Koaxial Antennenkabel, doppelt geschirmt.

Was für ein Bastelkram. Wo hast du den Verstärker angeschlossen?
Jetzt sag bitte nicht am Lautsprecherausgang vom Radio;)

Autor: Timon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Warum sollte man den verstärker nich am lautsprecherausgang des radios 
anschließen dürfen... nennt sich doch dann High-Input... Is halt für 
Radios die kein Chinch-ausgang haben...

wobei man das dann nich mit Koax-Kabel machen sollte...

Autor: Julian R. (tuefftler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ orfix

ich bin ein vierzehnjähriger Junge und bastle an dem Mercedes Vito 
meiner Eltern.
Der Radio nennt sich "Sound 4000" und Verstärker habe ich zwei Stück 
verbaut, einer mit 4 Kanälen 600W, der andere 300W mit 2 Kanälen eine 
für Center Bass deshalb ist nur ein Kanal genutzt.

@ Timon

Davon hab ich auch schon gehört, kann dem aber nicht ganz trauen.

@ mhh

kann man sich sowas selber baun oder sollte/muss man den Übertrager 
kaufen.

Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Prüf mal nach, ob an den CinchAusgängen von Deinem Radio überhaupt noch 
Masse anliegt!!!
Beim Basteln geht schnell mal die Masse vom Verstärker ab, der versorgt 
sich dann eben über die CinchAnschlüsse mit Masse und schwupps, sind die 
MasseVerbindungen im Radio durchgebrannt. Das stinkt nicht mal. Die 
einzigste Auswirkung ist ein tierisches Pfeiffen aus den Boxen wenn der 
Motor läuft, weil Dein CinchKabel ohne Abschirmung eine prima Antenne 
für allerlei Störungen ist.

Ansonsten, wie schon geschrieben: Cinch und Strom getrennt verlegen, 
gute Cinchkabel verwenden, und vor allen den Verstärker nicht direkt auf 
Blech schrauben, sondern lieber isolieren.

Sollte es ein geringes Pfeiffen sein, dann gibt es Filter die kann man 
vor die Endstufe ins Cinchkabel stecken. Aber bitte nicht in den 
Basskanal, sonst klingt der Bass matschig!!!

Viel Spaß beim entstören!

Autor: Julian R. (tuefftler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sry wegen den KoaxialKabel, ich dachte die wären gut geschirmt...

Autor: Timon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn der Basskanal schon mit low-pass filter betrieben wird sin die 
pfeifgeräuche eh meistens nich interessant... weil ein pfeifen denk ich 
mehr als 60 Hz hat und somit vom Filter eh weggeschnitten wird...

@Julian

so nen Übertrager kannste dir selber bauen... wobei ich bezweifle das 
das dann audiogerecht dimensioniert werden kann ohne sich ins geld zu 
stürzen...

versuchs erstma mit den sachen die oben schon geschrieben wurden... 
Kabel, Anschlüsse ect... die kleinsten dinge verursachen meist die 
größten probleme :)

Autor: holger (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>nennt sich doch dann High-Input... Is halt für
>Radios die kein Chinch-ausgang haben...

Wenn das Teil sowas hat is ja prima. Wenn das Radio eine
Brückenendstufe hat, würde ich den Schirm der Audioleitung
nur an Masse anschliessen und NICHT an den -Pol vom Lautsprecher-
Ausgang vom Radio.

Autor: meima (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

ich würde dir raten, die Kabel anständig und sauber zu verlegen.
Das Chinchkabel zum Amp möglichst weit vom Versorgungskabel der Endstufe 
verlegen.

Hat bei meinem Auto sehr gut funktioniert. Es ist besser die 
Fehlerquelle beim Verlegen schon so gut es geht zu eliminieren.
Ich hatte den selben Fehler, wie du beschrieben hast. Massefilter und 
Co. hab ich anfangs auch benutzt, brachten aber nichts.

Hab mich dann entschlossen, die Kabel vernüftig zu verlegen und das 
Brummen war weg.

Schau mal in diversen Car-Hifi Foren da gibts meistens gute Tipps auch 
zu den Automodellen.

mfG
meima

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Julian R. schrieb:
> kann man sich sowas selber baun oder sollte/muss man den Übertrager
> kaufen.

Gibt es zu kaufen, ich komme gerade nicht auf die Bezeichnung.

Ist auf jeden Fall die beste Lösung, denn die Massen der Geräte an einem 
Punkt zu vereinen erfordert sehr viel Aufwand: Autoradio ist im 
Normalfall über Antenne, Gehäuse und Stromkabel mit Masse verbunden. 
Verstärker über Stromversorgungskabel, Audioverbindung und ev. auch 
Karosserie durch das festschrauben.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Julian R. (tuefftler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ mhh
Ist ein Audioübertrager das selbe wie ein Entstörfilter???

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein. Da ist ein Audioübertrager drin und weil er diese Störungen 
verhindert, haben sie ihn halt auf den Namen Entstörfilter getauft.

Autor: Bernd Rüter (Firma: Promaxx.net) (bigwumpus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was die Verstärker an Strom ziehen, bewirkt wegen des Widerstands in 
Kupfer und Blech eine leichte Spannungsanhebung an dem Massepunkt, an 
dem das Autoradio angeschlossen ist (auch wenn der Strom vom Verstärker 
nur "vorbeifließt".). Genau dieser Spannungshub wird auch schön über den 
Audio-Ausgang an den Verstärker gereicht, der es prima verstärkt. Das 
Ergebnis hörst Du.

Früher (während des Studiums in der "Praxis"-Cafeteria) haben wir 
gesagt, daß der Verstärker (und am Besten auch das Radio) mit jeweils 
eigenen ordentlich dimensionierten Strippen und einer passenden 
Sicherung direkt an die Batterie geklemmt werden (jeweils Plus und 
Masse).
Das sollte helfen.
Ein Mantelstromfilter für die Antenne kann dann auch Wunder wirken.

Autor: Julian R. (tuefftler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Radio hat aber drei Möglichkeiten sich die +12V zu holen:

1. Klemme 30 Dauerplus
2. Klemme 15 Zündung ein, Stufe 2
3. Klemme 58 Instrumentenbeleuchtung

außerdem läuft natürlich noch Klemme 31 Masse zum Radio
Da man den Radio auch bei ausgeschalteter Zündung etreiben kann solte es 
doch folgendermaßen sein:

KL.15 ist nur Steuerspanung, dass wenn die Zündung abgeschaltet wird, 
der Radio auch ausgeht,
KL.58 nur für die Beleuchtung da ist, also den "eigentlichen" Radio 
nicht interressiert,
KL.30 dann das einzige Kabel ist das uns interessiert

=>KL.30 und 31 mit Verstärkerendstufe von einem Punkt aus zusammenlegen.

denke ich da falsch oder stimmt das so

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Julian R. schrieb:
> denke ich da falsch oder stimmt das so

Nicht das (+), sondern das (-) ist das Problem. Audiosignale sind 
meistens massebezogen. Bernd Rüter hat es verständlich beschrieben.

Autor: Julian R. (tuefftler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JA, aber wenn ich das mache solle ich doch den Plus auch gleich 
mitmachen,
oder würde das mit Minus(MASSE) auch reichen

@Bernd Rüter
Ich hab vom Radio über die Batterie und zum verstärker einen wiederstand 
von ca. 10 Ohm gemessen.

Autor: Tishima (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo!

Hatte benfalls mal so ein Problem und folgender Reichelt 
(Elektronikversender) mit der Bestellnummer KFZ NF-FILTER
hat geholfen. Kostet zur zeit 5,10 EU.
Kommt zwischen Autoradio und Verstaerker in die Chinchleitung.


mfg,
Bjoern

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Bernd Rüter
Nicht das ich jetzt viel davon verstehe.
Bis jetzt war ja nur von Masseproblemen die Rede. Aber mir leuchtet 
jetzt nicht wirklich ein, wieso man da dann die Lichtmaschine hört. Wie 
kommt die ins Spiel?

Autor: Julian R. (tuefftler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die LiMa schafft kleine Spannungsspitzen die verstärkt werden.

Autor: MCUA (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
LiMa ist ja Drehstrom-LiMa mit bestimmter f. Diese Wellen kann man halt 
u.U. aus dem DC "heraus" hören.

Autor: GGaasstt (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Karl heinz Buchegger:

Weil der Strom der Lichtmaschine über die Karosserie zur Batterie 
fließt, Spannungsabfälle verursacht und damit eine Potentialverschiebung 
zwischen Radio und Verstärker erzeugt?

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja schon.
Aber das hat ja dann erst mal nichts mit irgendwelchen Masseschleifen zu 
tun. Oder irre ich hier?

Ich möchte nämlich die allgemeine Aufmerksamket auf das Wörtchen 
'drehzahlabhängiges' in der Überschrift lenken. Davon war bisher noch 
überhaupt nicht die Rede.

(Und das interessiert mich besonders, denn nach einem Autoradiowechsel 
hör ich meine LiMa auch ganz schwach :-)

Autor: MCUA (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Weil der Strom der Lichtmaschine über die Karosserie zur Batterie
>fließt, Spannungsabfälle verursacht .......
Nein, deswegen muss es ja noch lange nicht pfeiffen.

Autor: Julian R. (tuefftler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Karl heinz Buchegger:

Dein Problem besteht darin dass die Lichtmaschiene, der Radio nicht 
richtig entsört ist, die Baterie alt ist, oder sowas

Autor: Bernd Rüter (Firma: Promaxx.net) (bigwumpus)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was haltet ihr denn davon:

Die Lichtmaschine erzeugt eine gepulste Gleichspannung 
(gleichgerichteter Drehstrom !). Dieser Gleichstrom (+) gelangt über ein 
dickes Kabel an den Pluspol der Batterie.
Die Masse der Lichtmaschine wird über das Metall des Motors und der 
Karosse und über ein dickes Kupferband an den Minuspol der Batterie 
geführt.
Jetzt fließt der pulsierende Gleichstrom von der Batterie zum Verstärker 
und über den Massepunkt und der Karosserie wieder zurück zum Kupferband 
der Batterie. Überall entstehen Spannungsabfälle !

Und irgendwo auf dieser "Spannungsspitzenwiese" klemmt man ein Autoradio 
an und irgenwo anders einen Verstärker. Und vergeßt nicht die Antenne !

Was kommt da für ein Salat raus ?

PS: Und für den "integrietärer M" (R.I.P.): Ja - ich plenke !
Unter welchen Stein wurde der eingentlich gestampft ? ;-)

Autor: Peter Diener (pdiener) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe dieses Pfeifen früher besonders bei CB-Funkgeräten gehabt. Das 
ist die Frequenz des gleichgerichteten Drehstroms aus der Lichtmaschine. 
Die Batterie hat einen Innenwiderstand, die Lichtmaschine liefert nach 
der Gleichrichtung immer noch einen erheblichen Stromrippel und dadurch 
ergibt sich ein Spannungsrippel im ganzen Netz, der je nach 
Batteriezustand bis zu einige 100 mV haben kann.

Dagegen hilft ein guter Spannungsregler, der schnell genug dafür ist.
Ich habe mal testweise einen 12 Volt LDO gebaut, der ist bei der am Auto 
vorhandenen Spannung eigentlich immer ausreichen im Eingriff. Damit kann 
man auch einwandfrei ältere Funkgeräte betreiben, die mit dem Rippel 
nicht klarkommen.

Grüße,

Peter

Autor: Julian R. (tuefftler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,
heute um 21.40 hab ich mein Projekt erfolgreich fertiggestellt. 
Wahrscheinlich fahren wir morgen nach Italien, mit einer SUPER Anlage.
Im Dateianhang seht ihr den ungefähren Schaltplan.

>Hallo!
>
>Hatte benfalls mal so ein Problem und folgender Reichelt
>(Elektronikversender) mit der Bestellnummer KFZ NF-FILTER
>hat geholfen. Kostet zur zeit 5,10 EU.
>Kommt zwischen Autoradio und Verstaerker in die Chinchleitung.
>
>
>mfg,
>Bjoern

Wie Bjoern auch hab ich mir so ein ding heute früh bei Conrad für 
unverschämte 17.95 geholt(Konnte nicht bei Reichelt bestellen da wir ja 
morgen fahren)

Die Koax-Kabel hab ich alle rausgeschmissen



ZUM SCHALTPLAN:
Der HochtonVerstärker(600W = 4 x 150W) steuert 4 Kanäle mit 4 Boxen
Der Bass Verstärker(300W = 2 x 150W) hat 2 Kanäle davon aber nur einer 
genutzt.

Wichtig beim Nachbau:
Die Verstärker haben eine Interne Frequenzweiche, das ist der Grund 
warum man beim Bass FAST nichts vom Pfeifen hört!!!

Bei fragen an Tuefftler2@web.de wenden/senden.

Autor: DasMicha (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ein hinweis noch, wenn ihr glücklichen urlauber wieder da sein, nimm den 
"spannungsteiler" oder stero->mono wandler bitte raus, deine endstufe 
hat 2 eingänge, nutze diese und brücke den ausgang, die meinsten 
verstärker können das...
schonmal gut das du mit 2x4,7k einen quasi mono-ausgang gemacht hast, 
nur leitet die stereo-kanaltrennung trotzdem drunter, und sowas sollte 
nur im äussersten notfall gemacht werden ...
einige verstärker können auch auf mono geschaltet werden, mit stereo 
eingang ...

Autor: soundmachine (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also hier nur nochmal so ne Aufstekkung auf wasman achten sollte beim 
Einbau einer CarHifi Anlage, dann erübrigen sich 99% der oben 
angegebenen Problemstellungen:

Endtsufe mit 2!! KAbeln von der Batterie her versorgen (ca 10mm²) bei 
Pluspol Glassicherung direkt hinter die Battreie. Beide Kabel dürfen, 
und sollen miteinander parallel verlegt werden (auslöschung von 
Magnetfeldern)
Das Cinchkabel gut geschirmt, hier nicht sparen, so WEIT WIE MÖGLICH, 
vom Stromkabel weg verlegen (andere Einstiegsseite z.B.) dabei nicht die 
häufig dran gepappte REMOTE leitung verwenden sondern eine eigene 
...1,5mm² genügt.

Damit sollte einigs aus der Welt geschafft sein. Nun kann es sein, dass 
die masse an der Endstufe und die Masse am Radio einen Ohmschen 
Widerstand gegeneinander haben. Dieser bewirkt bei einem Stromfluss 
(vorallem beim hohen Stromfluss der Endstufe) einen unterschiedlichen 
Spannungsfall. Man darf sich das so vorstellen: An der 
Batteriemasseklemme ist die Spannung definitiv 0V. An der Endstufe am 
Masseanschluss aber noch 1V, da das restliche volt über die Leitung zur 
Batteria abfällt. Am autoradio sinds 0,1V, da 0,1V auf dem Weg von radio 
zur Masseklemme der Batterie abfallen. so und jetzt kommt einer und 
steckt zwischen diese beiden Geräte eine Cinchleitung die ebenfalls bei 
beiden Geräten auf deren Masse gelegt ist.1V und 0,1 V werden 
miteinander verbunden-->Ergo: es fließt ein Strom über die Cichleitung 
un ddas hört sich Wiederlich an. Die Drehzahlabhängigkeit rührt dann 
einfach nur noch von höheren Frequenzen, denn die LIMA bringt ja keine 
100% Gleichspannung sondern eine Mischspannung die aus einem 
Gleichanteil besteht und darauf überlagert ein Wechselstromanteil (Meist 
rechteckförmig). Bei höherer Motordrehzahl = höhere Frequenz und höhere 
Spannung.
Wenn der Motor aus ist, dann ist der Strom der zwischen den beiden 
Potentialen (hier 0,1V und 1V fließt ein REINER Gleichstrom, da 
Batteriegespeist) dieser wird vom Verstärker erst garnicht in ein 
hörbares Signal umgewandelt, der Verstärkt ja nur ca 10Hz-20kHz, somit 
kommt das Problem hier nicht zum tragen. So ich hoffe ich konnte mal 
einen Überblick verschaffen wie sich die Sache aus meiner Sicht 
darstellt, Über Problemlösungen kann jetzt hier diskutiert werden, 
allerdings sollte bei Batterien immer vorsicht geboten sein, mal schnell 
was zu brücken oder 2 Massen zusamenzuschalten. Man sollte wissen was 
man tut.

MfG

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.