mikrocontroller.net

Forum: PC Hard- und Software Keymap nach Portierung einer XP-VM verändert


Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe eine virtuelle Maschine mit XP von einem System zum anderen 
kopiert. Es lauft auf beiden Systemen unter VMware Server 2.0

Auf dem neuen System habe ich plötzlich eine ganz komische 
Tastenbelegung.
Die Tastenreihe über der Leertaste produziert:

- => ß
_ => ?
. => .
: => Ö
, => ,
; => Ö
m => m
M => M
...
y => y
Y => Y
< => ,
> => :

Wie kann man das geradebiegen?

Ich habs mit den Locale-Einstellungen probiert - das ändert nichts.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Und was ist das Wirtssystem?

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ubuntu 10.04. Vorher war es auf 9.10. Beide sind englische Systeme.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Korrektur: Die VM lief vorher nicht unter 9.10, sondern unter 7.04

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da kann ich Dir leider nicht weiterhelfen, da ich diese Wirtssysteme 
nicht kenne.

So eine verquere Tastenzuordnung habe ich jedenfalls noch nie gesehen, 
das sieht aus, wie der Versuch, eine US-Tastatur in eine DE-Tastatur 
umzumodeln (jedenfalls die Belegung : -> Ö und - -> ß lässt darauf 
schließen).

Verry strange.

Autor: Andreas Ferber (aferber)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rufus t. Firefly schrieb:
> So eine verquere Tastenzuordnung habe ich jedenfalls noch nie gesehen,
> das sieht aus, wie der Versuch, eine US-Tastatur in eine DE-Tastatur
> umzumodeln (jedenfalls die Belegung : -> Ö und - -> ß lässt darauf
> schließen).

Nunja, im Prinzip passiert genau das. VMware steht vor einem Dilemma: 
vom X-Server erhält es Keysyms, das Gastsystem erwartet aber Scancodes 
von der emulierten Tastatur. Ergo müssen die Keysyms wieder in Scancodes 
zurückübersetzt werden, und offenbar benutzt VMware dazu bei Uhu das 
falsche Tastaturlayout (nämlich das Amerikanische).

Warum VMware allerdings nach dem Ubuntu-Update das falsche Layout 
benutzt kann ich auch nicht sagen.

Andreas

Autor: Nicolas S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ubuntu bereitet seit 8.irgendwas bei der Tastaturoption "no dead keys" 
insbesondere bei der deutschen Tastatur arge Probleme, z.B. ein "Aigu" 
wird einfach brutal durch ein Apostroph ersetzt- für mich besteht die 
"L"osung" darin, diese Akzente mit Copy-Paste aus alten Dokumenten zu 
holen.

Ob es bei der amerikanischen genauso ist? Wird die Option "no dead keys" 
genutzt?


Grüße
Nicolas

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zunächst mal vielen Dank für eure Beiträge.

Nicolas S. schrieb:
> Ob es bei der amerikanischen genauso ist? Wird die Option "no dead keys"
> genutzt?

Wo kann man die denn einstellen - außer bei der Systeminstallation?

Autor: Nicolas S. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei unter "System->Einstellungen->Tastatur". Bin aber auch nicht so der 
Linux-Experte, vielleicht gibt es eine viel tollere Möglichkeit über die 
Kommandozeile.

Grüße
Nicolas

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das habe ich probiert und nichts gefunden. Kann aber auch daran liegen, 
daß es da Massen von Optionen gibt, unter denen ich mir nicht sehr viel 
vorstellen kann.

"dead keys" habe ich dort nicht gefunden.

Autor: karadur (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

such mal nach man keymaps.

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, jetzt habe ich endlich die Stelle gefunden, wo die Dead Keys 
hingehören:

Man muß das Keyboard-Layout "Germany Eleminate dead keys" zufügen und 
nach oben schieben.

Der Unterschied zeigt sich im Texteditor bei der Akzent-Taste und bei ~ 
: die reagieren jetzt auf einen Tastendruck.

Die schlechte Nachricht: Die virtuelle Maschine merkt nichts davon und 
liefert denselben Mist, wie zuvor. Auch ein Systemboot hilft da nicht.

karadur schrieb:
> such mal nach man keymaps.

Das ist zwar interessant, aber da lasse ich lieber die Finger davon - 
hinterher funktioniert die Ubuntu-Tastatur auch nicht mehr...

Autor: Uhu Uhuhu (uhu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eine Neukonfuguration des VMware Servers hat auch nichts geändert.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.