mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Problem beim schreiben auf µC.


Autor: Dennis D. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich hab eine Frage, viele Themen gehn schon in die Richtung aber ich hab 
leider noch keine Antwort gefunden.

Hab mir bei Pollin das Evaluationsboard Ver 2.01 gekauft, zusammen mit 
einem Atmega32 16PU.

Jetzt ist mein Problem, dass PonyProg2000, bei der Übertragung eines 
Programms auf den µC immer folgende Fehlermeldung bringt: "Device 
missing or unknown device (-24)"

Diese Fehlermeldung kommt, obwohl beim Test der Interface Einstellungen 
"OK" kommt und genau so bei der Kalibrierung.
Habs auch schon mit nem ATtiny13 versucht, aber da sieht es genau gleich 
aus.

Die Platine hab ich schon überprüft, aber hab keine Brücken oder 
sonstiges gefunden...

Liegt es vielleicht am µC das man mit diesem vor der ersten Benutzung 
noch etwas machen muss.

Meine Programme schreibe ich mit AVR Studio 4, übertragen sollte es über 
den eingebauten Com2 meines PCs und ein serielles Kabel(Pinbelegung 1:1) 
werden.

Momentan weiß ich echt nicht mehr weiter, hoffentlich kann mir jemand 
helfen.


Vielen Dank schonmal ;)

Grüße
Dennis

Autor: Stefan B. (stefan) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ähnliche Probleme wurden schon in diesem Forum berichtet. In einigen 
Fällen hat eine penible Kontrolle der Hardware etwas gebracht. Die gute 
Nachricht dabei - die Kontrolle war mit etwas Anleitung bei den 
Messungen, einem Multimeter für Spannungs- und Widerstandsmessungen und 
Geduld erfolgreich.

Wenn du anfangen willst:

Nimm den µC bis auf weiteres aus der Fassung.

Dann kontrolliere die Signalwege der ISP Leitungen auf Durchgang und auf 
Isolation gegen andere Leitungen. Ein Fehlerfall war mal ein Fitzelchen 
Lötzinn als Kurzschluss an zwei Pins des ISP-Steckers.

Dann kontrolliere an der µC-Fassung, ob GND und Vcc sauber anliegen und 
ob RESET beim Programmierversuch (einfach grösseres HEX-File an die 
leere µC-Fassung senden) sauber von HIGH auf LOW gezogen wird.

Schreib, wie du gemessen hast (wo waren die Strippen des Multimeters) 
und was wurde beobachtet.

Statt Ponyprog kannst du auch AVRDUDE benutzen. Das kann mit dem 
Parameter -vvv mehr Debuginfos ausgeben. Eine harmlose Kommandozeile für 
AVRDUDE könnte in deinem Fall so aussehen:
avrdude -vvv -p atmega32 -c ponyser -P com2
(aus Pollin Funk-AVR-Evaluationsboard)

Die Debugausgabe kannst du in eine Datei umleiten 
(http://www.mikrocontroller.net/articles/AVRDUDE#Te...) 
und hier anhängen.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.