mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR32 Engineering Sample


Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Abend!,

Ich besitze das EVK KIT 1100 und versuche es gerade das erste mal zum 
Laufen zu bringen. Das ganze stellt sich aber als schwieriger heraus als 
gedacht. Auf dem Board ist ein UC3A0512ES. Nur wie wähle ich diese MCU 
aus? Es ist nur die "Nicht ES" Version in der Liste. Ich habe bereits 
den Tipp mit dem ES Framework bekommen, nur habe ich keine Ahnung wie 
ich dieses installieren soll.
Hoffe auf Antworten!

MfG Thomas

Autor: Zwölf Mal Acht (hacky)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die ES verhalten sich wie die nicht-ES, allenfalls ziehen die ES etwas 
mehr Strom wie geplant.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja das mag sein. Jedoch erhalte ich immer diese Fehlermedlung:

Detected part UC3A0512ES differs from specified part UC3A0512.

Es muss ja irgendwie möglich sein diesesn Chip auszuwählen. Vorallem 
weil er am EVK Kit sitzt.

Lg Thomas

Autor: Phil S. (zippi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

>Die ES verhalten sich wie die nicht-ES, allenfalls ziehen die ES etwas
>mehr Strom wie geplant.

Eh ne nicht ganz, wenn man Errata ansieht.

Du brauchst dafür eine Alte AVR32 Version, ich glaube AVR32 Studio 2.2 
oder älter.

Sonnst kannst du dir auch einen neuen Chip kaufen und den alten 
austauschen ;). Ist aber dann doch aufwendiger.

Gruß
Zippi

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hey! Ich hab das Problem gerade gelöst. Hab mich ein bisschen mit dem 
Update Manager beschäftigt und bin dann auf das UC3AES Software 
Framework gestossen das ich vorhin manuell heruntergealaden hatte. Der 
ES Chip funktioniert jetzt auch in der 2.5 Version.

Trotzdem Danke für alle Antworten!

MfG Thomas

Autor: Robert Teufel (robertteufel)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Thomas,

falls Du etwas ernsthaftes mit dem AVR32 machen moechtest, dann hol Dir 
doch einen neuen Chip und tausche ihn aus. Ansonsten kaemfst Du evtl. 
gegen Windmuehlen. Es tauchen immer wieder Chipfehler auf und nach einer 
Weile werden die Errata Sheets des ES mit weniger Prioritaet behandelt, 
schliesslich gibt es schon lange Produktionsware. Also wenn Du nicht im 
Laufe der Zeit tagelange Fehlersuche betreiben moechtest, dann nimm 
einen neuen Chip. Dieses Verhalten ist keineswegs Atmel oder AVR typisch 
sondern gebraeuchlich mit ES Bausteinen.

Robert

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.