mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik 5V Netzteil liefert mehr


Autor: Andreas Riegebauer (blackpuma)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Forum!

Ich hab mir ein kleine Netzteil gebaut für 5V. Ich hab allerdings das 
Problem das 6,8V Rauskommen. Im Anhang ist die Schaltung zu finden. Wenn 
ich den BU508 rausnehme habe ich meine 5V.

BG
Andreas

Autor: Johannes (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast Du mal versucht, das Netzteil zu belasten? Vielleicht braucht man 
eine gewisse Mindest-Last, damit die Regelung richtig funktioniert.

Autor: Raimund Rabe (corvuscorax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mach den R3 kleiner. Bei 33 Ohm lässt Du dem 7805 nur etwa 20mA. Sollte 
eigentlich reichen, aber man hat schon Pferde vor der Apotheke k... 
sehen. Ein weiteres Problem könnte durchaus auch die Verwendung des 
BU508 sein. Warum hast Du ausgerechnet einen HV-(TV-)Switcher genommen, 
mit dem nicht immer gut Kirschen essen ist, wenn es um analoge 
Regelungen (wie hier) geht. Er ist schnell und für 
Hochvolt-Schalteranwendungen optimiert. Such dir besser einen anderen im 
TO-126-Gehäuse (BD140) oder TO-220-Gehäuse (...) aus.
Übrigens: Hängt überhaupt irgendeine Last dran, die einen Strom zieht?! 
Die 1k5 (von R1) finde ich arg hochohmig für eine simple LED - ausser 
bei Low-Current-Typen.
Ansonsten hätte ich gesagt, dass der BU508 defekt ist. Schon mal seine 
B-E- bzw. B-C-Strecke (rein ohmsch) nach Kurzschlüssen überprüft?!

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auserdem ist der BU508 kein pnp, sondern ein npn Transistor. Wäre also 
solcher vollkommen fehl am Platze. Deswegen geht über seine B-C-Strecke 
(pn-Übergang) ziemlich ungehemmt die Eingangsspannung zum Ausgang.

Autor: Andreas Riegebauer (blackpuma)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK Also das würde natürlich so einiges erklären wenn das kein PNP ist. 
Dabei habe ich das extra kontrolliert. Denke es war schon spät am Abend.

Na dann werd ich mal einen PNP besorgen.

Danke euch allen.

Autor: byte (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für was soll D1 und D4 gut sein? D3 bräuchte man dan eigentlich auch 
nicht wenn D1 drin ist. Das mit D4 ist ehrlich gesagt auch ziemlich 
unschön und ungenau. Da müste noch ein widerstand ran damit ein 
einigermaßen konstanter Strom durch die Diode fliest.

Für was soll denn das Netzteil sein?

Autor: Andreas Riegebauer (blackpuma)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es soll einfach ein Netzteil mit konstanten 5V sein mit bis zu 4A.

Die Dioden habe ich eingebaut um zB. 2 oder mehr parallelschalten kann 
ohne das Strom in ein Netzteil fließt fals dieses Ausgeschaltet ist.

Der große Widerstand ist ansich für eine lowCurrten LED gedacht. Aber 
ich habe jetzt eine normale verwendet. Somit hab ich schon mal eine 
Grundlast von 15mA.

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Es soll einfach ein Netzteil mit konstanten 5V sein mit bis zu 4A.

>Die Dioden habe ich eingebaut um zB. 2 oder mehr parallelschalten kann
>ohne das Strom in ein Netzteil fließt fals dieses Ausgeschaltet ist.

Eben deswegen wird es aber nicht mehr besonders genau sein, denn die 
Flußspannung einer Diode kann schon recht extrem schwanken, wenn die die 
Breite von 0A-4A mitmachen sollen. Aber als Ungefähr-Konstanter mag es 
noch gehen, wenn dir die paar 100mV Ungenauigkeiten nicht stören.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Na dann werd ich mal einen PNP besorgen.

Besser nicht, denn die Schaltung ist sowieso kompletter Schwachsinn.

Warum Leute auch niemals vorher Informationen lesen, sondern immer so 
was halbgares produzieren.

http://www.dse-faq.elektronik-kompendium.de/dse-faq.htm#F.9


Die 6V von deinem Trafo sind selbst ohne die unglückliche Konstruktion 
mit dem externen Transistor, durch die Kurzschlussschutz, 
Übertemperaturschutz und SOA Schutz des 7805 aufgehoben wird damit man 
ein möglichst betriebsunsicheres Netzteil bauen kann, zu wenig.

Deine angegebenen 8.64V sind kompletter Humbug.

Erstens wäre 6 * 1.414 = 8.48, also schon mal falsch vom Taschenrechner 
abgeschrieben.

Zweitens haben Brückengleichrichterdioden auch Verluste, und zwar ca. 1V 
pro Diode im Strossstrombetrieb, also bleben nur 6.64V.

Und dann ist da ein Siebelko, der die Spannung von der einen Halbwelle 
bis zur anderen puffern soll, und deine vollkommen lächerlicher 1000uF 
Elko würde schon bei 1A um satte 10V pro 1/100sec einsacken, also um 
mehr als überhaupt vorhanden sind. Aber bei 1A müsstest du einen 7805 
noch nicht mit einem externen Transistor verstärken, du willst also 
offenkundig mehr ziehen.

Zudem sollte ein Netzteil nicht nur bei 230V funktionieren, sondern auch 
bei 10% Netzunterspannung.

Rechne also eher mit einem 11V Trafo und einem 22000 uF Elko wenn deine 
Konstruktion irgendeinen Sinn machen soll.

11V (Trafospannung)
*0.9 (10% Netzunterspannung)
*1.414 (Spitzenspannung)
-2V (Brückengleichrichter)
*0.8 (üblicher Siebelko-Ripple)
-0.7V (Verlust externe Transistor)
-2.5V (Spannungsbedarf 7805)
-0.5V (Ausgangs-Schottkydiode)

müssen immer noch 5V ergeben, wenn der Murks auch nur ansatzweise 
funktionieren soll (über die 1N4148 und die Schottkys sollte man auch 
noch mal nachdenken, die sind in der Form auch eher Unfug).

Autor: Andreas Riegebauer (blackpuma)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe jetzt die Schottkys rausgeschmissen, den Kondensator vergrößert 
und einen neuen Trafo mit 9VAC.

Jetzt funktioniert es soweit ganz gut auch wenn ich das Netzteil mit 
3,5A belaste. Was jetzt allerdings passiert ist das die Ausgangsspannung 
auf 5,5VDC steigt. Wie kann das sein?

BG
Andreas

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wann steigt die Spannung auf 5,5V? Unter welchen Lastbedingungen. Unter 
welchen Lastbedingungen ist die Spannung ok?
Wie schon gesagt, bei null Last steigt die Spannung über Gebühr.

Autor: Andreas Riegebauer (blackpuma)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn als Last nur die LED dranhängt dann passt es. Wenn ich einen 
Widerstand mit 1,5 Ohm dranhänge dann fließen ca. 3,5A und dann steigt 
die Ausgangsspannung auf 5,5V an.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Was jetzt allerdings passiert ist das die Ausgangsspannung
> auf 5,5VDC steigt

Deine Schaltung ist nach wie vor mit dem BU508 NPN komplett
falsch und die 1N4148 eher witzlos.

Und auch richtige Transistoren hätten Leckströme,
so daß es ohne Mindestlast (weniger als 1mA reicht schon)
nicht geht.

Kauf dir einfach einen rcihtigen Spannungsregler, der deine 4A
auch locker schafft, wie ein LT1084-5 und alles ist gut,
ganz ohne Krampfschaltung.

Der würde sogar, wenn er zu heiss wird weil du vergessen hast
ihn auf einen Kühlkörper zu schrauben, auch einfach abschalten,
und ncht die volle Spannung durchlassen wie ein durchlegierter
externer Transistor der dann deine ganze Schaltung grillt.

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andreas Riegebauer schrieb:
> Wenn als Last nur die LED dranhängt dann passt es. Wenn ich einen
> Widerstand mit 1,5 Ohm dranhänge dann fließen ca. 3,5A und dann steigt
> die Ausgangsspannung auf 5,5V an.

Den Längstransistor durch einen PNP ersetzen (BU508 ist npn), den 10 Ohm 
Widerstand verkleinern auf 2,2 Ohm, dann wird das was.


BTW: Der Trafo ist mit 9V AC spannungsmäßig zu knapp am unteren Limit 
dimensioniert.

Autor: Andreas Riegebauer (blackpuma)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den Transistor habe ich schon durch einen BD246 ersetzt.

Wieso ist der 9V Trafo noch am unteren Limit? Ich habe an C1 eine 
Spannung von 11 Volt und möchte 5V rausbekommen. Das muss doch reichen.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wieso ist der 9V Trafo noch am unteren Limit?


Es wurde oben ausführlich vorgerechnet,
lesen musst du schon selber.

Zudem hast du von 1000uF nur auf 10000uF erhöht
und nicht den vorgeschlagenen 22000uF, also
müsstest du noch mal neu rechnen.

9V sind ok für einen LT1084.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.