mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Hilfe beim inverter reparieren (Unbekannter IC deffekt)


Autor: Trax Xavier (trax)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Habe vom ITler meines Instituts ein vermeintlich defekten 23" TFT 
bekommen, aufgeschraubt, heruntergespielt...
aha! Inverser schlisst Netzteil kurz... abgetrennt, PW_LED leuchtet... 
Bild da SUPER! nur kein Blacklist weniger super.

Weiter herum gesucht, Ergebnis 1 IC ist tod: 4620 BA841H steht drauf,
Google kennt den nicht.
Das ist der am Bild im anhand der da oben herumliegt und wo etwas weiter 
unten ein freier platz ist, daneben befindet sich im übrigen ein 
baugleicher,
so wie es aussieht sind das die Schalter die den Trafo vom Inverter 
versorgen.

Nun meine frage:
Weiß einer was das für ein IC sein kann und vor allem was man als Ersatz 
benutzen kann?

Danke schon mal im voraus

LG
Trax

Autor: iovi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das ist kein ic, das kann eig nur ein transistor sein.
was steht denn auf dem transistor rechts neben dem ausgelötet?

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Q805 - das ist ein (Mosfet-)Transistor, kein IC.

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also der hat etwas viele pins für einen transistor,
oben 4 ausgang,
unten ganz links ground dan irgendwas, dan die versorgungs spannung und 
wieder irgendwas.
Das wären 5 anschlusse.

ok, transistor, aber was amchen die überschüssigen 2, oder ist das so 
ein 2 transistoren in einem package teil?
da bleibt die frage der pinbelegung noch offen.


>was steht denn auf dem transistor rechts neben dem ausgelötet?
4620 BA841H

Autor: iovi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: iovi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
http://www.aosmd.com/pdfs/marking/AO4620.pdf
hier noch ein pdf zum marking. passt das?

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
iovi schrieb:
> http://www.aosmd.com/pdfs/datasheet/AO4620.pdf

Super!

Jetzt brauch eich nur nen höndler der sowas nach AT liefert

Autor: iovi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Ingo W. (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, Zusammen!
Habe hier grad einen ähnlichen Patienten auf dem Tisch, gleiches PCB, 
andere Bestückung. Ob hier auch ein Transi vom CFL-Konverter  die 
Fehlerursache ist, werd ich berichten. Hab extra die Bildauflösung 
gelassen, damit man gut lesen kann, sorry, wegen der Dateigröße.
mfg ingo

Autor: Ersatztyp (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
AO4620 -> FDS8962C von Fairchild

Autor: iovi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der linke transistor scheint vom oberen rechten pad her aufgeplatzt.
oder ist das nur dreck?
FDS8958
liefert dir http://www.hbe-shop.de

Autor: Ingo W. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also bei mir ist der CFL-Konverter in Ordnung.
Die
>> AO4620 -> FDS8962C von Fairchild (Gast)
scheinen also etwas stabiler zu sein, werden etwas mehr als handwarm.
Der hier muss irgendeinen thermischen Fehler haben, denn jetzt, 
auseinandergebaut auf dem Tisch läuft er. Das Körnchen auf dem linken 
Doppeltransisror muss ein Flussmittelrest gewesen sein.
mfG ingo

Autor: iovi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie sehen denn die kondensatoren aus? dicke bäuche?

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da wir gerade beim thema inverter sind

Ich habe da noch einen anderen da ist das backlight auch weg, aber man 
sieht keine schäden.
da kommen 3 steuer leitungen hin, on/off DIM_A Dim_B
Was für ein signall ist da normalerweise auf dimm drauf?

ad DIMM
Was das macht kann ich mir shcon vorstellen, also dimmen.
und das das wohl ein PWN ist weis ich auch.

Aber was ist da üblich wen man die offen/gnd hat voll Hell oder voll 
dunken?


PS:noch eine frage:
wieso gegen bei den neuen TFT's zu jeder seite der CFL auser dem dicken 
HV kabel noch so ein dünnes?
wozu ist das gut?

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
push

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe so ein AO4620 organisieren können, leide ist er recht schnell 
abgeraucht.
Ist wohl mehr defekt, als nur der eine mosfet

Könnte mir jemand ein tipp geben wie ich da jetet weiter vorgehen 
sollte?
ich würde gerne das teil wieder zum laufen bekommen

Autor: hans (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm einen stärkeren mosfet in einem großen gehäuse der schaft es

Autor: Magnus M. (magnetus) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Trax Xavier schrieb:
> Ich habe so ein AO4620 organisieren können, leide ist er recht schnell
> abgeraucht.

hans schrieb:
> Nimm einen stärkeren mosfet in einem großen gehäuse der schaft es

@hans:   Scherzkeks!

Miss mal sämtliche Halbleiter (Transistoren, Dioden) und Kondensatoren 
durch. Irgendwas muss wohl nen Schluss haben.

Gruß,
Magnetus

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
also fals was deffekt ist wäre es der haupt IC, da ist sonst nciht viel 
da und es scheint ok zu sein.

Wo kann man so ein ta9687-a-0-tr chip herbekommen, dazu finde ich 
momentan nciht mal eind atasheat.

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier ist ein manual mit vom meinem inverter:
http://202.103.212.155/upload/2009_08/09083111385458.pdf

Autor: Magnus M. (magnetus) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Trax Xavier schrieb:
> also fals was deffekt ist wäre es der haupt IC, da ist sonst nciht viel
> da und es scheint ok zu sein.

Wie hast du festgestellt dass alles ausser dem "haupt IC" intakt ist?

Auf Seite 48 des Servicemanuals ist der ursprünglich (und jetzt wieder) 
defekte Q805. Dieser wiederum bildet eine Vollbrücke mit Q806. Hast du 
mal Q806 auf Kurzschluss (Pins 5,6,7 und 8 gegen Pins 1 und 3) gemessen?

Gruß,
Magnetus

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja habe den Q806 auch durch gemessen, vor dem Reparatur versuch war der 
noch in tackt.
Danach waren beide der Q806 und der neue Q805 geschossen.

Ich habe da manual auf seite 36 befolgt, und
der ta9687-a-0-tr chip gibt auf pin 10 kein signal aus.

zudem weis ich nicht was ich von "Check IC801 PIN5 have triangle wave" 
halten soll da laut dem Schaltplan in 5 auf GND liegt :/

k.A. wie die PWM Signale da genau ausschauen mein altes oszi  (is so ein 
altes analoges) konnte das nicht auflösen, aber wen es an war sah man 
eine dopple Linie.

Der chip schaltet sicha uch immer mach 3 sec oder so ab, liegt aber wohl 
daran das da letzt keien mosfets drin sind und der am VSEN nichts sieht, 
oder so.

Also ein signal liegt an an pin s:
9 NDR1
8 NDR2
6 PDR2

und an pin 10 PDR1 fehlt es.

kann ich irgendwie einfach aus den3 oberen das fehlende ableiten, evl 
eines davon invertieren?

Oder wo kan ich so ein steuer IC bekommen, googeln nach ta9687 bringt 
nichts brauchbares.
Alternativ halt das genze board, muss es ja auch einzeln zu bekommen 
geben.

Autor: Tino N. (tino)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich bezweifel dass dieses IC defekt ist.
Aus Erfahrung mit Invertern weiß ich dass die Trafos meist einen Schluss 
haben.
Man kann das natürlich schlecht messen.
Ich wechsel immer beide MOSFETs und den Trafo. Von ungefähr wird der 
Schaden am MOSFET nicht kommen.
Die gehen nur kaputt weil zu viel Leistung drüber läuft.
Dass passiert eigentlich nur bei defektem Trafo oder defekten Lampen.

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tino N. schrieb:
> Ich bezweifel dass dieses IC defekt ist.
Wieso gibt es dann kein PWN Signal auf der Leitung?
Glaubst Du es ist unnötig?
Ich hätte gedacht, das der ausganz bzgl der 4 outputs zumindest 
symetrsich sein müste, also entweder es laufen alle 4 oder 2 davon aber 
doch nicht 3?

PS: IC datasheat: 
http://wenku.baidu.com/view/25c9444de518964bcf847c2e.html

Autor: Tino N. (tino)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist nicht so ganz einfach zu beantworten.
Das PWM Signal sollte nach dem Einschalten ganz kurz da sein.
Ob das messbar ist mir einem analogen Oszi, entzieht sich meiner 
Kenntnis.
Zündet die Röhre nicht richtig, schaltet das IC die PWM aus. Das ist 
aber kein Grund wieso der MOSFET dir um die Ohren fliegt.
Keine PWM = keine Ansteuerung der MOSFETs und somit auch kein Strom der 
diese zerstören kann.
Ich tippe ja immernoch auf den Trafo.

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der IC scheint das PWM nach ~3 sec auszuschalten auf den übrigen 3 
Leitungen.
auf der 1nen ist es wie gesagt immer aus.

Ich schau mir das morgen am Institut, mit nem richtigen oszi an. denke 
aber das bringt das selbe Ergebnis.

Was für einen widerstand sollte den so ein Trafo haben?
da ein Ersatz zu finden wird wohl auch nicht ganz leicht.
Hast Du da eine gute quelle zum empfehlen?

Was wäre sonst der nächste schritt um das Problem zu lösen?

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Trax Xavier schrieb:
> Was wäre sonst der nächste schritt um das Problem zu lösen?
Mach mal ein ordentliches Foto von Vorder- und Rückseite.

Ich bezweifle übrigens stark, dass ein Übertrager hin ist. Eher noch die 
Reversdioden, die den FET vor negativer Spannung schützen.

P.S.: Schenk lieber mir den Monitor =)

Autor: Trax Xavier (trax)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
2 bilder, vorder und rück seite.

Die Reversdioden sind in den MOSFET chips drin laut datasheat.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mindestens eine Röhre könnte defekt sein und zuviel Strom ziehen. 
Dadurch wird die Ansteuerung warscheinlich überlastet. Einen Trafo für 4 
Röhren zu verwenden ist seitens des Herstellers recht "sportlich" und 
damit fehleranfällig.

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da schaut eigentlich alles bis auf die Netzeingangsfilterdrossel i.O. 
aus.
Die Dioden sind die großen TO220-Bauteile auf den Kühlblechen. Die 
kannst du ja mal durchmessen, vielleicht hat es da doch eine erwischt.

Ansonsten würde ich auch auf eine defekte Röhre tippen. Läuft der 
Inverter denn, wenn du anstatt den Röhren nur 1MOhm (auf 
Spannungsfestigkeit achten!) anschließt?

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann ich irgendwie die röhren testen?

Der inverter läuft derweil gar nicht da mir neue mosfets fehlen.

hätte noch nen kleien inverter von nem lapi für eine röhre, da past der 
HV stecker

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Trax Xavier schrieb:
> Kann ich irgendwie die röhren testen?

Kauf Dir sowas:

http://www.reichelt.de/?;ACTION=3;LA=444;GROUP=EA3...

oder:

http://www.reichelt.de/?;ACTION=3;LA=444;GROUP=EA3...

Damit kannst Du Röhren testen.

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also sowas habe ich aus einpaar zerlgeten scannern,
Du meinst Also wen jede der 4 röhren nach anschließen leuchten, dan sind 
alle 4 in Ordnung?

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn sie weiß leuchten, dann i.A. ja. Leuchten sie rötlich oder gar 
nicht - defekt.

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also die röhren röhren, em... leuchten.
Alle 4e die 2 oberen scheinen jeweils de tft fast ganz auszuleuchten, 
die 2 unteren nur teilweise.

im prinzip könnte ich das teil nur mit iener röre und nem notebook 
inverter betreiben.
Würde aber dan doch gerne eher das problem lösen und es richtig 
reparieren.

@Michael H.
Alle dioden an kühlkörpern sind teile des netzteils und nciht des 
inverter.
Oder meinst Du ich solle prüfen ob das netzteuil keine negativen 
spannungen liefert?

PS:
Wie leicht wäre es den IC den ich für deffekt halte zu ersätzen?
Also ich meine wen man kein passenden ersatz hat, also selber eine 
shcaltung bauen die den trafo treibt.

Autor: Trax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also laut den guten digital oszi (1GS) ist wirklich der steuer IC 
deffekt.

NDR2 ist High wen PDR2 High Ist
NDR1 ist inverteirt zu NDR2

und PDR1 ist immer (!) auf 0

Das heist das ein mosfer imemr + und - gleichzeitig schaltet und ein 
krzschluss macht,
es sind also beide PDR1 und PDR2 Ausgänge defekt.

Ich denke was ich jetzt machen kan ist PDR1 und PDR2 abklemmen und NDR1, 
NDR2 über kreuzt anschließen.

Was meint Ihr dazu?

Autor: Trax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
???
kiner nen tip?

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich denke, dass du den gegentaktwandler nicht verstanden hast.

Autor: Trax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Naja, wen der eine mosfet chip die eine seite des trafo auf +12 sätzt 
muss der andere mosfet chip die andere trafo seite aud 0 sätzen und vice 
versa.

Und was nie passieren darf ist das meide mostfets 1es chips gleichzeitig 
durchschalten, den dan wird das netzteil kurzgeschlossen. <- das macht 
der conroll IC momentean.

Oder bin ich da geraqde voll danaban?

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
du vergisst aber, dass zwischen der versorgung noch die spule sitzt.
die wird also nur ganz normal bestromt.

Autor: Trax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also das ist so aufgebaut
eine GND und eine strom leitung geht zu jeweils einem MOSFET in einem 
chip.
Der ausgang des chips ist angeschlossen an eine seite des trafos.
mehr spulen außer der im Trafo gibt es nicht.

Was doch nicht sein darf ist das ein mostfet gleichzeitig 12 und GND auf 
ien trafo eingang legt, das ist ja ein kurzschluss, oder?

Autor: Trax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Falls ich da gerade auf dem holtzweg bin, bitte erleuchtet mich.

Autor: Trax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
für tipps wäre ich sehr dankbahr

Autor: Trax Xavier (trax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
push!

Autor: Trax (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Laut der Beschreibung eines Gegentaktwandler: 
http://members.fortunecity.com/furzen/smps2/Vgw_hilfe.html
sollte das so funktionieren wie in der 2 skitzen in der angehängten 
zeichung,
tut es aber nciht, der chip macht laut nem tektronix oszi das was in den 
unteren beiden skitzen angezeigt.
Also einen Kurzschluss.

Die frage ist jetzt ob ich das repareiren kann:
z.B. indem ich die 2 NDR Ausgänge über
kreuzt an die von den PDR's gesteuerten Mosfets anschließen und somit
die kaputten Ausgänge übergehen?
Wie in Inverter_fix.png beschrieben?

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn in dem Steuer-IC was defekt ist - wechsle ihn. Durch Überlastung 
entstandene teildefekte ICs neigen zum Totalausfall.

Stecke Deine Energie in eine richtige Reparatur, oder in die Suche nach 
einem Ersatzinverter.

Autor: Trax (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Den IC zu ersätzen wäre mir auhc am liebsten, das ist so ein TA9687:
http://wenku.baidu.com/view/25c9444de518964bcf847c2e.html
Leider konnte ich bis dato keinen Zulieferer finden der den hätte.

Wen einer hier wies wo ich so ein Chip bekommen könnte, wäre das 
wirklich super.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.