mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Siemens ST60 - AT-Befehle


Autor: mikrotomobile (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen;

Frank Wolf schrieb:
> Folgende Handys gehen unter anderen Vorausetzungen:
> C62 (nicht mit 19200), ST55, ST60 (anderes Datenkabel)

Könnt ihr, oder kannst Du selbst, falls Du es liest, mir sagen, was du 
mit einem anderen Datenkabel meinst? Habe im Netz schon unterschiedliche 
Pin-Outs gefunden, aber beide funktionieren suboptimal...
Ein original Datenkabel besitze ich leider nicht.

Das Verhalten des Handys ist sehr skuril momentan:
Manchmal bekomme ich auf einen At-Befehl ein Echo, macnhmal einfach nur 
Müll, manchmal bekomme ich gar keine Antwort. Das scheint mir ein 
Problem mit der Baud-Rate zu sein, nur habe ich auch dies bzgl. schon 
viele getestet.

Mit anderen Handy klappt alles, also am Terminal kann es nicht liegen 
(möchte später auf µC umsteigen, aber im Moment teste ich ersteinmal 
noch mit Terminal Programm und Max232)

Danke für Eure Hilfe!

Autor: \0 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo mikrotomobile!
Das S60 kenn ich jetzt nicht, hat das den alten Lumberg oder schon den 
"neuen" Lumberg-Stecker?
Meine Beobachtungen zu Siemens Handys:

Das S65 ließ sich mit einem Billig-Datenkabel erstmal überhaupt nicht 
ansprechen.
Beim M45, welches den neuen Stecker besitzt ist es manchmal möglich 
gewesen, mit dem Billigkabel auf das Telefon zuzugreifen, manchmal 
jedoch nicht.

Nachdem ich in den Stecker (weiß nicht mehr an welchen Pins) zwei 10kΩ 
Widerstände eingelötet habe, haben beide immer ohne murren geantwortet. 
Siemens hat da wohl eine Art Zubehörerkennung mit realisiert.
Vllt finde ich den Kram irgendwo.
\0

Autor: \0 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: mikrotomobile (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke \0 für den Link und die Antwort.

Leider scheint es sich um beide dieser Stecker nicht zu handeln, habe 
diese Stecker zwar auch an anderen Siemens Telefonen, aber diese passen 
leider nicht.

Hinzu kommt das die in dem Link angegebenen Pin absolut nicht passen, V+ 
und GND liegen auf meinem Stecker quasi links und rechts, also 1-3 GND 
und 13-15 V+ ... in den Lumber Steckern scheinen die beiden Leitungen 
nebeneinander geführt zu werden (was auch für die meisten Siemens 
Ladegeräte zutrifft.)

(Ladegerät vom ST60 bestätigt aber diese seltsame Belegung des ST60)

Hat noch jemand einen Tip für mich?

Es scheinen ja Daten zu kommen, nur völliger Mist eben...

Autor: mikrotomobile (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hab noch mal eben getestet... ein Ring z.b. kommt an aufm Terminal... es 
wird nur nicht AT-Befehle geantwortet :(

Autor: \0 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also was auf jeden fall geht, ist ATDT <Rufnummer>(Anrufen) und ATH(Hang 
up).
HAbe mit dem s65 gerade eben das festnetztelefon bei mir daheim klingeln 
lassen :D
\0

Autor: mikrotomobile (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast Recht... ATDT <nummer> geht, das geht bei mir auch.
Aber ATH nicht... Ich hätte es aber ehrlich gesagt für diese beiden 
Sachen auch mit ATD (ohne ein zweites T) und mit AT+CHUP probiert.

Welcher Liste entstammen deine Befehle? Nicht Nobbi.com?

Autor: \0 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gab da zwei verschiedene Steckverbinder. Auf der oben von mir 
Verlinkten Seite 
http://www.multihandyhacking.de/board/view.php?pg=... 
beschreiben die Leute doch auch beide Datenkabletypen/Steckverbinder.
Des Rätsels Lösung ist: Beide Steckverbinder sind von Lumberg, jedoch 
gibts da zwei Versionen.

Am ST60 ist, wie es mir scheint, die alte Version verbaut. bei der 
braucht man kein Gefummel mit den Widerständen.
Hier am S65 funktionieren die Statusbefehle für Lautstärke usw nicht. 
Man kann im Prinzip nur wählen, Daten schicken, Daten bekommen und 
auflegen. Das ergibt aber einen Sinn insofern, dass die Daten sowieso 
digital über die GSM-Verbindung gehen.
\0

Autor: \0 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: \0 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So mal die ganze Liste abgeklappert, alles was nicht geht sind die 
ATS<ziffer> Sachen. Kommentare hab ich mit //<Kommentar> eingefügt, 
sowie meine Telefonnummer ge-gartenzaun-t:
//Testanruf auf das Handy
RING

RING
//Es klingelt, heben wir mal ab
ATA

OK
ATH0

OK
//wieder Aufgelegt, jetz ein Testanruf vom Handy nach Festnetz
ATDT 0049#########

NO CARRIER
//Klar, da mein Festnetzanschluss keine Daten annimmt.
//evtl müsste ich GPRS mal anschalten, mal sehen was dann geht
ATH0

OK
//lokales Echo ausschalten, ein Befehl mit Zahl
//und man lässt die weg, wird als <Befehl>0 gewertet 
ATE

OK
//hier habe ich blind "ATE1<Enter>" geschrieben 

OK
ATL//siehe da, Echo wieder an!

OK//Lautstärke funzt, inwieweit das jetz hörbar ist, keine Ahnung
ATL5

OK
ATM

OK
ATM1

OK
ATO//Online Modus ohne Datenverbindung geht nat. nicht.

NO CARRIER
ATQ

OK
//"ATS" ght nicht
ATS

ERROR
ATS1

ERROR
ATS4

ERROR
ATS

ERROR
ATS0

ERROR
ATV1

OK
ATV0//Verbose Mode: Statusmeldungen nicht als Klartext, sondern Ziffern

0
ATV1

OK
ATX

OK
ATZ

OK
Was kannst du deiner Mühle entlocken?
\0

Autor: \0 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Komisch, dass es jetz gar nicht mehr daheim klingelt, wenn ich am 
Festnetz anrufe. Oha. Mal rausfinden woran das liegt.

ATL hat keine Auswirkung auf Lautstärke, jedenfalls nicht am 
Handylautsprecher hörbarer Unterschied. Funzt also nur virtuell.

Ja irgendwas weniger sinnvolles müsste ich auch mal mit dem Telefon 
anstellen :D
\0

Autor: mikrotomobile (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke \0 für deine Hilfe!

Also was die AT-Befehle angeht - just try 'n error, da es sich um ein 
nicht Fax-Fähiges GSM Modem handelt, wird auch nicht der gesamte AT Satz 
unterstützt... -.-. komm da mal wer drauf...

Naja, nun weiß ich, welche der wichtigen Befehle ich nutzen kannund 
welche nicht.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.