mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik UART klingelt etwas stark


Autor: Martin alexander N. (martinalexander_n)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

das angehaengte Foto zeigt einen kleinen Ausschnitt meiner UART TX 
Leitung: Leider klingelt die Leitung besonders stark im Moment in dem 
meine sendende MCU high voltage (5V) auf die Leitung gibt.

Habt ihr vielleicht eine Idee wo mein Fehler begraben liegt?

Gruesse, Alex

Autor: Bernd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wasn dat für ne Zeitbasis?
Und wo isn überhaupt der Schaltplan?

Autor: Martin alexander N. (martinalexander_n)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Zeitachse ist in 2us Schritten.

Meinen Schaltplan moechte ich nicht komplett publizieren. Meine 
UART-Verbindung ist sehr uebersichtlich:

MCU ----- Stecker -- Buchse ----- MCU

TX und RX beider MCUs sind gekreuzt direkt miteinander Verbunden, ich 
habe sonst keine Bauteile an den Leitungen.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> TX und RX beider MCUs sind gekreuzt direkt miteinander Verbunden
Und die Masse?

Autor: Martin alexander N. (martinalexander_n)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die sind beider MCUs auch direkt miteinander verbunden durch den 
Stecker.

Autor: Grund (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Und die Masse?

UART ist doch ne Zweidrahtleitung ;-)

Autor: Thi Lo (flothi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Braucht trotzdem ne Referenzmasse.

Autor: Maik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann mich bitte mal jemand aufklären, was es bedeutet, wenn "eine 
Leitung klingelt" ?!

Für mich sieht das Oszi-Bild okay aus. (Bis auf die Tatsache, dass eine 
falsche Zeitbasis gewählt wurde und es daher zu einer Unterabtastung 
gekommen ist...

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Für mich sieht das Oszi-Bild okay aus.
Ich weiß nicht mal, wo da 0V und 5V sind...

> Die Zeitachse ist in 2us Schritten.
D.h. das was dort zu sehen ist, dauert gerade mal 3,5us?
Was hast du für eine Baudrate?

Autor: Martin alexander N. (martinalexander_n)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf der Y-Achse habe ich 1V Schritte und 0V ist bei einem Offset von 
-2.5V.

Der Ausschnitt ist knapp 20us und der Highpegel so 8us (meine Skalierung 
ist 5us, doch nicht 2us) -- ich treibe mit 115200bps.

Autor: Eddy Current (chrisi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist der mieseste Screenshot, den ich je gesehen habe. So wie es 
aussieht, läuft die CPU nicht mal mit 5V. Woher sollen wir das wissen, 
wie stark es klingelt? Wahrscheinlich klingelt der 1:10 Tastkopf und 
nicht die UART. Zoom doch um Himmels Willen mal die Zeitbasis rein, lege 
0V auf eine Rasterlinie und halte den Fotoapparat gerade.

Autor: bernd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Eddy Current schrieb:
> Das ist der mieseste Screenshot, den ich je gesehen habe.

Hey, immerhin hat er kein 10MB BMP verwendet ;)

Autor: Martin alexander N. (martinalexander_n)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deinen Beitrag Eddy lasse ich unbeantwortet.

Das Problem konnte ich gerade lösen: Ein Kurzschluss mit einem anderen 
Signal auf dem Board war der Auslöser.

Autor: bernd (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ist irgendein Bauteil jetzt zerstört?

Autor: Martin alexander N. (martinalexander_n)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also bisher ist mir nichts aufgefallen: Ich habe gerade ein paar 
Beispielprogramme getestet und es sieht noch tip top aus.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.