mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Transistor leitet, obwohl er es nicht soll. Wo liegt der Fehler?


Autor: Jan Weber (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
ich habe ein Interface zum Auslesen des Fehlerspeichers eines Autos für 
den VW T4 meiner Freundin nachgebaut. Es ist im Prinzip nichts anderes 
als ein Pegelwandler mit Optokoppler für die serielle Kommunikation.
Allerdings funktioniert es noch nicht ganz, da die Pegel der Signale 
nicht hoch genug sind.
Über den Optokoppler SFH615(im orginal ein 2501) soll der BC546(im 
orginal ein 2N3904) angesteuert werden. Das funktioniert auch, 
allerdings scheint der BC nicht ganz zu sperren, wenn er es soll. Das 
hat zum Effekt, dass am Ausgang nicht die ganzen 12V anliegen, sondern 
nur 8-9V.
Am Optokoppler liegt es nicht, habe den mal die Leiterbahn am Pin3 des 
Optokopplers getrennt, da war die Ausgansspannung immernoch zu gering.

Ich bin inzwischen am Verzweifeln, da ich(für mich)sehr unlogische 
Sachen gemessen habe. Wenn ich zB den Widerstand des Transistors mit 
einem Multimeter im gesperrten und im leitenden Zustand messe sind diese 
Widerstände in Ordnung.
Lötbrücken ect kann ich ausschließen. Den Transistor habe ich auch schon 
getauscht(natürlich nicht zu heiß gelötet...).

Hat jemand von euch vielleicht einen Tipp woran es liegen könnte?
Schonmal vielen Dank für eure Hilfe!

Gruß
Jan

: Verschoben durch Admin
Autor: Kay I. (imperator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was hängt denn an Out?

Welches Potential bildet sich an der Basis aus, wenn Du einen inaktiven 
Optkoppler hast?

Trenn mal den Pfad zwischen Pullup und Collector auf und miss den Strom 
... fließt der Strom wirklich in den Transistor?

Liegen wirklich 12V an?

Ist Dein Pullup wirklich nur 1k groß ?

Autor: HildeK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jan Weber schrieb:
> Hat jemand von euch vielleicht einen Tipp woran es liegen könnte?

Es liegt an der Last, die du am Out angeschlossen hast. Die ist zu 
niederohmig.
Andernfalls ist der Transistor kaputt, falsch angeschlossen etc.

Autor: Peter Roth (gelb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> sondern nur 8-9V.

Du hast den Emitter am Ausgang und die Basis auf Masse.
Die Basis-Emitter-Diode verhält sich im gesperrten Zustand etwa wie eine 
Z-Diode, die Spannung passt ungefähr.

Grüße, Peter

Autor: Jan Weber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Kay,
 >>Was hängt denn an Out?
Bisher garnichts außer ein Oscilloscope.

>>Welches Potential bildet sich an der Basis aus, wenn Du einen inaktiven
Optkoppler hast?
0,36V ; diese Spannung liegt auch an, wenn nur der Pulldown an der Basis 
ist.

>>Liegen wirklich 12V an?
Ja

>>Ist Dein Pullup wirklich nur 1k groß ?
Ja, ist im Plan so vorgegeben. Wäre dann ein Strom von 12mA, relativ 
hoch, aber sowohl der Transistor als auch der Optokoppler können das ab.

>>Trenn mal den Pfad zwischen Pullup und Collector auf und miss den Strom
>>... fließt der Strom wirklich in den Transistor?
Im gesperrten Zustand fließen 3mA zum Collerctor des BC, im leitenden 
sind es 11mA. Der Transistor scheint also wirklich nicht ganz zu 
sperren, es liegen ja auch 0,36V an der Basis an(wobei die ja unter der 
Sättigungsspannung von 0,7V liegt... sollte der Transisot da nicht 
sperren?).

Gruß
Jan

Autor: Jan Weber (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, dank eurer Hilfe konnte ich den Fehler grade beseitigen. Perters 
Hinweis war der entscheidene, allerdings war seine Vermutung nicht ganz 
richtig. Vertausch waren nicht Emitter und Basis sondern Emitter und 
Collector.
Ich habe mich beim Löten ans Layout gehalten und den Transistor 
entsprechend der Abflachung am Gehäuse eingelötet. Ein Blick ins 
Datenblatt hat mir eben verraten, dass der 2N3904 und der BC546 
bezüglich der flachen Seite des Gehäuses den Collector und den Emitter 
Vertauscht haben.
Es gibt sooo viele Normen ect... warum ist das nicht genormt?

Vielen Dank an alle Beiteiligten! Ich war kurz davor das Interface in 
die Ecke zu schmeißen und wohl nie mehr dran weiter zu machen.
Gibt es wohl eine Möglichkeit, dass die falsch herum eingelöteten 
Transistoren überlebt haben? Habe gerade den letzten neuen eingelötet 
und muss noch einen weiteren tauschen.

Gruß
Jan

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jan Weber schrieb:

> Es gibt sooo viele Normen ect... warum ist das nicht genormt?


Wäre zu einfach.
Es gibt auch Transistoren mit gleicher Bezeichnung und unterschiedlicher 
Belegung, je nach Hersteller :-)

Beitrag "Transistortester mit AVR"

> Gibt es wohl eine Möglichkeit, dass die falsch herum eingelöteten
> Transistoren überlebt haben?

Höchst wahrscheinlich haben sie das sogar.

Autor: Helmut Lenzen (helmi1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jan Weber schrieb:
> Es gibt sooo viele Normen ect... warum ist das nicht genormt?

Weil es auch vom internen Chipaufbau abhängt.

Jan Weber schrieb:
> Gibt es wohl eine Möglichkeit, dass die falsch herum eingelöteten
> Transistoren überlebt haben?

Wenn du Emitter und Kollektor vertauschst hast gibt es gute Chance daas 
er überlebt hat. Du willst das Teil ja nicht verkaufen.

Autor: Philipp Burch (philipp_burch)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jan Weber schrieb:
> ...
> Es gibt sooo viele Normen ect... warum ist das nicht genormt?
> ...

Nimm SMD-Transis, da sind mir bis jetzt eigentlich keine Ausnahmen 
untergekommen. Immer in der Art B-C-E, bzw. G-D-S, wobei Drain bei 
"zweiseitigen" Gehäusen auf der gegenüberliegenden Seite liegt (SOT-23 
z.B.).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.