mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Frage zu PNP-Transistor


Autor: Kevin Messer (xxdmxxx)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich habe mich bereits einmal hier erkundet um ein Problem mit einer 
Konstantstromquelle zu lösen. Wir haben uns jetzt für die angehängte 
Schaltung entschieden und nun tritt das nächste Problem auf.

Ich verstehe den PNP-Transistor nicht ganz, und das ist mein 
Hauptproblem ich habe bereits diverse Artikel gelesen aber in den 
meisten wird der NPN besser erklärt als der PNP. Es ist nicht so das ich 
gar nichts weiss aber es gibt da so ein paar Sachen die mir unklar sind.

Die Laständerung ist von 0..20kOhm mit dieser Konstantstromquelle 
erhalte ich eine genauigkeit von ca. 1%. Das ist auch gut so..

Jedoch ist die Abweichung bei der Temperatur 10-12% und das ist zu viel, 
Ziel wäre 5% maximal. Was kann ich tun um diese Schaltung 
Temperaturstabiler zu machen?

Ich habe es bereits mit diversen sachen probiert jedoch hats nie 
geklappt. Kann mir da jemand helfen?

Grüsse DmX

EDIT: der unbeschriftete Widerstand ist 910 Ohm gross.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Jedoch ist die Abweichung bei der Temperatur 10-12%
Pro Kelvin?
Oder von -30 bis +140°C?

EDIT:
> Ich verstehe den PNP-Transistor nicht ganz, und das ist mein
> Hauptproblem ich habe bereits diverse Artikel gelesen aber in den
> meisten wird der NPN besser erklärt als der PNP.
Dann dreh einfach alle Pfeile (BE-Diode, LED) und die Spannungsquelle 
um, dann kannst du mit einem NPN überlegen, wenn das hilft...

Autor: Kevin Messer (xxdmxxx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ups entschuldigung

10-12% von -30°C - +50°C

Das ist der Temperaturbereich.

Edit: -30°C

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du die Betrachtungen dort schon mal angeschaut?
http://www.elektronik-kompendium.de/public/schaere...

Autor: Kevin Messer (xxdmxxx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
> Hast du die Betrachtungen dort schon mal angeschaut?

Ja hab ich, ich hatte nie 2 Dioden in Serie ich hatte von Anfang an eine 
LED. Meinst du das wegen der Wärmeleitpaste?

Ist die so Ausschlaggebend? Wenn ja, ich hab noch welche hier. Ich bin 
noch Lehrling vielleicht ist die Frage jetzt ein wenig doof, kann man 
die Temperatur nicht mit einer zusätzlichen Diode irgendwo stabilisiern? 
peinlich

Greez

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dein Problem ist, dass du 2 Temperaturkoeffizienten hast:
einen von der BE-Strecke des Transistors und einen in der LED.

Und nur, wenn beide genau gleich sind, heben sich die Abweichungen auf.
Du solltest es daher evtl. mal mit einer anderen LED probieren.

Autor: Tom (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Je größer Res2, desto stabiler da Stromgegenkopplung!

Lieg ich da richtig?

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Je größer Res2, desto stabiler da Stromgegenkopplung!
Sooo einfach ist es nicht.
Es hilft nur, wenn der Spannungsabfall über Res2 signifikant höher ist 
als der Fehler durch die unterschiedlichen Temperaturkoeffizienten. Das 
heißt aber auch: statt einer LED deren 2. Oder gleich ststt der LED eine 
Z-Diode mit 5V. Aber dann bleibt evtl. zuwenig Spannung am Kollektor 
über...

Autor: Kevin Messer (xxdmxxx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich versuchs mal mit einer 4V7 Diode. Aber ob das dann 
Temperaturstabiler ist bezweifle ich schwer. Oder lieg ich da falsch?

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hänge in Reihe zu D1 die BE-Strecke noch eines 2N2905 als Diode. Damit 
dürftest Du innerhalb Deiner 5% Abweichung liegen.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Oder lieg ich da falsch?
Ich würde sagen: Ja, du liegst falsch.
Probiers aus, Versuch macht schlau.

Autor: Kevin Messer (xxdmxxx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok ich werde das mit der BE-Strecke auch noch versuchen.

Ich habe jetzt gerade das mit der Z-Diode versucht, ich habe ein 5V1 
genommen und zwischen dem Transistorgehäuse (TO-39) und der 5V1 Diode 
Wärmeleitpaste geschmiert und siehe da bei Zimmertemp. ein Strom von 
1.000mA und bei 50°C Ambient (Heissluftföhn) nach 1min warten 1.012mA.

Dies ist schon um einiges besser!^^ Ich versuchs jetzt noch mit der BE 
strecke... Mal guggn..

EDIT: Mein Kältespray ist leider ausgegange den negativ Temp test muss 
ich morgen machen...

Autor: Kevin Messer (xxdmxxx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei der Idee mit der BE-Strecke hatte ich bei Zimmer Temp. wieder 
1.000mA und bei 50°C 0.996mA Toll.

Ihr seit echt gut jungs, danke vielmals ich glaube das wars^^

Grüsse Kevin

Autor: Frank Eppers (ffje)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,
in Reihe zu D1 z.B. eine 1N4148, diese muss mit
dem Transistor thermisch gut gekoppelt sein.
Thermische Kompensation ist oft Feinmechnik.
mfG  ffje

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erstens sollten Transistor und LED thermisch gekoppelt sein (also 
irgendwie mechanisch zusammenbinden - vielleicht mit Alu-Ring um beide 
drumherum, oder einfach Alufolie mehrlagig, ausgefüllt mit 
Wärmeleitpaste.
Dann darauf achten, daß der Transistor nicht zu viel Strom führen muß, 
weil dies dann zusammen mit der Uce-Spannung zu Verlustleistung, also 
zusätzlcihe Temperaturerhöhung führt, womit LED und Transistor 
auseinanderdriften.
LED und Transistor haben weitgehend gleiche Temperaturkoeffizienten, 
deswegen sollte dieser Weg zu deutlicher Resuzierung der 
Temperaturabhängigkeit führen.

Autor: Frank Eppers (ffje)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sorry, zum Schaltbild.
Deine orange LED D1 muss eine Z-Diode sein mit Kathode oben
und in Reihe mit der thermisch gekoppelten Universaldiode
zur Temperatur-Kompensation des Transistors BE-Diode.
Wo in deinem Bild die Last ist, gehört die im Strom durch
die Schaltung stabilisierte LED hin.
Ich hatte etwas Ähnliches mal für 50 IR-LED in Reihe (>90V)
gebaut, und das 4 mal, einen IR-Scheinwerfer für eine Kamera,
600mA-Puls für einen Vertikal-Scan der Kamera, dann Sekunde Pause.
mfG  ffje

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Frank Eppers schrieb:
> Deine orange LED D1 muss eine Z-Diode sein

Du weißt schon, daß der Temperaturkoeffizient einer Z-Diode oft 
schlechter ist als der einer LED (außer bei ca. 6V, da gibt es einige 
bei fast 0)?

Sinnvoller als ein 2. Transistor ist eine Universaldiode auch nicht 
unbedingt. Die Temperaturkoeffizienten dürften sich da hin und wieder 
unterscheiden. Und das er schon zufrieden ist hast Du scheinbar auch 
übersehen...

Autor: Kevin Messer (xxdmxxx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meine LED ist explodiert sie kam mit der Kathode an das Gehäuse des 
Transistors welches direkt mit dem Kollektor verbunden ist. Nun geht 
nichts mehr ich habe eine neue LED hinein getan und nix hat sich getan.

Kann der Transistor kaputt sein?

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kevin Messer schrieb:
> Kann der Transistor kaputt sein?

Ja.

Autor: Kevin Messer (xxdmxxx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hmmm... gut hab ihn gerade ausgewechselt tut sich aber nicht. Komisch 
vielleicht ist der Verdrahtung nicht gerade perfekt das Vero-Board ist 
schon ein wenig alt.

Autor: mhh (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
R1 kann auch etwas abbekommen haben (je nach eingestelltem 
Widerstandswert).

Autor: Kevin Messer (xxdmxxx)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Neuer Tag neues Glück dachte ich mir heute Morgen nachdem ich das 
Problem gefunden hatte und der Aufbau wieder funktionierte ich stellte 
exakt 1mA ein und siehe da... Was zur hölle ist das? Ich dachte ich 
zeige es euch an mit einem Diagramm.

Ich habe den Wert alle 5sek. abgeschrieben weil mich das so verwundert 
hat. Wie ist das möglich das der (ohne Laständerung, ohne Heissluftföhn 
oder Kältspray) so schwankt?

Ich habe den Transistor und die Z-Diode Thermisch verbunden mit 
Wärmeleitpaste und die beiden Gehäuse zusammen gedrückt.

Eigenerwärmung? So extrem?

Was ist nun zu tun?

Grüsse Kevin

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Welches Messgerät verwendest du?

Autor: Kevin Messer (xxdmxxx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
GWinstek GDM-8246

Autor: Kevin Messer (xxdmxxx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kevin Messer schrieb:
> Eigenerwärmung? So extrem?

Selbst Zitat:

Ja, und zwar ist dies der Fall sobald ich eine Silizium Diode verwende, 
also entweder die Z-Diode im vorherigen versuch oder die 1N4148 die ich 
in Serie zur LED versucht habe. Sobald ich einer dieser beiden drin habe 
wird es sehr instabil.

Jetzt mal ne Frage:

Wenn mein Transistor z.B +2mV/K hat. Kann ich dann nicht ein Bauteil 
nehmen das -2mV/K hat um das alles auszugleichen oder versuch ich das 
bereits die ganze Zeit ohne es selbst zu merken?

Grüsse Kevin

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
Du willst einen temperaturstabielen Stromtreiber und experimentierst mit 
LED,Z-Dioden und zusätzlichen Dioden rum?
Bist du von allen guten Geistern verlassen?

Wicki. -> Stromspiegel -> Lesen -> Verstehen -> Anwenden ->glücklich 
sein.

Viel Erfolg, Uwe

Ps.: es soll auch Mehrfachtransistoren geben.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Wenn mein Transistor z.B +2mV/K hat.
Dann brauchst du ebenfalls ein Referenzbauteil, das +2mV/K hat. Nur dann 
bleibt die Spannung über dem Emitterwiderstand konstant. Und eine 
konstante Spannung an einem konstanten Widerstand gibt was für einen 
Strom?

Was dir bei dieser simplen Stromquelle aber auch reinfunken könnte, ist 
eine Änderung der Stromverstärkung über die Tmeperatur...

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wozu hast Du noch eine normale Diode in Reihe zur LED? Das macht doch 
den Temp.-Gang kaputt.

Autor: Uwe (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi!
>an einem konstanten Widerstand
So, so der hat also keinen TK?

Viel Erfolg, Uwe

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast sozusagen einen thermischen Oszillator erfunden. Kommt 
vermutlich daher, weil LED+Diode zusammen den doppelten Temperaturkoeff. 
haben, also den Temeraturkoeff. des Transistors überkompensieren. Heizt 
also der T auf, kommt das zeitverzögert bei den Dioden an, und die 
steuern gegen mit doppelter Gewalt.

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>>an einem konstanten Widerstand
> So, so der hat also keinen TK?
Der wird aber bitteschön in ppm angegeben, nicht in %   ;-)

Autor: Michael (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kevin Messer schrieb:
> Wenn mein Transistor z.B +2mV/K hat. Kann ich dann nicht ein Bauteil
> nehmen das -2mV/K hat um das alles auszugleichen oder versuch ich das
> bereits die ganze Zeit ohne es selbst zu merken?

Nein kannst du nicht, wenn schon dann müssen die TKs gleich sein, hat 
also der Transitor +2mV/K dann muss auch die Diode +2mV/K aufweisen. Der 
Trick an der Transitor-Dioden-Sache ist ja, dass die Diode und die 
BE-Strecke gleich stark mit der Temperatur wegdriften und das geht nur 
wenn sie den gleichen TK haben. Achja, man geht hier davon aus, dass der 
Einstellwiderstand einen TK von 0 hat. Ist dies nicht der Fall...naja, 
das kannst du dir doch jetzt bestimmt denken, oder ;).

Lothar Miller schrieb:
> Der wird aber bitteschön in ppm angegeben, nicht in %   ;-)

Na wegen der paar Nachkommastellen die man bei % mehr berücksichtigen 
muss...stell dich mal net so an. Ist doch egal ob ich 0.001% schreibe 
oder 10 ppm ist doch Wurscht, beides das Gleiche ;)xD

Autor: Kevin Messer (xxdmxxx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Lothar Miller schrieb:
> Und eine
>
> konstante Spannung an einem konstanten Widerstand gibt was für einen
>
> Strom?

Einen konstanten Strom. Jedoch ist der Widerstand bei mir nicht 
konstant^^

Er ändert sich von 0...20k Ohm.^^ Aber funzt trotzdem mit 0,4% 
Abweichung auf dem ganzen Lastbetrag. Und etwa 2-3% bei den Temp. Test.

Scheint aber gut zu funktionieren


Uwe schrieb:
> Du willst einen temperaturstabielen Stromtreiber und experimentierst mit
>
> LED,Z-Dioden und zusätzlichen Dioden rum?
>
> Bist du von allen guten Geistern verlassen?

Jens G. schrieb:
> Wozu hast Du noch eine normale Diode in Reihe zur LED?


Wiso ich das tue? Weil mir das gesagt wurde^^


Frank Eppers schrieb:
> Deine orange LED D1 muss eine Z-Diode sein mit Kathode oben
>
> und in Reihe mit der thermisch gekoppelten Universaldiode
>
> zur Temperatur-Kompensation des Transistors BE-Diode.
>
> Wo in deinem Bild die Last ist, gehört die im Strom durch
>
> die Schaltung stabilisierte LED hin.

Aber funzt wie gesagt nicht schlecht mal gucken wies aussieht wenn ich 
meine 100 Konstantstromquellen gebaut habe^^

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Wiso ich das tue? Weil mir das gesagt wurde^^
Wenn es eine Z-Diode mit einer bestimmten Spannung (ich glaube so 3-5V 
rum), dann hat die wohl so den niedrigsten Temp.-Koeff., wenn ich mich 
recht erinnere. Da würde es sinn machen, eine zusätzliche Diode 
reinzumachen, um dann wieder auf den selben Wert zu kommen, wie der 
Transistor.
Aber da eine LED bereits so um die 2mV hat wie der Transistor, ist eine 
zusätzliche Diode wohl eher kontraproduktiv.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.