mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik 4fach OpAmp uebersprechen?


Autor: Christoph Noname (mrmister)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo an die Freunde der analogen Schaltungstechnik ;-)

...ich hab mir eine Messchaltung aufgebaut die einen AD8608 verwendet, 
will garnicht ins Detail gehen was da genau gemacht wird nur 
soviel...ein OPV ist als Transimpedanzverstaerker geschalten und einer 
dahinter als invertierender Verstaerker...das ganze zweimal...

...jetzt zum Problem, wenn ich am ersten Verstaerkerzug 
(Transimpedanzverstaerker + inv. Verstaerker) ein Signal anlege das 
meinen OPV ins Eck treibt (ist von meiner Applikation so vorgegeben), 
dann liefert mir auch der zweite Verstaerkerzug ein komplett falsches 
Signal...

...das Eingangssignal am zweiten Zug ist ok, am Ausgang aber komplett 
falsch....kann es damit zusammenhaengen das im IC inneren Uebersprechen 
stattfindet? Ich verwende die OPVs folgend: Zug eins OPV A + OPV D und 
zug zwei OPV B + OPV C

...kann man an einem bestehenden PCB was dagegen tun?...

...Eine Moeglichkeit ware natuerlich im Falle des Signals, dass den OPV 
ins Eck treibt den Eingang mit einem Schlater zu Oeffnen, nur dazu 
muesste ich eine neue PCB machen und brauche zusaetzliche 
Digitalleitungen vom uP um zu schalten..

: Verschoben durch Admin
Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schau Dir mal das Innenschaltbild des ICs an, etliche 
Konstantstromquellen werden da gemeinsam genutzt.  Da wundert es nicht, 
wenn Du da einen OPV extrem übersteuerst das die übrigen "davon was 
mitbekommen".

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was das Übersprechen im Analogbetrieb angeht, siehe Datenblatt.
Und was das Übersprechen im Übersteuerungsfall angeht, dann meistens 
nicht mehr "siehe Datenblatt", weil das eben nicht der normale Fall 
eines OPV ist.
Da kann es durchaus sein, daß intern gemeinsam benutzte Strukturen (wie 
Spannungs/Stromreferenzen) dabei "verzogen" werden, z.B. weil evtl. 
irgendwelche pn-Übergänge dann leitend/nichtleitend werden (auch die 
Ursache für ein mögliches Latch-Up bei nicht Latch-Up-festen OPVs).
Umgehung dafür wäre eigentlich nur, völlig getrennte Single-OPVs zu 
benutzen.
Komparatoren müssten dabei besser wegkommen, weil die sind ja für 
"Übersteuerung" ausgelegt.

Autor: Christoph Noname (mrmister)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...ein Symptom, das auftritt ist, dass die negative Versorgung stark 
belastet wird, also der OP wird von mit mir +/-2.5V versorgt und im 
angesprochenen Problemfall zieht der OPV 100mA ueber die -2.5V...

...Innenschaltbild des OPV hab ich leider keines...

...welcher Wert des Datenblatt gibt mir auskunft uebers uebersprechen?

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn da 100mA gezogen werden, machst Du vermutlich was falsch. Das kann 
nicht durch simple Übersteuerung kommen. Vielleicht arbeitet einer der 
Ausgänge auf Kurzschluß? Das könnte dann laut DB schon um die 100mA 
ergeben.

Ansosnten, was die innenschaltung angeht: bei neueren Typen ist die 
natürlich meist nicht mehr mit im DB drin, aber wenn Du in ältere DB's 
reinschaust, dann sieht man schon die klassischen Verschaltungen, wozu 
auch gemeinsam genutzte Teile dazu gehören, die dann für sowas anfällig 
sein können.

Autor: Christoph Noname (mrmister)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...irgendetwas falsch?Ja das befurchte ich auch ;-) ...aber ich hab bei 
meiner Schlatung ja insgesamt drei der AD8603, die wie oben beschrieben 
jeweils zwei Verstaerkerzuege beinhalten...

...wenn  an einem Verstaerkereingang das, nennen wirs mal "bad signal" 
anliegt, dann heisst das sein Ausgang geht auf 2.5V, also voll in 
Eck...der Verstaerkerzug der im selben Package sitzt und das richtige 
eingangssignal erhaelt gibt mir am Ausgang -1.9V!!!, alle anderen 
Verstaerker liefern das richtige Signal...

...liegt das "bad signal" an einem anderen Verstaerker an, wandert der 
Fehler mit, also immer nur in dem einen Package, das ein "bad Signal" 
bekommt...

...ich versuche mit der Schaltung Strom zu messen, im Bereich weniger 
uA...da liegen dann am Eingang normalerweise auch nur -16mV an, beim 
"bad signal" kommen aber 1.9V auf den Eingang...

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Christoph Noname schrieb:
> angesprochenen Problemfall zieht der OPV 100mA ueber die -2.5V...


Das nannte man früher Latch-up-condition.
Heute schlicht Übersteuerung, Details hat Jens ja bereits erläutert.


Du wirst nicht drumrum kommen Deine Beschaltung so zu modifizeren, das 
diese Fall nicht mehr auftreten (kann).
Oder, was man auch sonst oft macht: Man nimmt einen anderen OPV-Typ.

Poste bitte mal den Gesamtschaltplan in lesbarer Form hier, sonst 
stochern wir weiter im Trüben.

Autor: Alexander Schmidt (esko) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Andrew Taylor schrieb:
> Christoph Noname schrieb:
>> angesprochenen Problemfall zieht der OPV 100mA ueber die -2.5V...

Ich nenne das Kurzschluss.

@Christoph:
Zeig mal einen Ausschnitt der Schaltung mit dem übersteuerten OPV.

Autor: Christoph Noname (mrmister)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...so hab jetzt nochmal bissl gemessen und folgendes entdeckt:

..ich hab auch den AD8606 (2fach OPV) und wenn ich den auch als TIA + 
inv.Verstaerker schlate und bissl aergere passiert folgendes:

...bei Eingangsspannungen >0V hab ich am TIA Ausgang -2.5V, am Ausgang 
des inv. Verstaerkers +2.5V und einen geringen Versorgungsstrom...

...bei Eingangsspannungen <0V habe ich am TIA Ausgnag +2.5V, am Ausgang 
des inv.Verstaerkers -1.9V und einen erheblichen Stromfluss um die 30mA 
mehr!!!...

...Trenne ich die beiden Verstaerker und verwende nur noch den TIA 
bleibt der Versorgungsstrom unabhaengig von der Eingangsspannung 
gering...

...ich komme also zum Schluss das mir der inv.Verstaerker den Strom 
zieht...

..hinzu kommt dass ich (wenn ich jetzt wieder am AD8608 messe) bei dem 
"bad Signal" Fall messe, dass das Groundpotential um 10mV nach unten 
verschoben wird...

Autor: Andrew Taylor (marsufant)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Fazit: Es muß unendlich schwer für Dich sein einen Schaltplan zu posten.

Autor: Christoph Noname (mrmister)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...ok, warum der invertierende Verstaeker den Strom braucht ist jetzt 
klar...

...ich hab am Ausgang einen 50R Widerstand und eine Shottkydiode um 
negative Spannungen nicht an den ADC weiter zu geben...hab den 
Widerstand jetzt auf 2k vergroessert und dieses Problem ist weg....

...was aber weiterhin vorliegt, ist das mein AD8608 jetzt "nur mehr" 
80mA zieht, die ich nicht erklaeren kann...

...ich werd jetzt nochmal messen und berichten...

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja - aber bevor du mit weiteren Fragen kommts, liefere erstmal einen 
Schaltplan. Daß die Ausgänge überlastet werden, war mir ja fast schon 
klar ...

Autor: Christoph Noname (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...es wird nicht nur die negative, sondern auch die positive Versorgung 
stark (80mA) belastet....

...Schlatplan folgt...

Autor: Christoph Noname (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
..Probelm gelöst...und zwar wie folgt:

- Ich habe am Rückkoppelzweig des TIA einen CMOS Schalter angebracht, 
mit dem ich den 1M Widerstand mit einem 10k Widerstand überbrücken 
kann...dieser CMOS Schalter hat aber eine interne Schutzdiode und wird 
mit +4V und GND versorgt...versucht also mein TIA am Ausgang ein Signal 
<GND schlatet die Diode des Schalters und zieht den Strom...

...und ja ich weiß es...haette ich den Schaltplan gepostet waer hier 
wahrscheinlich schon letzte Woche die Antwort gekommen....ich werde 
daraus lernen ...versprochen ;-)

...danke für eue Mithilfe...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.