mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ADC: Lineares Poti - exponentielle Werte?


Autor: Software-Entwickler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

meine Schaltung ist quasi wie auf folgendem Bild aufgebaut:

http://www.mikrocontroller.net/wikifiles/7/75/Tut_ADC_01.gif

An der Quellspannung von 5V haengen sowohol Poti als auch Controller. 
Das Potentiometer ist linear und hat 47k Ohm. Als Controller nutze ich 
den ATTiny13, der hat einen 10bit AD Wandler.

Problem: Bis zum Winkel von 230 Grad steht der Wert auf 0, bis zum 
Winkel von ca. 260 Grad erreiche ich gerade Mal den Wert 160. Dann 
verteilen sich die restlichen Werte auf ca 1-2 Grad und danach habe ich 
dann Maximum, so ist nichts einstellbar.

Ich nutze nicht die interne Referenzspannung, sondern VCC fuer die 
Conversion. Als Spannungsquelle dient das STK 500, das sollte ein 
relativ sauberer Pegel sein.

Ich frage mich, was ich falsch mache! Ich habe schon alle moeglichen 
Prescaler Einstellung durchprobiert, weswegen ich die Frequenz als 
Fehlerursache ausschliesse.

Hier noch der relevante Code:

void ADW(void)
{
    // ADC aktivieren, Frequenzvorteiler setzen
     ADCSRA = (1<<ADEN) | (1<<ADPS2) | (1 << ADPS0);

     // Kanal waehlen (ADC2)
       ADMUX  =   0x2;

     //keine interne Referenzspannung nutzen
       ADMUX  &= ~(1<<REFS0);

     // eine ADC-Wandlung
       ADCSRA |= (1<<ADSC);
       while(!(ADCSRA & (1<<ADIF)))
     {
         // auf Abschluss der Konvertierung warten (ADIF-bit)
     }

     // ADC muss einmal gelesen werden,
       voltage = ADC;


       //ADC-Messung mit arithmetischen Mittel aus 25 Messungen
       voltage = 0;
       for (int i=0;i<25;i++)
       {
          ADCSRA |= (1<<ADSC);
          while(ADCSRA & (1<<ADSC))
      {
          // Konvertierung abwarten
      }

      // aufaddieren zur Mittelwertbildung (ADC auslesen der zwei Bits)
          voltage += ADC;
        }

    // ADC ausschalten
        ADCSRA &= ~(1<<ADEN);

        voltage /= 25;
}

Autor: Andreas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde nur sehr kurz zögern um anschließend am Schleifer die Spannung 
zu messen.

Gruß,
Andreas

Autor: Spezi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Poti defekt? ADC-Pin auf Eingang geschaltet? Pullup-Widerstand aus?

Miss mal mit dem Multimeter die Spannung am Pin des Tiny13. Ist der 
Verlauf dort genauso? Und miss mal ohne den Tiny die Spannung. Wenn sie 
dann ok ist, kann es nur am Controller bzw. seiner Programmierung 
liegen.

Autor: Software-Entwickler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spezi schrieb:
> Poti defekt? ADC-Pin auf Eingang geschaltet? Pullup-Widerstand aus?
>
> Miss mal mit dem Multimeter die Spannung am Pin des Tiny13. Ist der
> Verlauf dort genauso? Und miss mal ohne den Tiny die Spannung. Wenn sie
> dann ok ist, kann es nur am Controller bzw. seiner Programmierung
> liegen.

Heureka!

DDRB &= ~(1 << PIN4);

Dass ich darauf nicht gekommen bin!

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Software-Entwickler schrieb:

>> Verlauf dort genauso? Und miss mal ohne den Tiny die Spannung. Wenn sie
>> dann ok ist, kann es nur am Controller bzw. seiner Programmierung
>> liegen.
>
> Heureka!
>
> DDRB &= ~(1 << PIN4);
>
> Dass ich darauf nicht gekommen bin!

Das wär mir jetzt allerdings neu, dass man für den ADC den Pin extra auf 
Eingang schalten muss. Zumal er das sowieso ist, wenn du nicht 
anderwertig am Konfigurationsregister rumgeschraubt hast.

Pullup könnte allerdings tatsächlich sein.

Autor: Software-Entwickler (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Karl heinz Buchegger schrieb:
> Das wär mir jetzt allerdings neu, dass man für den ADC den Pin extra auf
> Eingang schalten muss. Zumal er das sowieso ist, wenn du nicht
> anderwertig am Konfigurationsregister rumgeschraubt hast.

Ich steuer noch ein Display ueber i2c an. Das DDR ist allerdings 
wirklich schuld!

Funktioniert:
  DDRB = 0xFF;
  DDRB &= ~(1 << PIN4);
  PORTB = 0x00;


Funktioniert nicht:
  DDRB = 0xFF;
  PORTB = 0x00;

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.