mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR mit usbasp unter Windows 7


Autor: eSKape (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ;)
ich hab versucht meine AVR-Mikrocontroller unter WIndows 7 zum laufen zu 
bekommen, via usbasp. Jedoch erkennt windows 7 scheinbar die treiber 
nicht, obwohl diese laut website auch für windows 7 geeignet sind. Was 
unter XP null Problem war funktionert unter 7 nicht im geringsten.
Und ja es muss mit usbasp programmiert werden (schule^^)

vlt kann jemand helfen, wäre dankbar :)

MfG,
eSKape

Autor: eSKape (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sry, hab vergessen das ich 32Bit system hab ;) bisher hab ich nur von 
dem Treibersignierungsproblem unter 64Bit gehört, aber bei gehts halt 
nicht nter 32Bit :-$

Autor: Joachim K. (minifloat)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
usbasp braucht treiber?
avrdude macht das doch via libusb?
mfg mf

Autor: Martin e. C. (eduardo)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jo K. schrieb:
> usbasp braucht treiber?

Ja, Usbasp brauct treiber und normallerweise ist unter Win 7 32Bit kein 
Problem.
Welches Fehler kommt? oder was funktioniert nicht??

Autor: eSKape (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es kommt einfach die Meldung "unbekanntest Gerät" Gerät kontne nicht 
installiert werden :-$ selbst bei manueller Treiber installation 
funktionierts nicht. Habe bereits die aktuellsten Treiber probiert aber 
auch ältere hm..

Autor: Dan M. (killler07)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bei mir lag das daran, dass die Schaltung mit den 5V Vusb betrieben 
wurde. Der USBasp verwendet software-USB, die USB-Datenleitungen sind 
also direkt an den AVR-Pins. Und hier ist das Problem: Der AVR jagt 
seine 5V durch die USB-Datenleitung, was laut USB-Spezifikation 
"illegal" ist. Viele Mainboards verweigern darauf die Zusammenarbeit.

Falls das wirklich das Problem ist gibt es 2 Lösungen:

1. USB Hub dazwischen, sozusagen als unfreiwilliger "Pegelwandler"
2. Betriebsspannung der Schaltung auf 3,x V heruntersetzen. Ich habe das 
mit 2x 1N4148 in der Versorgung gemacht.

Grüsse,

Dan

Autor: eSKape (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
danke für die Lösung, ich werds mal mit nem Hub ausprobieren, aber am 
Mainboarsd kanns eig nicht liegen, denn unter XP wars ja kein Problem 
:-$ mal schauen ;)

Autor: iohm (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
eSKape schrieb:
> aber am
> Mainboarsd kanns eig nicht liegen, denn unter XP wars ja kein Problem

Kann schon, Stichwort andere Controllertreiber

Autor: Phillip P. (phillip)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich möchte hiermit Dan. M.'s These bestätgen: Ich hatte dasselbe Problem 
(USBasp wurde unter Win7/32bit nicht erkannt) - der Tipp mit dem Hub war 
die Lösung :-).

Danke und LG,
Phillip

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.