mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik AVR-JTAG-USB mit Studi0 4


Autor: Christian C. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin, ich habe den AVR-JTAG-USB gekauft und möchte nun ein Board mit 
AT90CAN128 und dem Programm debuggen.

Leider gibt es meine Plattform dort nicht, nur JTAG ice und einen 
anderen.

Wie bekomme ich nun den Code auf meinen Controller?

Danke

Autor: Georg W. (gewe)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn Du das Olimex AVR-JTAG-USB hast, dann must Du das Device JTAG ICE 
auswählen. Als COM-Port wähltst Du den virtuellen COM-Port aus, der beim 
Anstecken des AVR-JTAG-USB eingerichtet wurde.

cu
Georg

Autor: Christian C (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die Antwort.
Den Teiber erkennt er nicht.
Ich hab gerade rqausgefunden, dass ich den FT232-Treiber installieren 
muss, oder wie der hiess.

Autor: Georg W. (gewe)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf der Olimex Seite gibt es eine Anleitung für Anfänger, wie Du das 
Ding zum Laufen bekommst:

http://www.olimex.com/dev/pdf/AVR/How%20to%20insta...

cu
Georg

Autor: Christian C. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab nun den Virtual Com Driver installiert.

Ich hab auch unter Geräte Manager USB Serial Port (Com4) stehen, COM3 
war belegt.

AVR-JTAG-USB ist per USB mit dem PC verbunden. Wenn ich nun bei AVR 
Studio 4 JTAG ICE auswähle und als COM-Port Auto, sagt AVR Studi mir 
Connection failed.

Ich hab am PC nur den AVR-JTAG-USB Adapter dran ohne diesen an einem 
Board dran zu haben. Aber AVR Studio muss sich doch mit dme Adapter 
verbindne können ohne das der Adapter über JTAG mit einem Board 
verbunden ist?

Autor: Henrik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wähle COM4 und nicht Auto. Dann sollte es klappen.

Autor: Christian C. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habs vergessen zu erwähnen, aber das hatte ich natürlich auch versucht.
Klappt leider auch nicht: Connect failed...

Autor: Henrik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ich richtig denke, solltest du auch das Target mit mit Debugger 
verbinden.

Mit dem Bedugger allein connecten funzt nicht. Jedenfalls nicht mit den 
DebuggingSystemen, die ich kenne...

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.