mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Primer2, lesen der target informationen über SWD funktioniert, über JTAG kein Lebenszeichen vom STM3


Autor: BjoernC (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
für meine Haussteuerung wollte ich einen STM32 einsetzen. Zu diesem 
Zwecke habe ich mir einen primer 2 gekauft, um erste Test-Programme auf 
diesen zu testen im speziellen wollte ich schauen ob die IDE bestehend 
aus dem Code-Sourcey Compiler sowie Eclipse funktioniert um dann später 
auf einem eigenem Board weiter zu machen. Die ersten Test-Programme mit 
der von Raisonance gelieferten Software liefen ohne probleme, auch das 
compilieren mittels Eclipse funktionierte. Bis ich dann die genierte 
Hex-File auf den primer 2 geladen hatte danach ging gar nichts mehr. Via 
SWD kann ich die target informationen (STM32F103VECT) auslesen, über 
JTAG bekomme ich gar keine Informationen über den uC. Ich habe schon 
einiges ausprobiert wie zum Beispiel die JTAG frequenz herunter zu 
drehen auf 375kHz. Auch da gab sich keine Besserung des Zustands. Ein 
erneutes aufspielen einer funktionierenden Software funktioniert 
ebenfalls nicht. Die einzigsten Fehlermeldungen oder Meldungen könnt ihr 
dem Anhang entnehmen. Meine Frage ist daher, kann ich den primer nun 
wegwerfen oder gibt es noch Hoffnung das ich diesen wieder fit bekomme?
Und die wichtigste Frage ist, was ist schief gelaufen warum hat das 
gleiche Programm unter einer anderen IDE so fatale Auswirkungen gehabt?
(in eclipse benutze ich das hier vorgestellte Plugin die Einstellungen 
bezüglich target-Architecture habe ich übreprüft udn stimmt überein, für 
das Linker-Script habe ich jenes übernommen welches ich für das damals 
funktionierende Programm übernommen, sonstige Einstellungen in Eclipse 
habe ich bei den default-Werten belassen).
Die Fehlermeldungen die ich bekomme findet ihr im Anhang, für eure 
Bemühungen möchte ich mich schon im Voraus bedanken.

Autor: BjoernC (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
[EDIT] also bisher habe ich nach dem Suchen von WRP folgendes 
herausgefunden anscheinend ist die write Protection aktiv, nur gibt es 
eine Möglichkeit diese zu deaktivieren?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.