mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Dockstar an Fritzbox ohne DHCP


Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

habe seit ein paar Tage eine Seagate Dockstar rumliegen und komme mit 
der nicht weiter.

Folgendes weiß ich:
Die Dockstar IP Adresse : 169.254.192.122
Meine Fritzbox IP : 192.168.0.1
DHCP ist ausgeschalter in der FB
Alles anderen Computer im Netzwerk habe statische IP Adressen 
192.168.0.xxx

Wenn ich die Dockstar an meine Fritzbox anklemme komme ich nicht per 
Putty drauf.

Ich habe die Dockstar vorher an meinem Laptop per Lan und habe das 
Heimtelefonieren ausgeschaltet(Fritzbox war nicht im I-Net)


Wie komme ich denn jetzt auf die Dockstar rauf, wenn die an der FB 
hängt.
Wenn sie am Laptop per LAN hängt, dann kommt ich zwar auf die Dockstar 
aber die Dockstar hat keine Verbindung zum Internet.

Bye

Autor: Hallo (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,
naja ich vermute mal das du zuerst mal die ersten vier Bereiche der IP 
der Dockster mit der der Fritzbox gleichsetzten musst also sie muss 
192.168.0.xxx
lauten sonst können die Geräte nicht untereinander Kommunizieren.

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das war auch mein Plan - nur fehlt mir dafür das Grundwissen von Linux 
um dies zu ändern...

Autor: Peter (Gast)
Datum:
Angehängte Dateien:
  • rcS.txt (357 Bytes, 182 Downloads)

Bewertung
0 lesenswert
nicht lesenswert
Könnte man das in der /etc/init.d/rcS ändern?

habe die mal von mir hier angehängt.

Autor: ertwet (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dann schalt doch DHCP ein, hab ich auch so gemacht, obwohl ich keine 
Fritzbox habe. du wirst bei der Fritzbox doch auch angeschlossene Geräte 
sehen können.

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich möchte aber kein DHCP verwenden - daher wäre mir eine Lösung mit 
fester IP Adresse lieber.

Die Dockstar ist nicht in der FB sichtbar - egal ob direkt angeschlossen 
oder über den Laptop.

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jetzt habe ich was umgestellt per Putty über den Laptop:
/sbin/ifconfig eth0 192.168.0.17 broadcast 192.168.0.1 netmask 255.255.255.0 up

Danach habe ich die Dockstar an die FB angeschlossen und konnte drauf 
zugreifen.

Nur leider läßt sich die FB jett nicht anpingen.

Was muß ich denn da noch machen?

Autor: Sascha Weber (sascha_w)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das 'broadcast 192.168.0.1' sieht irgendwie merkwürdig aus wenn das 
'gateway' heissen würde ok - an sonsten nicht die selbe IP wie die der 
FB.

Sascha

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Geht nicht...
-bash-3.2# /sbin/ifconfig eth0 192.168.0.17 gateway 192.168.0.1 netmask 255.255.255.0 up
ifconfig: bad address 'gateway'
-bash-3.2#

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wieso setzt du broadcast? Und warum auf den kranken Wert?
Wenn dann muß es 192.168.0.255 sein, nicht ....1.

Außerdem darf die 192.168.0.17 natürlich nicht nochmal
im Netz verwendet sein.
Im Zweifelsfall ohne das Ding mal ein ping auf deise Adresse
machen und sehen, ob sich jemand meldet.

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter schrieb:
> Geht nicht...
> -bash-3.2# /sbin/ifconfig eth0 192.168.0.17 gateway 192.168.0.1 netmask 
255.255.255.0 up
> ifconfig: bad address 'gateway'
> -bash-3.2#

lass das gateway mit seiner nachfolgenden Adresse mal weg; das
setze ich immer hinterher mit route add default gw 192....

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das mit dem Broadcast habe ich irgenwo im Internet gefunden.

Dachte da kommt die Adresse der FB rein.
Daher der Eintrag von mir.

Die Adresse 192.168.0.17 ist garantiert nicht bei mir vergeben.
Ein Ping auf der Dockstar an sich selbst geht - aber nicht zur FB


Wie müsste denn die genau Befehlszeile heißen?

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
/sbin/ifconfig eth0 192.168.0.17 broadcast 192.168.0.255 netmask 
255.255.255.0 up

danach mal ifconfig ohne Parameter und route ohne Parameter
eingeben und die Ausgabe herzeigen

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klaus Wachtler schrieb:
> danach mal ifconfig ohne Parameter und route ohne Parameter
> eingeben und die Ausgabe herzeigen

-bash-3.2#
-bash-3.2# /sbin/ifconfig eth0 192.168.0.17 broadcast 192.168.0.255 netmask 255.255.255.0 up
-bash-3.2#
-bash-3.2# /sbin/ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:10:75:1A:C1:7A
          inet addr:192.168.0.17  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5111 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3655 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:472192 (461.1 KiB)  TX bytes:514014 (501.9 KiB)
          Interrupt:11

-bash-3.2# /sbin/route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
-bash-3.2#

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok, dann mach noch ein (falls deine FB und damit das Gateway nach
außen 192.168.0.1 ist und du auch rauswillst von dem Ding aus):
  route add default gw 192.168.0.1

Dann mal ping probieren...

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PS: Soll die auch mit Internet außerhalb der FB plaudern?
Dann kann es sein, daß die MTU zu groß ist - falls du DSL hast.

Abhilfe:
  /sbin/ifconfig eth0 192.168.0.17 mtu 1400 broadcast 192.168.0.255 
netmask 255.255.255.0 up

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Für einen Zugriff von außen muß natürlich dann auch noch die
FB dazu gebracht werden, die entsprechende Verbindung von
außen an 192.168.0.17 weiter zu leiten.

Ein ping von außen wird dann aber nicht klappen, weil
das ja nicht durchgereicht wird.

Für alles interne in deinem LAN ist das aber unerheblich.

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ping an die FB geht
-bash-3.2# ping 192.168.0.1
PING 192.168.0.1 (192.168.0.1): 56 data bytes
64 bytes from 192.168.0.1: seq=0 ttl=64 time=0.692 ms
64 bytes from 192.168.0.1: seq=1 ttl=64 time=0.579 ms
64 bytes from 192.168.0.1: seq=2 ttl=64 time=0.575 ms

--- 192.168.0.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 0.575/0.615/0.692 ms

-bash-3.2#

Muss ich jetzt nochwas machen?

Jetzt wollte ich Debian draufhauen und habe damit angefangen:
-bash-3.2# wget http://jeff.doozan.com/debian/dockstar.debian-squeeze.sh
wget: bad address 'jeff.doozan.com'
-bash-3.2#

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ah, dann fehlt ihm ein nameserver.

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also Ping von FB an DS geht auch...

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann deine FB DNS spielen?
Dann trag einfach bei deienem NAS mit einem Editor in der
Datei /etc/resolv.conf so etwas ein:
nameserver 192.168.0.1

Wenn nicht die FB, dann halt ein DNS außerhalb (hat dir dein
Provider mal mitgeteilt)

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
OK - Nameserver eingetragen - Jetzt komme ich online damit.

Wenn Du mir jetzt noch sagt, ob ich das auch in die /etc/init.d/rcS 
eintragen kann, damit das auch nach einem Neustart geht, bist Du mein 
Retter vom Wochenende :-)

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es gibt bestimmt schon ein Skript in init.d, in dem der Netzwerkkram 
hochgefahren wird.
Da ist wahrscheinlich eine Fallunterscheidung
(switch...case...case...esac) drin won wegen
irgendein Parameter den Wert "start" oder "stop" hat.
Am Ende vom start-Zweig könnte man dann das ifconfig... und
route add.... eintragen.

Aber das würde ich nur als Notnagel machen; eigentlich gehört
es in Konf-Dateien.
Bei mir ist das /etc/network/interfaces :
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# original # The primary network interface
# original allow-hotplug eth0
# original iface eth0 inet dhcp


# The primary network interface (static IP)
auto eth1
iface eth1 inet static
        address 192.168.0.30
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
        mtu 1400
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 192.168.0.1 195.185.185.195
        dns-search wachtler.de
Hast du so eine Datei?
Das musst du dir ggf. anpassen. Auf jeden Fall wirst du eth1
gegen eth0 tauschen müssen (das ist beimir eth1, weil ich eine
GBit-Karte reingesteckt habe und deshalb eth0 auf dem Mainboard
nicht nutze).

Nicht alle vertragen hier die dns-Einstellungen.

Die DNS-Einstellung in /etc/resolv.conf bleibt ja stehen,
falls es über die interfaces-Datei nicht geht.

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
PS:
Alle geänderten Dateien würde ich mir irgendwo sichern,
falls mal bei einem Update alles platt gemacht wird und
die Raterei von vorne losgeht...

Autor: Peter (Gast)
Datum:
Angehängte Dateien:
  • rcS.txt (357 Bytes, 110 Downloads)

Bewertung
0 lesenswert
nicht lesenswert
Habe die /etc/network/interfaces nicht auf der Dockstar.

Im Anhang nochmal die org. /etc/init.d/rcS
(Ich vermute das das so eine Art "autostart.bat" ist)

Ich würde es dort so eintragen:
/sbin/ifconfig lo 127.0.0.1
/sbin/ifconfig eth0 192.168.0.17 broadcast 192.168.0.255 netmask 255.255.255.0 up
/sbin/route add default gw 192.168.0.1

anstelle von
hostname Pogoplug

ifconfig lo 127.0.0.1
ifconfig eth0 169.254.37.133
udhcpc -b `hostname`


Traue mich nur nicht richtig - nicht das ich nach einem Neustart gar 
nicht mehr raufkomme...

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
das muß bleiben:
ifconfig lo 127.0.0.1

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das:
udhcpc -b `hostname`
weiß ich nicht, was es macht.
Lass es mal stehen; wahrscheinlich wird es ein broadcast lostreten um 
einen DHCP-Server zu suchen.
Wenn du so einen hast, dann reicht es wahrscheinlich, das
ifconfig eth0 169.254.37.133
zu ändern in:
ifconfig eth0 192.168.0.17

Wenn nicht, dann halt das volle ifconfig von oben eintragen und
ggf. an den Schluß der Datei das route add... nachtragen.

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wahrscheinlich war ifconfig eth0 169.254.37.133 der Bösewicht;
damit bist du nicht im 192.168.0.* und bekommst kein dhcp mehr
zugeteilt.

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
sehe gerade:
hostname Pogoplug
muss auch drin bleiben.

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Klaus Wachtler schrieb im Beitrag #1899314:
> Feigling!


Jetzt habe ich es erst recht probiert und mir während der Bootzeit nen 
Bier geholt

...
...
...

Und es geht - Jetzt kann ich berühigt weiter machen.

DANKE DIR - darfst Dir auch nen Bier holen...

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
In Kürze mein Vorschlag:
#! /bin/sh

mount -t proc none /proc
mount -t sysfs none /sys
mount -t devpts none /dev/pts
mount -t tmpfs none /tmp
mkdir /tmp/var

echo "/tmp/core_%e_%t" > /proc/sys/kernel/core_pattern

hostname Pogoplug

ifconfig lo 127.0.0.1
ifconfig eth0 192.168.0.17 broadcast 192.168.0.255 netmask 255.255.255.0 up
udhcpc -b `hostname`

# ggf auskommentieren, wenn er nicht raus kommt:
# /sbin/route add default gw 192.168.0.1

telnetd
/etc/init.d/db
ntpd -g

#/etc/init.d/hbmgr.sh start

#/bin/mount -a

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ok
Wohin soll ich die Rechnung schicken?

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
AN

peter@vorderDockstar.de

:-)

Autor: Klaus Wachtler (mfgkw)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wohl einfacher, wenn du ein paar Euro an Ärzte ohne Grenzen o.s.ä. 
spendierst...

Autor: Jay B. (jay_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
boah...
wer DEMAßEN garkeine ahnung von linux hat, sollte wirklich dhcp auf 
der fritzbox anmachen und das benutzen...

damit holt sich die dockstar nämlich auch als jungfrau eine ip und setzt 
alle diese von hand zusammengeknaupten sachen von selbst richtig...

jay

Autor: Toralf Wilhelm (willi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@ Peter
als Anfänger, schau Dir mal bei den Jungs vom Streamboard die Dockstar 
Seiten an. [[http://streamboard.gmc.to/wbb2/thread.php?threadid=29121]]

Gruß Willi

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hat irgendjemand gesagt, das ich von Linux keine Ahnung habe?

Habe hier mehrere VDR am laufen, die ich ohne Probleme eingerichtet 
habe.
Nur den Teil mit der Netztwerkkonfiguration war bei den VDR Distis 
einfacher.

Möchte mit der Dockstar meinen jetzigen Stromfressenden Server(Freenas) 
nur ersetzen.

Autor: Jay B. (jay_)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hi,

Peter schrieb:
> Hat irgendjemand gesagt, das ich von Linux keine Ahnung habe?
bei der art von frage und nachfragen hast du das selbst bewiesen; 
insofern hast du es uns selbst "gesagt" :-)

> Habe hier mehrere VDR am laufen, die ich ohne Probleme eingerichtet
> habe.
> Nur den Teil mit der Netztwerkkonfiguration war bei den VDR Distis
> einfacher.
wer eine consumer dist einlegen und deren fragen beantworten kann, hat 
noch lang keine ahnung von linux...

> Möchte mit der Dockstar meinen jetzigen Stromfressenden Server(Freenas)
> nur ersetzen.
ja. das ist immer eine gute idee... aber ich kann mir so recht keinen 
vernünftigen grund vorstellen, weshalb man keinen dhcp server im netz 
hat (es sei denn, man kann auch diesen nicht bedienen)...

jay

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.