mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Warum ist die Spannung nicht stabil?


Autor: Ben (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich steuere mit einem Microcontroller ein Grafikdisplay (Dip122) an. Das 
LCD braucht laut Datenblatt eine Kontrastspannung von ca -4V.

Das Display habe ich wie im Bild links gezeigt beschaltet: Der LT1054 
liefert dabei -12 V, die über einen Spannungsteiler mit einem Poti 
genauer  auf -4V eingestellt werden kann. Die +12V liefert ein 
Netzgerät, das genügend Strom liefern kann. Wie ich die +12V auf 5V für 
die Betriebsspannung des Displays wandle, ist im Bild rechts 
dargestellt.

Folgendes Problem tritt auf:
Wenn ich das Display nicht anschließe, habe ich Bei VCC konstant +5V und 
die Kontrastspannung liefert auch die -4V. Sobald ich aber das Display 
anschließe, beträgt die Kontrastspannung nur noch gut -2V, weshalb man 
fast nichts auf dem Display erkennen kann.
Außerdem beträgt VCC nicht mehr exakt 5V, sondern etwas weniger. Dieser 
Effekt fällt noch größer aus, wenn ich noch zusätzlich mehr Strom z.B. 
durch das Einschalten von LEDs fließen lasse.

Kann mir bitte jemand sagen, woran das liegt, bzw. wie ich dem Ganzen 
entgegenwirken kann?

Vielen Dank!

Autor: Andi ... (xaos)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wieso hängt am Vout vom LT das +12V Net wie am power supply ??

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Was ist DAS ?

D3 und D4 haben welchen Sinn ?  Du wolltest nur mal die Bastelkiste leer 
bekommen ?

Ist V+ vom LT1054 auch an irgendwas angeschlossen ? Wer VOUT mit 12 
verbindet, muß sich nicht wundern.

Und wenn statt 12 mehr als 24V kommen, was geht dann kaputt ? Und warum 
ist die Schaltung so gebaut, daß dann was kaputt geht ?

Mit dem R78B50 hast du ja zum teuersten Bauteil gegriffen, was es so 
gibt, also am Geld kann's bei dir nicht liegen...

Autor: Micha H. (mlh) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ben schrieb:
> Außerdem beträgt VCC nicht mehr exakt 5V, sondern etwas weniger. Dieser
> Effekt fällt noch größer aus, wenn ich noch zusätzlich mehr Strom z.B.
> durch das Einschalten von LEDs fließen lasse.

Das liegt vermutlich an L1210, dessen Serienwiderstand dürfte zu groß 
sein. Aber nicht nur da sieht Deine Netzteilschaltung recht sonderbar 
aus.

Was sollen die +12V am Ausgang des LT1054 bewirken?

Autor: Ben (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> wieso hängt am Vout vom LT das +12V Net wie am power supply ??
sorry, die Darstellung war falsch. Auf meiner Platine ist es natürlich 
so, wie jetzt angehängten Bild. Entschuldigung, dass ich damit 
Verwirrung gestiftet habe.

> D3 und D4 haben welchen Sinn ?  Du wolltest nur mal die Bastelkiste leer
> bekommen ?
Das soll wohl ein Überspannungsschutz sein.
Wie nicht allzu schwer festzustellen ist, bin ich nicht der 
Über-E-Techniker und habe deshalb die Beschaltung von einem Bekannten 
übernommen. Ich verwende in einem anderen Aufbau die selbe Schaltung in 
Verbindung mit einem R-785.0-1.0. Da hab ich keine Probleme mit 
Spannungsschwankungen. Ich habe mich dieses mal für den R-78B5.0-1.5 
entschieden, weil ich wohl mehr Strom brauche.

Kann mir jetzt nach Berichtigung der Schaltung jemand sagen, woher die 
Spannungsschwankung kommt?

Autor: Micha H. (mlh) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ben schrieb:
> Kann mir jetzt nach Berichtigung der Schaltung jemand sagen, woher die
> Spannungsschwankung kommt?

Ich sehe keine Berichtigung der Netzteilschaltung. Meine ursprüngliche 
Aussage steht noch.

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Micha H. schrieb:
> Das liegt vermutlich an L1210, dessen Serienwiderstand dürfte zu groß
> sein. Aber nicht nur da sieht Deine Netzteilschaltung recht sonderbar
> aus.

> Was sollen die +12V am Ausgang des LT1054 bewirken?

Meine Berichtigung bezieht sich auf deinen letzten Satz. Die +12V liegen 
natürlich nicht am Ausgang des LT1054, sondern an seinem Eingang.

Das mit dem Serienwiderstand an L1210 verstehe ich nicht. Du meinst 
also, dass die Spule einen zu großen Widerstand hat? Ich könnte die 
Spule ja mal überbrücken. Allerdings liegt es ziemlich sicher nicht 
daran, da ich wie gesagt in einem anderen Aufbau die selbe Schaltung 
verwende und da passt alles.

Ich bin ratlos...

Autor: Micha H. (mlh) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ben schrieb:
> Ich könnte die Spule ja mal überbrücken.

Tu das doch mal, kostet ja nichts.

> Allerdings liegt es ziemlich sicher nicht daran

Dann ist ja gut ;-)

Autor: Dennis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hoffe du möchtest mit R5 so nicht den Kontrast einstellen...oder was 
macht der?

Autor: Dennis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ah, seh grad, das is die Beleuchtung...

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Spule hab ich überbrückt. Wie erwartet, keine Veränderung.

Autor: Mike J. (linuxmint_user)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie viel Strom fließt denn in den VEE Eingang ?

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mike J. schrieb:
> Wie viel Strom fließt denn in den VEE Eingang ?

Weiß ich nicht. Und ich weiß leider nicht, wie ich das messen könnte. 
Sorry, wie gesagt, ich bin nicht soooo fit.

Autor: Pascal H. (pase-h)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ben schrieb:
> Weiß ich nicht. Und ich weiß leider nicht, wie ich das messen könnte.

Multimeter?

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Pascal Haury schrieb:
> Multimeter?

äh ja, schon klar. Aber soweit ich weiß, muss man Strom doch seriell 
messen. D.h. ich muss doch mit meinem Multimeter zwischen Pin und Pad. 
Ehrlich gesagt weiß ich nicht, wie ich das anstellen soll.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Auf meiner Platine ist es natürlich
> so, wie jetzt angehängten Bild.

Das dürfte die Ursache sein.

Du hast deine Schaltung genau so nachlässig aufgebaut wie du deinen 
Schaltplan gezeichnet hast.

Denn PRINZIPIELL funktioniert deine Schaltung,  auch wenn einige 
Bauteile überflüssig sind oder zumindest unglücklich gewählt.

Da wird wohl was am Aufbau vergurkt sein.

1mA liefert der LT1054, und er macht die -12V ja aus den +12V, also gar 
nicht aus den 5V die dir (leicht) einbrechen.

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
MaWin schrieb:
> 1mA liefert der LT1054, und er macht die -12V ja aus den +12V, also gar
> nicht aus den 5V die dir (leicht) einbrechen.
hab ich ja auch nie behauptet, dass die -12V aus den 5V entstehen.

Ich kann dir versichern, dass ich sicher nicht leichtsinnig war beim 
Zeichnen des Schaltplans und auch nicht beim Aufbau der Platine. 
Allerdings ist der Schaltplan im Ganzen schon recht groß und ein 
ANfänger macht nun mal Fehler.

Ich vermute, dass wohl der teure R-78B5.0-1.5 hinüber ist. Weil als ich 
die Power Supply Schaltung aufgebaut hatte, hatte ich tatsächlich für 
kurze Zeit einen Kurzschluss drin. Da aber danach immer noch 5V 
rauskamen, dachte ich, ich hätte nochmal Glück gehabt. Und jetzt kommt 
diese nicht konstante Spannung. Dann liegts wohl daran, oder?

Autor: bla (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi.

Also lass des mal mit dem Trimmer und dem R22 am Ausgang von dem LT1054. 
Im Datenblatt zum 1054 gibts ne bessere Beschaltung (Typical 
Applications, Basic Voltage Inverter/Regulator). Mit der angegebenen 
Formel kannste dann ja auch alles berechnen.

Um welchen Betrag brechen denn die 5V ein?

MaWin. Er hat vermutlich genauso nachlässig seine Schaltung aufgebaut, 
wie du die Schilderung seines Problems gelesen hast.

 -bla-

Autor: Mike J. (linuxmint_user)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ben schrieb:
> D.h. ich muss doch mit meinem Multimeter zwischen Pin und Pad.

Du kannst auch in das Datenblatt schauen.

Wenn das nicht vorhanden ist oder sich ein andere Fehler eingeschlichen 
hat kannst du die Leitung zum VEE Pin durchtrennen und mit einem 
Widerstand (10 bis 100 Ohm) wieder überbrücken.
(Ich gehe mal davon aus dass es ein Prototyp oder ein Testboard ist.)

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bla schrieb:
> Hi.
>
> Also lass des mal mit dem Trimmer und dem R22 am Ausgang von dem LT1054.
> Im Datenblatt zum 1054 gibts ne bessere Beschaltung (Typical
> Applications, Basic Voltage Inverter/Regulator). Mit der angegebenen
> Formel kannste dann ja auch alles berechnen.
Ich hab ja meine Schaltung nach dem Basic Voltage Inverter aufgebaut. 
Und an dem Trimmer kanns doch eigentlich nicht liegen. Ich hab halt 
jetzt alles schon in SMD fertig und solche Änderungen sind im Nachhinein 
recht schwierig. Vor allem, weil ich auch keine weiteren Bauteile wie 
andere Widerstände da hab.

> Um welchen Betrag brechen denn die 5V ein?
Wie gesagt: je mehr ich das Ganze Belaste, desto mehr weicht die 
Spannung von den 5V ab. Wenn ich alles einschalte (dann fließt wohl gut 
1A), beträgt die SPannung nur noch 4,6V. Das ist doch einiges.

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mike J. schrieb:
> (Ich gehe mal davon aus dass es ein Prototyp oder ein Testboard ist.)

nein, leider kein Testboard. Sondern ne fertige Platine ;-)

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mir fällt gerade ein, dass ich noch einen anderen DC/DC-Wandler da habe. 
Zum Testen löte ich jetzt mal den R-78B5.0-1.5 aus und versuchs mit dem 
anderen. Ich meld mich dann wieder.

Autor: bla (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ben schrieb:
> Wie gesagt: je mehr ich das Ganze Belaste, desto mehr weicht die
> Spannung von den 5V ab. Wenn ich alles einschalte (dann fließt wohl gut
> 1A), beträgt die SPannung nur noch 4,6V. Das ist doch einiges.

Die 1A misst du wo? Vor oder hinter dem DC/DC converter?
Das der DC/DC en Schlag hat, glaube ich nicht so wirklich. Immerhin hat 
der doch laut dem Datenblatt eine Kurzschlussstrombegrenzung bzw. einen 
Kurzschluss-Schutz.

Ben schrieb:
> Ich hab ja meine Schaltung nach dem Basic Voltage Inverter aufgebaut.
> Und an dem Trimmer kanns doch eigentlich nicht liegen. Ich hab halt
> jetzt alles schon in SMD fertig und solche Änderungen sind im Nachhinein
> recht schwierig. Vor allem, weil ich auch keine weiteren Bauteile wie
> andere Widerstände da hab.

Ja, das habe ich auch gesehen als ich das Datenblatt überflogen habe. 
Als Basic Voltage Inverter / Regulator ist halt die Spannung nicht mehr 
so vom Strom abhängig. Da stellst du dann die Referenzspannung einmal 
ein und hast konstante -4V am Ausgang. Das ist dann eben leichter, als 
einen Spannungsteiler zu konstruieren, im Leerlauf abzugleichen und sich 
dann zu wundern, wieso es bei einer Belastung des Spannungsteilers zu 
einem Zusammenbruch der vorher eingestellten Spannung kommt. Aber ist ja 
nur en Vorschlag. Musste ja nich umsetzen.

-bla-

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also der R-78B5.0-1.5 wars nicht. Ich hab wie gesagt nen anderen 
Schaltregler drangehängt und da ist das selbe in grün:

Wenn ich das Display abstecke und keine LEDs o.Ä. anschalte, bekomm ich 
bei VCC 4,96V (also ziemlich genau 5V) und am Kontrastpin -4V.
Wenn ich dann z.B. 2 Sieben-Segment-Anzeigen anschalte, bekomm ich nur 
noch VCC = 4,88V und am Kontrastpin liegen weiterhin -4V an.
Und wenn ich dann zusätzlich noch das Display aufstecke, messe ich VCC = 
4,86V und am Kontrastpin nur -2,06V.

Ich habe keine Ahnung, wo der Fehler liegt. So ne Scheiße, echt...

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bla schrieb:
> Ja, das habe ich auch gesehen als ich das Datenblatt überflogen habe.
> Als Basic Voltage Inverter / Regulator ist halt die Spannung nicht mehr
> so vom Strom abhängig. Da stellst du dann die Referenzspannung einmal
> ein und hast konstante -4V am Ausgang. Das ist dann eben leichter, als
> einen Spannungsteiler zu konstruieren, im Leerlauf abzugleichen und sich
> dann zu wundern, wieso es bei einer Belastung des Spannungsteilers zu
> einem Zusammenbruch der vorher eingestellten Spannung kommt. Aber ist ja
> nur en Vorschlag. Musste ja nich umsetzen.

Ich würde das wirklich gerne versuchen, aber wie ich oben schon 
geschrieben habe, ist die Platine bereits fertig da, sodass ich nicht 
viel ändern kann. Und ein Umstieg auf die Basic Voltage Inverter / 
Regulator ist nicht so einfach möglich, da ich drei zusätzliche Bauteile 
dafür unterbringen muss (die ich auch gar nicht da habe). Und der 
Einbruch von VCC ist doch auch alamierend. Da stimmt doch was anderes 
nicht.

Autor: bla (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das muss alles nicht soo genau sein. Immerhin hat dein Multimeter ja 
auch noch ne prozentuale Abweichung abhängig vom Messbereich. Sagen wir 
statt 4,86V lieber mal 4,9V. Das ist doch eigentlich in Ordnung. Bissel 
Zusammenbruch hat man immer. Wird der denn heiß? Und wo misst du denn 
die 1A? VOR oder HINTER dem DC/DC Converter?

Eigentlich haste ja nur des Problem mit dem Kontrast. Probier doch 
einfach mal meinen Vorschlag aus. Musste halt kratzen und tetzeln. Den 
Trimmer kannste weiterhin als R1 (siehe Datenblatt zum LT1054) nutzen. 
Den R22 vieleicht als R2 (Datenblatt). Musste ma nachrechnen.

-bla-

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bla schrieb:
> Das muss alles nicht soo genau sein. Immerhin hat dein Multimeter ja
> auch noch ne prozentuale Abweichung abhängig vom Messbereich. Sagen wir
> statt 4,86V lieber mal 4,9V. Das ist doch eigentlich in Ordnung. Bissel
> Zusammenbruch hat man immer. Wird der denn heiß? Und wo misst du denn
> die 1A? VOR oder HINTER dem DC/DC Converter?

Ah ok. Also der Abfall ist also OK? Ich dachte, da müsste unabhängig von 
der Belastung 5V bereit stehen. Aber sowas weiß ich nicht. Und wenn du 
sagst, dass das normal ist, dann beruhigt mich das schon mal.

Die 1A hab ich gar nicht gemessen. Die Angabe bezog sich auf den STrom, 
der insgesamt fließt, wenn ich alles anschalte und war nur ne Schätzung.

Und OK, ich überleg mir das mit der Umstellung auf Basic Voltage 
Inverter / Regulator. Begeister bin ich zwar nicht, aber wenns gar nicht 
anders geht, muss die Bastellösung eben reichen.

Dank dir schonmal für deinen Tipp!

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ah ja. Heiß wird Gott sei Dank nichts.

Autor: bla (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn nix heiß wird, dann überlastest du auch nix. Dann hat der 
Zusammenbruch (so schlimm ist der ja auch nicht) evt. andere Gründe 
(Längsdioden als Verpolungsschutz, usw.). Oder das Ding ist eben einfach 
scheiße. Aber ich sehe den Einbruch von 0,1 V nicht als dramatisch an. 
Die nachfolgende Elektronik hat ja auch Toleranzen. Ob du nun deinen µC 
mit 5V oder 4,9V betreibst ist ihm ziemlich egal. Und 4,9V sind ja 
eigentlich auch 5V. Kannst ja mal en Poti an den ausgebauten DC/DC 
anschließen und verschiedene Werte einstellen. Dann siehst du ja, obs am 
DC/DC oder deiner Schaltung hängt.

-bla-

Autor: Bernhard R. (barnyhh)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich vermisse eine wichtige Frage:
Woher kommen die 12 V Eingangsspannung?

Die fallen doch nicht vom Himmel, und ich denke, daß dort der Wurm 
liegt.

Bernhard

Autor: bla (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Bernhard,

mit deiner Frage hast du natürlich recht. Ich hatte dazu folgende 
Annhame: Der DC/DC hat ja einen Weitbereichseingang. Er braucht demnach 
also mindestens 5V Eingangsspannung. Wenn nun die 12V auf unter 5V 
zusammenbricht, dann müsste sich die Spannungsquelle, die die 12V 
bereitstellt geruchlich bemerkbar machen. Und beim LT1054 dürfte sich 
die Ausgangsspannung wohl auf wenige Millivolt reduzieren. Deswegen habe 
ich diese Frage nicht gestellt.

-bla-

Autor: Ben (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bernhard R. schrieb:
> Ich vermisse eine wichtige Frage:
> Woher kommen die 12 V Eingangsspannung?
>
> Die fallen doch nicht vom Himmel, und ich denke, daß dort der Wurm
> liegt.

Antwort:
Ben schrieb:
>> Die +12V liefert ein Netzgerät, das genügend Strom liefern kann (4A).

bla schrieb:
> Aber ich sehe den Einbruch von 0,1 V nicht als dramatisch an.

0,1V ist nicht dramatisch. Aber wenn ich wie gesagt alles einschalte, 
was ich so auf meiner Platine hab, dann bricht die Spannung auf ca 4,6V 
ein. Der µC arbeitet dabei noch problemlos. Ich frage mich eben nur, ob 
so ein großer Einbruch "normal" ist, oder ob das nicht ein Fehler ist, 
der mit dem Problem meiner Kontrastspannung zusammenhängen könnte.

Von einem DC/DC-Wandler, der 15€ kostet würde ich nämlich eigentlich 
schon erwarten, dass ich konstant 5V von ihm bekomme. ABer ich bin ja 
Neuling und wenn ihr sagt, dass das normal ist, dann glaub ich das auch 
gerne.

Vielleicht kann mir noch jemand (neben bla) bestätigen, dass ich mir 
diesbezüglich keine SOrgen zu machen brauche.

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dieser RECOM Wandler ist ungeregelt, soweit ich weiß. Demnach ist es 
völlig in Ordnung wenn er etwas einbricht. Eine Kurve dazu lässt sich 
bestimmt im Datenblatt einsehen.

Autor: bla (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Man müsste halt nach wie vor noch wissen, wie hoch die Stromaufnahme 
deiner Schaltung ist. Der Hersteller gibt bis zu 3% Abweichung an, bei 
einem maximalem Strom von 1,5 A. Ziehst du nun mehr als 1,5A aus dem 
Ding, brauchste dich nicht wundern, dass die Spannung einbricht. Aber 
eigentlich müsste des Ding dann auch warm werden.

-bla-

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.