mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Ansteuerung SS 202S02 WIE?


Autor: Sucher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

kann mir bitte jemand erklären, wie man die "korrekte" Ansteuerung eines 
Solid-State Relays aus dem Datenblatt entnehmen kann?
So habe ich in einem Ansteuerungsschaltung bei 5V einen 1K + LowCurrent 
LED vor der Inpt ansteuerung ist. Wohl ist das erprobt in einer 
Heizungsteuerung. Das sind doch nur 5 mA oder? Schaltet da das SSR 
sicher durch?
Wo kann man im Datenblatt finden was der  Minimum-Ansteuerstrom ist ist, 
da steht nur was von IF 20mA.

Wie schaltet man das am besten an einen Atmega32 dran?

Vielen Dank
Achim

Autor: Fragender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Datenblatt ... welches Datenblatt ??

Autor: Sucher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

Wie wäre es mit 'Minimum trigger current'?

MfG Spess

Autor: Sucher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

das wären 8 mA oder? Aber unter Degradation steht:

Therefore in order to maintain proper operation, a design implementing 
these SSRs should provide at least
twice the minimum required triggering current from initial operation.

Jetzt wieder meine Ausgangsfrage:

5V--1K---lowCurrent Led----SSR----GRND  ==>.....das sind doch  nur 5mA

wie ist das nun "richtig"? Das war meine Frage.

Die Schaltung ist wohl erprobt ==> 
http://www.erfinderjo.de/Heizung_Schaltplan_1.JPG

Ich möchte nicht nur "klonen" sondern auch verstehen was ich mache...

In diesem Sinne
Achim

Autor: eProfi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich würde da eher den Bereich 100 Ohm vorschlagen.

Ein zu geringer Diodenstrom kann nämlich ins Auge gehen:
Die Triggerempfindlichkeit ist leicht unterschiedlich für positive und 
negative Halbwellen. Wenn der Strom gerade so an der Kippe steht, kann 
es sein, dass nur eine Halbwelle durchgelassen wird und die andere 
nicht.
Das SSR wirkt dann wie eine Diode, worauf sich vor allem induktive 
Lasten "freuen", sie brennen dann evtl. durch.

Autor: eProfi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Außerdem fällt mir noch auf:
wie kommst Du auf 5mA ?
Die würden fließen, wenn 5V am R abfallen würden. Du musst aber von den 
5V noch den Drop des Ausgangstransistors im µC und den der beiden LEDs 
abziehen. Da bleiben vielleicht 1-2mA übrig.

Du kannst ja den Schaltplanzeichner darauf hinweisen.

Autor: Sucher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

die 5 mA waren noch optimistisch gerechnet......

>>5V noch den Drop des Ausgangstransistors im µC und den der beiden LEDs
>>abziehen. Da bleiben vielleicht 1-2mA übrig.

..deshalb wundere ich mich ja

@eProfi also ist das auch dir unklar....

Wie schließt man so ein SSR "richtig" an einen ATMEGA an?

MfG
Achim

Autor: Sagender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zum richtigen Schalten benötigst du etwa 20mA (Forward voltage) bei 1.2V 
bis 1.4V (Pin3 und Pin4). Das wird durch den Widerstand und die LED 
realisiert. Wobei bei der low current LED keine mA angegeben sind. Ich 
gehe mal von 2mA aus !?

Auf alle Fälle würde ich noch ein snubber vorsehen:

http://www.st.com/stonline/products/literature/an/6785.pdf


Wenn du es etwas besser machen willst dann noch Überspannungsschutz vor 
und nach dem SSR, Sicherung und X-Kondensator. Aber das ist jedem selbst 
überlassen g

Autor: Sagender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich seh grad das SSR hängt direkt am uC. Das macht man besser mit einem 
FET der die 20mA schaltet.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mache an den Portpin 2 Widerstände mit 120 Ohm und mit 1Kohm dran.
Von dem 120 Ohm gehst Du auf ´das Solid-State-Relais und von dem 1Kohm
auf die Anzeige_LED, so daß praktisch beide LED mit ihren eigenen
Vorwiderständen parallel geschaltet sind.

Das funktioniert hier auch bei mir so.
MfG Paul

Autor: Sagender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul Baumann schrieb:
> Mache an den Portpin 2 Widerstände mit 120 Ohm und mit 1Kohm dran.
> Von dem 120 Ohm gehst Du auf ´das Solid-State-Relais und von dem 1Kohm
> auf die Anzeige_LED, so daß praktisch beide LED mit ihren eigenen
> Vorwiderständen parallel geschaltet sind.

Er arbeitet aber mit 5V und der Strom würde auf dem SSR bei 31mA liegen 
plus LED-Strom. Ist das nicht etwas viel für den Portpin !?

Autor: Paul Baumann (paul_baumann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>würde auf dem SSR bei 31mA liegen
>plus LED-Strom. Ist das nicht etwas viel für den Portpin !?

Wie kommst Du darauf? Im Datenblatt steht eine Flußspannung von 3 Volt
für die LED im SSR. 5V-3V=2V/120 Ohm ->knapp 17mA.

Flußspannung der Anzeige LED, um die 2 Volt. 5V-2V= 3V/1000 Ohm=3mA.

17mA+3mA=20mA

->Funktioniert. Auch in Natura.

MfG Paul

Autor: Sucher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

um noch mehr zur Verunsicherung beizutragen und zu meinem Verständnis. 
Wo steht da was von 3 V Flußspannung?

Forward Voltage ist doch 1,2V  und 1V Dropout am Atmega (oder wieviel 
ist das)

Dann würd 2,8V/120Ohm = 23 mA ergeben oder?

Also ist doch mein Klärungsbedarf wichtig gewesen.

Ich bitte weiterhin um Aufklärung....

MfG
Achim

PS: Ich habe nochmal eine Schaltung gefunden, die mir plausibel 
erscheint und mit Berechnung
==> http://www.ulrichradig.de/forum/download/file.php?id=375

Autor: Sagender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul Baumann schrieb:
> Wie kommst Du darauf? Im Datenblatt steht eine Flußspannung von 3 Volt
> für die LED im SSR. 5V-3V=2V/120 Ohm ->knapp 17mA.
>
> Flußspannung der Anzeige LED, um die 2 Volt. 5V-2V= 3V/1000 Ohm=3mA.
>
> 17mA+3mA=20mA

Bei mir steht Vf 1.2-1.4V und If 20mA. 3V sehe ich nur bei der 
Durchbruchspannung Vr, die sollte man wohl eher meiden wenn man länger 
etwas vom SSR  haben will.

> ->Funktioniert. Auch in Natura.

Fragt sich nur wie lange.

Autor: Sagender (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Sucher schrieb:
> Forward Voltage ist doch 1,2V  und 1V Dropout am Atmega (oder wieviel
> ist das)
>
> Dann würd 2,8V/120Ohm = 23 mA ergeben oder?

Die 1V bei der Schaltung beziehen sich auf den Transistor, der vom Port 
geschaltet wird. Dort kannst du auch einen FET einsetzen. Die Dioden 
sind etwas übertrieben finde ich.

Anbei noch die Appl. Note von Sharp mit diversen Schaltungsbeispielen.

Autor: Sucher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

@Sagender vielen Dank für die Appl. Note. Die Dioden sind doch im 
ULN2803 verborgen....und schaden doch nicht.

MfG
Achim

Autor: Sagender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sucher schrieb:
> vielen Dank für die Appl. Note. Die Dioden sind doch im
> ULN2803 verborgen....und schaden doch nicht.

Im ULN befindet sich nur eine Diode.

Autor: Sucher (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo

@Sagender..es geht nicht ums Rechthaben,aber in der "Schematics (Each 
Driver)" sind schon einige mehr wie nur die "Common FREE WHEELING 
Diodes"...

Zumindest habe ich die Berechnung so interpretiert.

==>http://www.reichelt.de/?;ACTION=7;LA=28;OPEN=0;IND...

MfG
Achim

Autor: Sagender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die 3 Dioden im Datenblatt sind die "parasitic diodes".

und dann noch:

The input and output parasitic diodes cannot be used as clamp diodes.


Ich denke die Dioden im Schaltplan sind externe Dioden (clamp diodes). 
Ansonsten würden dort 2 Widerstände am Transistor fehlen.

Diese Frage kann wohl nur der Autor selbst beantworten.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sagender schrob:
>Fragt sich nur wie lange.

Na ja, ich würde sagen: So 3 1/2 bis 4 Jahre bis heute im 
Dauerbetrieb...

Ich habe keine Lust, mich herumzuzanken.

MfG Paul

Autor: Sagender (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Paul Baumann schrieb:
> Ich habe keine Lust, mich herumzuzanken.

Das war auch nur als Hinweis gemeint.

Autor: eProfi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nimm die Schaltung wie im ersten Post, nur statt 1 kOhm nimm 100 - 150 
Ohm.
Dann fließen etwa (5-0,5-1,7-1,3)/100=15 mA  oder bei 150 Ohm 10 mA, 
gerade richtig.

Ich denke, das ist nicht so kritisch. Der Original-Aufbau mit 1,5 mA 
wird auch funktionieren, ist aber grenzwertig, würde ich nicht machen.

Wenn der Strom niedriger ist, altern die LEDs langsamer.


Paul, an Parallelschalten habe ich auch gedacht, bringt aber überall 
(Vreg, µC, Rs) mehr Verlustleistung. Eigentlich unnötig.

Autor: Paul Baumann (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Paul, an Parallelschalten habe ich auch gedacht, bringt aber überall
>(Vreg, µC, Rs) mehr Verlustleistung. Eigentlich unnötig.

Ja, bei 3 LED mit zusammen ca. 10 mA sind das schon 50 mW. Das sind 
schon
enorme Leistungen, die da in Wärme umgesetzt werden.

dämlich grins
Paul

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.