mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Bauteile aus Datenblatt lesen (IRS2453) Vollbrückentreiber


Autor: Rene Dittmann (renedittmann)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo habe mir diese Vollbrücke zugelegt um meine Igbts anzusteuern, nur 
bekomme ich leider keine vernünftigen Ausgangspegel um sie zu schalten.
Vielleicht liegt es daran das ich den Schaltplan nicht richtig deute.
Kann mir jemand von euch helfen? welche Bauteile, bzw. welche Größen 
würdet Ihr wählen für 100kHz?


Hier noch der Link zum Datenblatt
http://www.irf.com/product-info/datasheets/data/irs2453d.pdf

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja warum solltest du auch sagen was für IGBTs. 100kHz sind für die 
geringen Ausgangsströme schon recht viel. Vielleicht liegst daran, 
vielleicht sind auch die Bootstrapkondensatoren an Pin10 und 14 zu 
klein, oder das Tastverhältnis zu klein um die nachzuladen, oder....

Autor: Rene Dittmann (renedittmann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Als IGBT habe ich den IRG4Ph50U + 10ohm am GATE und an den Pin 10 und 14 
habe 2,2 nF Kerkos verbaut.

Für die 100KHz nehme ich als RT 3Kohm und als CT auch ein 2,2 nf Kerko

hier noch das Datenblatt vom IGBT
http://www.irf.com/product-info/datasheets/data/ir...

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Boostrapkondensatoren sind viel zu klein und können die Gateladung 
der IGBT nicht liefern und der HighSide-Treiber schaltet wegen 
Unterspannung ab. Mindestens 220nF einsetzen.

Autor: Rene Dittmann (renedittmann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Super.. danke für die Info.
Was würdest du für ein Elko an Pin1 und 2 empfehlen?

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Elko 22µ und keramischen Kondensator von mindestens 470n parallel.

Autor: Rene Dittmann (renedittmann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke das mit dem Elko verstehe ich aber was macht der kerko 470n 
parallel und warum ist der nicht im Datenblatt? Dachte es wäre so schön 
einfach.

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der Kondensator muss, sobald der LowSide-Treiber einschaltet, u.a. die 
BootstrapKondensatoren nachladen und die LowSide-Gates treiben. Dazu 
muss er einen hohen Stromstoß liefern, ohne das die Spannung nennenswert 
einbricht. Dazu ist ein Elko nicht gut geeignet.

Autor: Jemand (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ArnoR schrieb:
> Dazu ist ein Elko nicht gut geeignet.

Ist dafür ein Snubber besser geeignet ?

Autor: Rene Dittmann (renedittmann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Noch eine Frage: Kann ich zum Testen an AC+ und AC- auch erstmal die 
gleichen 15Volt anlegen oder muss die Spannung generell größer sein. 
Wollte erst später mit der größen Spannung arbeiten, wenn alles läuft?

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Jemand schrieb:

> ArnoR schrieb:
>> Dazu ist ein Elko nicht gut geeignet.
> Ist dafür ein Snubber besser geeignet ?

Was soll denn diese Frage? Das eine hat mit dem anderen nichts zu tun!

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Rene Dittmann

Ja.

Autor: Rene Dittmann (renedittmann)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wollte nur eine Fehlerquelle ausschließen. Werde das jetzt so aufbauen. 
Muss nur leider neue Bauteile bestellen. Oder habe ich dich bei den 
Bauteilvorschlägen falsch verstanden?

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So ist alles richtig.

Autor: Rene Dittmann (renedittmann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So alles ist da und verbaut. :-)

Habe jetzt auch am LOAD ca. 11 Volt ab leider nur DC
Die Schaltung zieht jetzt über 5A, wenn ich die Masse vom T3 entferne 
fällt der Strom auf 2,5 A ab.

Was kann denn jetzt noch falsch sein??

Habe ich jetzt meinen IC schon geschossen??  :-(

Hat einer noch eine Idee?

Autor: Rene Dittmann (renedittmann)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann ich die Schaltung ohne IGBTs testen oder ist die Rückmeldung an VS1 
und VS2 notwendig für die Frequenz?

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.