mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Wann ist ein µC kaputt ?


Autor: Andre R. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo ersteinmal,
die Frage hört sich vielleicht ein bischen komisch an, aber mein ATM
mega16 scheint nicht ganz zu funktionieren. Ich hab mir eine eigene
Platine gelötet und diese ist auch fehlerfrei, davon kann man
ausgehen.
Doch irgendwie hat der µC ein abnormales verhalten.
1. Die ports C0 & C1 und C6 & C7 funktionieren, die 4 dazwischen geben
kein Mucks von sich.
2. Wenn man ein wenig auf dem µC rumdrückt flckert eine LED (geht, geht
mal nicht) das liegt jedoch nich an der IC Verbindung oder an der
Platine (glaub ich jedenfalls).

Habs mit den Quellcodes aus den Tuts probiert (natürlich auf mein µC
angepasst). Benutze Win XP mit dem AVR Studio 4.

Jezz frage ich mich: "Hab ich den µC beim einbau igendwie geschrottet
?
und gibt es vielleicht ein Test-Programm mit dem man gucken kann ob
noch alles geht im µC ?"

Autor: edgar p (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
entweder haengt was in der luft oder du hast einen abblockkondensator
vergessen

Autor: Andre R. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
gute idee, denkst du das Problem wäre mit einem 100nF an der
Speisespannung behoben ?

Autor: Michael (ein anderer) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Deine Platine ist schrott, wenn durch rumdrücken auf der
Platine/Bauteile die Schaltung mal geht, und mal nicht.

Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Wenn man ein wenig auf dem µC rumdrückt flckert eine LED
>(geht, geht mal nicht) das liegt jedoch nich an der IC Verbindung
>oder an der Platine (glaub ich jedenfalls).

naja, das deutet aber schon irgendwie auf einen defekt am print hin...

Autor: Michael (ein anderer) (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Oder Deine Lötstellen sind eine Katastrophe...

Autor: Tux (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Ports C2 bis C5 können nur benutzt werden, wenn das JTAG Interface
über die FuseBits ausgeschaltet wurde.

Gruss Tux

Autor: Andre R. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke Tux, jetzt gehen dir Ports schonmal, wär ich nie drauf gekommen.
Und das Löten, naja also ich hab da eigentlich schon recht viel
Erfahrung. Aber ich check die nochmal.
Danke für die schnelle Hilfe !

Autor: MathiasM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vielleicht ein Haarriss in einer Leiterbahn?

Autor: Andre R. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hmm ich prüf das morgen nochmal alles durch.

Autor: Tim O. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mein Senf dazu :)

Ich hatte mal ne zeitlang dem 7805 blind vertraut und keine
Kondensatoren gespendet, dadurch gab es ziemlich genau die
von dir beschriebenen Symptome, durch "rumdrücken" hatte man
erreicht, das der durch die Spannung verwirrte Oszillator
doch mal nen paar Cycles gearbeitet hat.. naja, das würde
vielleicht das Flackern erklären, das durch deinen Körper
irgendwelche Spannungen störend wirken. Nen mega64 hab ich
hier bald mal vor mir, mal gucken wie mein erster Versuch
wird, bisher reichten die kleineren ;)

Gruss,
 Tim

Autor: nurmi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab auch mal eine woche an genau dem selben fehler gesucht:

ich sag nur: fuse bits - JTAG Interface ;)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.