mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Schaltung mit Optokoppler FOD0710


Autor: Matthis (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi!

ich möchte gerne einen galvanisch getrennten USB/TTL zu TTL/RS232 
Adapter bauen.
Nun bin ich leider nicht vom Fach und äußerst unsicher was die 
Beschaltung vom Optokoppler angeht.
Ich wäre sehr dankbar, wenn jemand der sich auskennt vielleicht kurz 
über meinen Schaltplan schauen könnte und mir sagen kann ob das so 
funktionieren kann, wie ich mir das gedacht habe.
Ich hab die teureren FOD0710 von Fairchild genommen, da sie nicht 
invertieren und nach dem Datenblatt schnell (ich brauche eine Baudrate 
von 115200) und leicht zu beschalten sind. Ich bin aber auch anderen 
Ideen mit einfachen Opto-Schaltungen nicht abgeneigt.
Nach den 6n137 hab ich auch schon gesucht und auch viel hier im Forum 
gefunden, aber soweit ich das erkenne invertieren die und um TTL zu 
entkoppeln sollten die mit Transistoren? beschaltet werden?
Vielen Dank im Vorraus für die Hilfe.

Gruß Matthis

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthis schrieb:
> aber soweit ich das erkenne invertieren die und um TTL zu
> entkoppeln sollten die mit Transistoren? beschaltet werden?
Jain.
Du mußt nur die LED so anschliessen, dass dann ein Strom fließt, wenn du 
an der anderen Seite 'low' willst. D.h. du mußt die LED nicht gegen GND 
anschliessend, sondern gegen Vcc. Das wars.
Aber natürlich muß der angeschlossenen Baustein die LED auch treiben 
können...

> Ich bin aber auch anderen
> Ideen mit einfachen Opto-Schaltungen nicht abgeneigt.
Nimm doch Magnetkoppler vom Schlage ADUM1400...

BTW: Was willst du an den Steckern U$2 und U$3 anschliessen? Das könnte 
Konflikte mit dem MAX bzw. FTDI geben...

Autor: Matthis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Danke für die schnelle Antwort,
die ADUM1400 schau ich mir mal an.

Mit U$2 und U$3 sollte es unkritisch sein, weil "entweder/oder" 
vorgesehen ist. U$3 wird nicht gleichzeitig mit U$4 und U$2 wird nicht 
gleichzeitig mit U$1 betrieben.

Gruß Matthis

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Matthis schrieb:
> U$3 wird nicht gleichzeitig mit U$4 und U$2 wird nicht
> gleichzeitig mit U$1 betrieben.
Es wird schon Prbleme geben, wenn du an diesen beiden etwas anschliessen 
willst und die beiden erwähnten Bausteine bestückt sind.
Als Tipp: das betrifft nur die TX-Leitung des jeweiligen Bausteins...

Autor: Matthis (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Noch ne Frage zu
"du mußt die LED nicht gegen GND anschliessend, sondern gegen Vcc."

Ich stell mir das jetzt wie im Anhang vor, wäre das richtig?
Und wie komm ich auf den Wert von R1? Ich hab den jetzt aus ner 
Schaltung, die ich gefunden habe, raus genommen.
Und ist es nötig Tx_In nochmal über nen Wiederstnad auf GND zu ziehen?
Und wenn ja, woher bekomme ich da den Wiederstandswert?
Betrieben wird alles mit +5V auch die Tx_In sollten 0V-5V sein (TTL 
halt).

Danke für die Mühe!
Gruß Matthis

Autor: Lothar Miller (lkmiller) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Der R3 muß weg, sonst leuchtet die LED immer "so halb".

> Und wie komm ich auf den Wert von R1?
Sieh im Datenblatt nach dem nötigen Strom und der Spannung für die LED. 
Der slbe Strom fließt durch den Widerstand und am Widerstnad fallen 
5V-Uled ab. Der Rest ist Ohmsches Gesetz...

Aber wie gesagt: der MAX und der FTDI muß den nötigen Strom treiben 
können. Sonst klappts nicht.

Autor: Matthis (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Es wird schon Prbleme geben, wenn du an diesen beiden etwas anschliessen
> willst und die beiden erwähnten Bausteine bestückt sind.
> Als Tipp: das betrifft nur die TX-Leitung des jeweiligen Bausteins...

Achso, ich glaub ich weiß was du meinst. Kann da vielleicht schon ne 
Diode abhilfe schaffen?

Gruß Matthis

P.S. ich glaub der ADuM1201 ist genau das was gesucht habe!

Autor: Bernd S. (soundgott)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ich hab da immer noch
ADUM1100 für 5 EUR + Porto für 25 Stücks liegen.....

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.