mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik H-Brücke mit µC - Transistor Schaltet nicht


Autor: Robert (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Schönen guten Tag.

Ich habe ein Problem mit der Ansteuerung meiner H-Brücke. Diese soll 
einen Motor(12V) ansteuern. Programm für den µC läuft auch soweit. 
Schließe ich die H-Brücke aber an die Platine an, fällt hinter den 
beiden Transistoren die Spannung ab.

Entweder bin ich nach 8 Stunden arbeiten an dem Projekt bereits 
Fehlerblind oder ich finde ihn einfach nicht.

Könntet ihr mir bitte weiter helfen?

ach noch paar wichtige Daten: die H-Brücke wird mit bis zu 10A belastet.


Mit freundlichen Grüßen

Robert

Autor: Martin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Transistoren: Emitter & Kollektor vertauscht.

Autor: ArnoR (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Sieht so aus als wären alle Transistoren falsch herum eingebaut.

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
BIst du ein PNP Freak, oder warum verwendest du überall PNP 
Transistoren? Selbst dort wo es eigentlich NPN sein müssten.

Mit 5V an der Basis kriegst du einen PNP nie zum Sperren an dessen 
Emitter 12V anliegen.


Edit: Moment, das sind ja gar keine PNP, das sind ja NPN die verkehrt 
rum eingebaut sind.
Aber selbst dann: einige deiner NPN müssen PNP sein

Autor: Robert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
oh sorry, vergessen zu drehen
hatte den Schaltplan vereinfacht und dann wieder falsch eingefügt

angeschlossen sind sie aber richtig.

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Robert schrieb:
> oh sorry, vergessen zu drehen
> hatte den Schaltplan vereinfacht und dann wieder falsch eingefügt
>
> angeschlossen sind sie aber richtig.

Dann mach da mal eine Reinzeichnung, damit man mal sieht was du da 
wirklich verbrochen hast.
Es können nicht alle Transistoren vom selben Typ sein.

Autor: Karl Heinz (kbuchegg) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier findest du eine H-Brücke mit der Art von Ansteurung die dir 
vorschwebt.
http://letsmakerobots.com/node/9450

Autor: Simon Huwyler (simi)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Stell Dir mal vor, die "oberen" Transistoren (NPN, "richtig" herum") 
schalten (vollständig) durch. Was hast Du dann für eine 
Basis-Emitter-Spannung? Und wie gross müsste die sein, damit ein 
Basisstrom (und somit ein Collectorstrom) fliessen kann?

--> Wie schon weiter oben gesagt. Das müssen PNPs sein (oder 'ne 
Bootstrap-Schaltung verwenden, um die Basis über die Versorgungsspannung 
hinaus anzulüpfen).

Gruäss
Simon

Autor: Raimund Rabe (corvuscorax)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Aber selbst wenn bei allen Transistoren die Emitter mit den Kollektoren 
getauscht würden, wäre immer noch das Problem, daß z.B. bei K5 und K8 
(und respektive K6 und K7) die Basen direkt miteinander verbunden wären. 
Damit würde dann zwar K8 (bzw. K6) leitend gemacht, aber K5 (bzw. K7) 
würde man so nie leitend bekommen.

Tse-tse-tse, es gibt so viele Beispiele im Internet zu finden, wo eine 
funktionstüchtige Vollbrücke gezeigt ist, aber diese hier ist richtig 
'verrissen'.

Übrigens fehlen noch (vier!) Schutzdioden von den beiden Motorklemmen 
nach (-) bzw. (+) der Versorgungsspannung, denn Motoren sind große 
Induktivitäten, welche beim Abschalten wohl gerne was tun würden ...?

Autor: Falk Brunner (falk)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@  Robert (Gast)

>ach noch paar wichtige Daten: die H-Brücke wird mit bis zu 10A belastet.

So klein (im Wissen) und schon so große Träume? Ach ja, das ist ja immer 
so. ;-)

Mein Tip. Backe erstmal kleine Brötchen und nimm eine fertige, 
integrierte H-Brücke. Der L6203 ist dein Freund, der schafft immerhin 4A 
Dauerstrom. Siehe H-Brücken Übersicht. Braucht aber bei Vollast 
einen kleinen Kühlkörper.

MFG
Falk

Autor: Robert (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielen dank für die schnelle Hilfe.

Bin heute irgendwie total neben mir, man sieht es ja schon an der 
Zeichnung, die Transistoren falsch eingezeichnet....

nun gut werde mich nu erstmal mit der H-Brücke beschäftigen.

vielen dank

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.