mikrocontroller.net

Forum: Platinen Eagle: SMD Bauteile lassen sich nicht routen


Autor: Wilfried Mellenthien (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo, ich brauche noch einmal Eure Hilfe. Nachdem es mir nun endlich
gelang, Bibliotheken zu erstellen, lassen sich nun die Teile nicht
"elektrisch" miteinander verbinden. (Siehe Bild)

Die selbstgezeichnete Spule liegt im Raster, aber der Schaltkreis nicht.
Ich habe schon probeweise das Raster auf "Feinstes" verstellt, aber der
Autorouter kann es nicht anschließen. Ein "Wackeln" mit gedrückter
StrG-Taste am Schaltkreis nützte nichts.

Was kann ich da tun?

Gruß Wilfried

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Meine Güte, LIES DAS HANDBUCH!!!
Was du da fabriziert hast, ist von vorne bist hinten unbrauchbar.

Im Handbuch ist eine kindgerechte Schritt-für-Schritt-Anleitung zum 
Erstellen von Bibliotheken mit Footrpint und Symbol für THT- und 
SMD-Bauteile.

Lies das, dann kommt auch eine Bibliothek raus, mit der Eagle umgehen 
kann.


P.S.: das Werkzeug, das da auf dem Screenshot grade aktiv ist, ist der 
Autorouter, nicht das Werkzeug zum Routen.
Lies das Handbuch, oder wenigstens das Tutorial...

Autor: Wilfried Mellenthien (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe doch nach dem Handbuch gearbeitet, glaube es mir...
 ;-)

Meine selbstgezeichnete Spule liegt offenbar trotzdem nicht im Raster.
Ich habe Dir mal die Bibliothek angehangen und hoffe, daß Du mir sagen
kannst, wie ich sie verändern muß, damit sie auch mit dem Autorouter
geroutet werden könnte, nicht nur von Hand.

Beim Zeichnen des Package und des Device habe ich doch die Einstellungen
des Rasters so genommen, wie sie waren.

Womit habe ich das verdient?

Gruß Wilfried

Autor: Wilfried Mellenthien (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Da kommt nichts mehr gell?

Aber ich weiß mittlerweile woran es liegt: Da mir die SMD-Pads zu klein
waren, habe ich im Layer "Top" die Pads mit Wires "dicker" gemacht.
Offenbar verträgt Eagle das nicht.

Jetzt suche ich eine Möglichkeit, die SMD-Pads der Spule größer zu 
machen,
denn die mechanische Last der Spule ist mir für die 2 Pads zu groß.

Weiß jemand außer Michael natürlich, ob und wie man das sonst machen 
kann?
Das Handbuch weiß es nämlich nicht.... :-(

Gruß Wilfried

Autor: Michael H. (michael_h45)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Wilfried Mellenthien schrieb:
> Ich habe doch nach dem Handbuch gearbeitet, glaube es mir...
Ich geh mal davon aus, dass die Spule ein bedrahtetes Bauteil ist.
Dann brachst du Pads. Pads: die Flächen, auf denen die Bauteilbeinchen 
landen.
Pads werden in Eagle per default grün dargestellt.
Siehe Anhang. Am unteren Pad hab ich deine Wires und SMDs noch 
dringelassen, damit zu den Zusammenhang siehst. Korrekt ist es so wie 
beim oberen Pad.

Aber gib mal einen Link zum Datenblatt an, damit man sich auch sicher 
sein kann, wie das Bauteil denn real ausschaut.

> Meine selbstgezeichnete Spule liegt offenbar trotzdem nicht im Raster.
Das ist egal. Verbindungen haben einen Fangradius, der größer als das 
Standard-Raster ist.

> Beim Zeichnen des Package und des Device habe ich doch die Einstellungen
> des Rasters so genommen, wie sie waren.
Das ist beim Device auch richtig so, beim Package aber nicht. Da musst 
du das Raster so wählen, dass du die Maße des Bauteil richtig übertragen 
kannst. Vor allem bei der Pad-Geometrie.


Ansonsten:

- Der Package-Name SPULE330 ist nicht sinnvoll. Sinnvoll wäre hier zum 
Beispiel "L-13x13mm". Ein Name, der das PACKAGE beschreibt, nicht einen 
Bauteilwert. Im Idealfall eine Herstellerbezeichnung oder etwas, das die 
Geometrie beschreibt.
Eine Spule mit 220µH kann es genauso in diesem Package geben.

- >Value- und >Name-Tags sind im falschen Layer. Die gehören in tValue 
und tName.

Autor: Wilfried Mellenthien (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Gut, Du bist also doch ein vernünftiger Mensch und schwatzt kein
wirres Zeug...;-)

Also: Die Spule ist ein SMD-Bauelement und sie stammt (wie der Regler
im gestrigen Artikel) aus einem Handy-Ladegerät von Pollin. Sie hat 
keine
Typenbezeichnung, nur die Induktivität steht drauf, so daß ich kein 
Daten-
blatt dafür angeben kann. Ich nahm die Maße mit der Schiebelehre ab.

> Meine selbstgezeichnete Spule liegt offenbar trotzdem nicht im Raster.
>>Das ist egal. Verbindungen haben einen Fangradius, der größer als das
>>Standard-Raster ist.

Gut zu wissen.

>>- >Value- und >Name-Tag sind im falschen Layer. Die gehöten in tValue
>>und tName.

Das werde ich gleich ändern.

Mittlerweile fand ich auch heraus, wie man die SMD-Pads in der Größe
verändern kann, so daß ich sie nicht mehr "von Hand" größer malen
mußte.

Autor: Ralf-Peter Grellmann (ralfpeter)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Wilfried,

um es "Eagle-Göttern" einfacher und nachvollziehbarer zu machen, hänge 
bitte keine gifs, png itd an, sondern das von Dir erzeugte 
Schematic-file. Habe mal Deine Spule.lbr ausprobiert (Verdrahtung gibt 
funktional keinen Sinn !!) - simsalabim es funktioniert.

Ralf-Peter

Autor: Michael H. (michael_h45)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wilfried Mellenthien schrieb:
> Mittlerweile fand ich auch heraus, wie man die SMD-Pads in der Größe
> verändern kann, so daß ich sie nicht mehr "von Hand" größer malen
> mußte.
Ja, jetzt hat das brauchbare Züge.
Das Symbol für eine Spule kannst du übrigens der LCR.lbr entnehmen.


Generell: du willst bei einem Schaltregler nicht den Autorouter 
ranlassen. Das wird nix.
Lieber die Layoutvorschläge aus Datenblatt oder Application-Note per 
Hand umsetzen.

Autor: Wilfried Mellenthien (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@Ralf Peter
>(Verdrahtung gibt
>funktional keinen Sinn !!) - simsalabim es funktioniert.

Ja, ich weiß, daß die Verdrahtung keinen Sinn ergibt, -das war nur mal
so schnell zusammengeklickt, um ein paar Verbindungen zu haben, damit
ich sehen konnte, ob es überhaupt kontaktiert werden kann.
Danke für Deine Hinweise.

@Michael
>Das Symbol für eine Spule kannst du übrigens der LCR.lbr entnehmen.

Ja, das mache ich auch. Ich wollte nur einmal ein Bauelement komplett
selbst zeichnen. Den Autorouter werde ich dafür nicht nehmen, ich richte
mich nach den Vorschlägen zur Leitungsführung im Datenblatt. Ich wollte
nur feststellen, ob es denn überhaupt mit dem Autorouter gehen würde.

Also dann: Noch einmal dank für die Hilfen an Euch.

Gruß Wilfried

Autor: Jörn Paschedag (jonnyp)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ahemm, wenn du bei deinen SMD pads auch noch die ROUNDNESS änderst 
bekommst du die Ecken auch noch abgerundet ;-)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.