mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik NE555 Blitzlicht


Autor: Dominik H. (super_flummy)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich will aus der Blinklichtschaltung mit dem NE555 ein Blitzlicht 
machen.
Jetzt hab ich mit einem 250k poti den Takt schon so langsam gemacht wie 
ich es haben will (pause zwischen denn Blitzen ). Nur wenn die LED dann 
blitzt ist sie noch zu lange an ( ca: 1 sec ). Wie kann ich es schneller 
blinken ( blitzen ) lassen ohne denn poti zu verändern?

Kann ich am NE555 pin3 Ausgang vielleicht einen Kondensator (pin3 und 
LED ) dran machen um eine schnellere Entladung zu bewirken so das es 
dann blitzt?

Danke schon mal

: Verschoben durch Moderator
Autor: Flip B. (frickelfreak)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Elko zwischen Ausgang und Led und antiparalell zur Led einen Widerstand 
+Diode(in serie)

Autor: H.Joachim Seifert (crazyhorse)
Datum:

Bewertung
0 lesenswert
nicht lesenswert

Autor: Dominik H. (super_flummy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi,

Danke. Ich hab jetzt nur einen 0,1µF dazwischen gesetzt und es 
funktioniert. Nur ist der Spannungsabfall zu hoch, so das die LED nur 
noch schwach Blitzt.

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schalte die LED (plus Vorwiderstand) statt von OUT nach GND von OUT nach
VCC. Vertausche R1 und R2 und nimm statt der 6,8k ggf. einen kleineren 
Wert.

Autor: Dominik H. (super_flummy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yalu X. schrieb:
> Schalte die LED (plus Vorwiderstand) statt von OUT nach GND von OUT nach
> VCC.

Hab ich jetzt gemacht.
Und anstatt denn 470 Ohm Vorwiderstand hab ich einen 220 Ohm rein 
gemacht.
Jetzt ist es heller und so wie es sein soll. Nur nach dem Blitz glimmt 
die LED noch nach! ca: 1sec

Autor: Yalu X. (yalu) (Moderator)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Dominik H. schrieb:
>> Schalte die LED (plus Vorwiderstand) statt von OUT nach GND von OUT nach
>> VCC.
>
> Hab ich jetzt gemacht.

Hast du den Kondensator und die Diode an der LED wieder ausgebaut und R1
und R2 vertauscht? Die Schaltung sollte so aussehen wie im Anhang.

Für R2>>R1 bestimmt R2 im Wesentlichen die Periodendauer und R1 die
Blitzdauer.

Autor: Dominik H. (super_flummy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ne die genannten Bauteile von dir hab ich nicht da.
Ich bin Wiedereinsteiger in das schöne Hobby Elektronik. Und außer 
0,1/3,3/10 µF, NE555, 470, 220, 430, 510 ohm hab ich nichts da. Muss mir 
mein Bauteil Magazin erst wieder zusammen kaufen.

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dominik H. schrieb:
> Ne die genannten Bauteile von dir hab ich nicht da.

Ich habe doch nur die Bauteile aus deinem Schaltplan anders zusammenge-
setzt. Deswegen dachte ich, es müsste alles vorrätig sein. Der 100k-
Widerstand soll dabei dein 250k-Poti in Mittelstellung repräsentieren.

Aber es müssen ja auch nicht exakt diese Bauteilwerte sein. Ich wollte
nur zeigen, wie man den NE555 beschalten kann, dass die Einschaltdauer
der LED deutlich kleiner als die Periodendauer ist. Da bei dieser Stan-
dardschaltung ohne eine zusätzliche Diode die High-Phase am Ausgang
immer länger als die Low-Phase ist, muss die LED eben so angeschlossen
werden, dass sie bei Low leuchtet. Und damit ein Blitz- und kein Blink-
licht entsteht, muss der untere der beiden Widerstände (R1 in meiner
Schaltung) relativ klein und der obere (R2) relativ groß sein. Falls du
keinen 6,8k-Widerstand hast, kannst du natürlich auch 510Ω versuchen.
Allerdings wird das Aufblitzen dann so kurz, dass de es evtl. kaum noch
wahrnimmst.

Autor: Dominik H. (super_flummy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yalu X. schrieb:
> Ich habe doch nur die Bauteile aus deinem Schaltplan anders zusammenge-
> setzt. Deswegen dachte ich, es müsste alles vorrätig sein. Der 100k-
> Widerstand soll dabei dein 250k-Poti in Mittelstellung repräsentieren.

Ach so ja dann.
Ich muss noch viel Lehren.

Dann mach ich mich mal ans löten und schau mal.


Vielen Dank

Autor: Dirk J. (dirk-cebu)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dominik H. schrieb:
> Ich muss noch viel Lehren.

Lernen, nicht lehren!
Der Schüler lernt, der Lehrer lehrt und der Müllmann leert die 
Mülleimer;)

Autor: Dominik H. (super_flummy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dirk J. schrieb:
> Dominik H. schrieb:
>> Ich muss noch viel Lehren.
>
> Lernen, nicht lehren!
> Der Schüler lernt, der Lehrer lehrt und der Müllmann leert die
> Mülleimer;)

Sorry. Ich schreib immer zu schnell.

Ich hab gestern die Schaltung ausgebaut, aber irgendwie funktionierte es 
nicht. Vielleicht liegt daran das ich einen 10µ anstatt einen 100n 
genommen habe da ich die Bauteile nicht hatte oder weil ich etwas falsch 
zusammen gelötet habe. Auf jeden Fall ab ich mir jetzt die richtigen 
Bauteile bestellt und auch Basismaterial so wie Natriumpersulfat damit 
ich mir die Schaltung mal auf eine Platine aufbauen kann. Dann hab ich 
nicht diese Verkabellei und bessere Übersicht wo was hin geht.

Autor: Dominik H. (super_flummy)
Datum:
Angehängte Dateien:
  • preview image for 01.jpg
    01.jpg
    49,2 KB, 714 Downloads
  • preview image for 02.jpg
    02.jpg
    82,3 KB, 673 Downloads

Bewertung
0 lesenswert
nicht lesenswert
Yalu X. schrieb:
> Dominik H. schrieb:
>>> Schalte die LED (plus Vorwiderstand) statt von OUT nach GND von OUT nach
>>> VCC.
>>
>> Hab ich jetzt gemacht.
>
> Hast du den Kondensator und die Diode an der LED wieder ausgebaut und R1
> und R2 vertauscht? Die Schaltung sollte so aussehen wie im Anhang.
>
> Für R2>>R1 bestimmt R2 im Wesentlichen die Periodendauer und R1 die
> Blitzdauer.

Hi,

ich hab jetzt eine Platine mit der Schaltung geätzt und bestückt. Aber 
ich habe keinen Blitz sondern ein dauer Leuchten :(

Im Anhang hab ich die Platine und den Schaltplan.

Wo ist denn der Fehler?

Danke
Dominik

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hast du die nicht geroutete Verbindung von Pin 2 nach Pin 6 von Hand
verdrahtet oder einfach weggelassen?

Autor: Simon K. (simon) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du kannst die verbleibende Leitung einfach über dem NE555 lang legen...

Autor: Dominik H. (super_flummy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yalu X. schrieb:
> Hast du die nicht geroutete Verbindung von Pin 2 nach Pin 6 von Hand
> verdrahtet oder einfach weggelassen?

Doch hab ich gemacht.

Autor: Thomas S. (thomas_s74)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du kannst eine Monostabile kippstufe mit einer A-stabilen kippstufe 
triggern. Dann lassen sich Frequenz und Blitzdauer getrennt von einander 
regeln. Auserdem kann man mit nem Transistor die Monostabiile Kippstufe 
mit Musik triggern. Ich hab ein Eigenbau-LED Strobo, dass Blitzdauer, 
Frequenz und Audiotriggermode regeln kann.

MFG
Thomas

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dominik H. schrieb:
>> Hast du die nicht geroutete Verbindung von Pin 2 nach Pin 6 von Hand
>> verdrahtet oder einfach weggelassen?
>
> Doch hab ich gemacht.

Was, weggelassen? ;-)

Scherz beiseite. Nach meinem Kopf und der Spice-Simulation sollte die
Schaltung funktionieren. Allerdings kann sich ersterer irren und
letztere ungenau sein ;-)

Wenn ich heute Abend etwas Zeit habe, werde ich die Schaltung mal auf
dem Steckbrett aufbauen. Damit ich genau die gleiche Schaltung habe wie
du, brauche ich aber noch folgende Informationen:

- Ist deine Dimensionierung der Widerstände genau so, wie in deinem
  Schaltplan gezeigt? Wenn nicht: Was ist anders?

- Wie hoch ist die Versorgungsspannung?

- Was für einen 555er hast du, die klassische Bipolarversion namens
  NE555 oder eine CMOS-Variante (TLC555, ICM7555 o.ä.)?

Es sollte doch nicht so schwierig sein, einen einfachen Rechteckgenera-
tor zum Laufen zu bringen :)

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, ich habe jetzt die Schaltung nach deinem letzten Schaltplan
(02.12.2010 05:18) zusammengesteckt und mit 5V versorgt. Sie hat auf
Anhieb wunderschön geblitzt :)

Das Timing (46ms an und 702ms aus) stimmt bis auf wenige Prozent (das
sind die Bauteiltoleranzen) mit der Simulation überein.

Wenn ich aber die Verbindung zwischen Pin 2 und Pin 6 weglasse, leuchtet
die LED wie bei dir ständig. Bist du sicher, dass der Verbindungsdraht
wirklich verbindet?

Autor: Dominik H. (super_flummy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab jetzt die Schaltung nochmal auf einer Lochrasterplatine 
aufgebaut.

Verwendete Bauteile:

NE555 (420)
6800 Ohm (6K8)
470 Ohm
100k Ohm (SMD)
100nF (SMD)
10µF (Elko)
LED (grün)


Aber es funktioniert noch immer nicht:(
8,6 V Versorgungsspannung.
Habe mal am Kondensator gemessen, bei 5,7 V entlädt er sich.

Ich weiß nicht was wo falsch sein soll.

Edit:
1. Hab ich + von LED an - gehabt ( ist aber nicht schlimm da sie jetzt 
so leuchtet wie auf der Platine vorher schon )

2. Hab ich am Kondensator gemessen ( der entlädt sich schrittweise bis 
er unter 3V ist und dann geht die LED kurz aus. Der Kondensator lädt 
sich wieder auf 5,7 V und entlädt sich wieder bis unter 3 V )

Aber ich wollte es eigentlich anders herum!?
Soll die Schaltung das so machen oder hab ich noch was vertauscht?

Autor: Yalu X. (yalu) (Moderator)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dominik H. schrieb:
> 1. Hab ich + von LED an - gehabt ( ist aber nicht schlimm da sie jetzt
> so leuchtet wie auf der Platine vorher schon )

Das habe ich jetzt nicht ganz verstanden. Betreibst du die LED in
Sperrrichtung?

> 2. Hab ich am Kondensator gemessen ( der entlädt sich schrittweise bis
> er unter 3V ist und dann geht die LED kurz aus. Der Kondensator lädt
> sich wieder auf 5,7 V und entlädt sich wieder bis unter 3 V )

Die Schaltschwellen von etwa 2,8V und 5,7V sind richtig. Der Kondensator
sollte relativ schnell entladen und langsam wieder aufgeladen werden.
Während des Entladens sollte der Ausgang des NE555 Low, während des
Aufladens High liefern.

> Aber ich wollte es eigentlich anders herum!?

Wie in deinem Schaltplan richtig gezeichnet, muss die LED von Plus zum
Ausgang des NE555 geschaltet werden. Sie leuchtet dann bei Ausgang=Low,
also kurz mit langen Pausen. Schaltest du sie hingegen vom Ausgang nach
Masse, leuchtet sie bei Ausgang=High, also lang mit kurzen Pausen.

Autor: Dominik H. (super_flummy)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yalu X. schrieb:
> Das habe ich jetzt nicht ganz verstanden. Betreibst du die LED in
> Sperrrichtung?

Ich hab + von LED an - gehabt.

Also muss ich um den gegen Effekt zu bekommen nur die LED und denn 
Anschluss umdrehen? schau ich gleich mal


Vielen Dank

Autor: Ben ___ (burning_silicon)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
400V blitzkondensator an pins 1-4 und 4-8, fertig ist dein 
555-blitzlicht! können auch andere billige ICs eingesetzt werden, wie 
LM741 oder so.

SCNR (scherz, NICHT NACHMACHEN ODER AUFBAUEN!!)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.