mikrocontroller.net

Forum: PC Hard- und Software SATA Festplatte an IDE Mainboard


Autor: Hans Meyer (student23)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Guten Tag zusammen,

ich versuche seit einigen Tagen eine SATA Festplatte an meinem IDE 
Mainboard ans Laufen zu bekommen ohne Erfolg. Deshalb wollte ich fragen 
ob ihr mir weiterhelfen könnt?

Technische Daten:
- Hitachi HDS5C1010CLA382
- Wintech SAK-65 SATA/IDE Adapter
- A7N8X-X Mainboard
- BIOS Rev 1007
- Windows XP Professional SP3 Betriebssystem

Falls was fehlt sagt Bescheid...

Als ich die Festplatte das erste Mal angeschlossen hatte wurde sie im 
BIOS erkannt. Ich hatte dann versucht die Festplatte mit der Windows XP 
CD zu formatieren, dabei wurden von den 1000GB nur 132GB angezeigt, 
liegt wohl daran das es keine SP3 CD war?! Nachdem dieser Weg nicht 
funktioniert hatte habe ich die Platte in der Datenträgerverwaltung 
initialisiert und formatiert, dabei gab es eine Fehlermeldung, dass die 
Formatierung nicht fehlerfrei abgeschlossen werden konnte. Dann habe ich 
es mit PartitionMagic 8 versucht ebenfalls ohne Erfolg. Zusätzlich wurde 
die Festplatte nicht immer im BIOS erkannt.
Um einen Festplattenschaden auszuschließen bin ich wieder zu meinem 
Händler gegangen und habe ihn die Platte untersuchen lassen. Er konnte 
die Festplatte problemlos erkennen und formatieren.
Ich habe die formatierte Festplatte dann wieder an meinem PC 
angeschlossen und sie wurde zuerst auch ohne Probleme erkannt und ich 
konnte die Platte im Arbeitsplatz öffnen. Nach einem Neustart war die 
Festplatte aber im Arbeitsplatz verschwunden und wurde in der 
Datenträgerverwaltung als unformatiert angezeigt. Ich wurde auch 
aufgefordert die Festplatte zu initialisieren.
Ich habe darauf die Festplatte an beiden IDE Slots auf meinem Mainboard 
ausprobiert ohne Erfolg. Dann habe ich die Treiber meines nForce2 
Chipsatzes aktualisiert. Vorher wurde die Übertragungsart PIO angezeigt, 
nach der Treiberaktualisierung wird Ultra-DMA 6 angezeigt.
Leider finde ich für mein Mainboard kein neues BIOS sonst hätte ich es 
geflasht, weil eventuell könnte das Problem, dass die Festplatte nicht 
immer im BIOS angezeigt wirde von meinem alten BIOS stammen.
Als nächstes werde ich wohl einen anderen SATA/IDE Adapter ausprobieren 
um auc dort einen Fehler auszuschließen.

Ich hoffe ich habe nichts vergessen. Sonst liefere ich das nach.

Ich wollte euch fragen, ob es einen gibt der weiß ob und wie dieses 
Problem in den Griff zu bekommen ist?

Mit freundlichen Grüßen
student23

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Problem heißt fehlende LBA-48-Unterstützung.
Die ist für Festplatten mit mehr als 128 GiB (137 GB) Kapazität 
erforderlich.

Windows XP kann seit SP1 mit solchen Laufwerken umgehen, allerdings muss 
das mit einem Registry-Eintrag aktiviert werden.

Unter

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters

muss es den DWORD-Eintrag EnableBigLba mit dem Wert 1 geben.

Dann kann XP mit den mitgelieferten IDE-Treibern auch mit Festplatten 
mit mehr als 128 GiB Kapazität arbeiten.

Da das aber nicht Dein einziges Problem zu sein scheint (die 
gelegentlich fehlschlagende Erkennung der Platte durch das BIOS ist das 
andere), könnte eine andere Lösung sinnvoller sein: Ein dedizierter 
SATA-Controller, den Du in einen PCI-Slot Deines Mainboards steckst. Der 
kommt mit eigenen Treibern, benötigt also nicht den oben erwähnten 
Registry-Eintrag.

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Meyer schrieb:
> anderen SATA/IDE Adapter ausprobieren

Nochmals Auge in Bios ! Was wird erkannt?
Als meine SATA nicht wollten, habe ich sie behelfsweise über einen 
IDE-SATA-Adapter betankt (XP mit SP3) und dann gleich die nötigen 
TREIBER nachgezogen. Ob das in jedem Fall hilft, weiß ich nicht.

Notfalls könnte man die HD zum Test in externem USB-Gehäuse formatieren 
und betanken.

Autor: Hans Meyer (student23)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rufus t. Firefly schrieb:
> Das Problem heißt fehlende LBA-48-Unterstützung.
> Die ist für Festplatten mit mehr als 128 GiB (137 GB) Kapazität
> erforderlich.
>
> Windows XP kann seit SP1 mit solchen Laufwerken umgehen, allerdings muss
> das mit einem Registry-Eintrag aktiviert werden.
>
> Unter
>
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters
>
> muss es den DWORD-Eintrag EnableBigLba mit dem Wert 1 geben.
>
> Dann kann XP mit den mitgelieferten IDE-Treibern auch mit Festplatten
> mit mehr als 128 GiB Kapazität arbeiten.

Das mit dem Registry Eintrag hatte ich auch schon überprüft und der Wert 
war bei mir schon auf 1 gesetzt. Ich habe vorher schon mit einer 160GB 
IDE Festplatte gearbeitet.

> Da das aber nicht Dein einziges Problem zu sein scheint (die
> gelegentlich fehlschlagende Erkennung der Platte durch das BIOS ist das
> andere), könnte eine andere Lösung sinnvoller sein: Ein dedizierter
> SATA-Controller, den Du in einen PCI-Slot Deines Mainboards steckst. Der
> kommt mit eigenen Treibern, benötigt also nicht den oben erwähnten
> Registry-Eintrag.

oszi40 schrieb:
> Hans Meyer schrieb:
>> anderen SATA/IDE Adapter ausprobieren
>
> Nochmals Auge in Bios ! Was wird erkannt?
> Als meine SATA nicht wollten, habe ich sie behelfsweise über einen
> IDE-SATA-Adapter betankt (XP mit SP3) und dann gleich die nötigen
> TREIBER nachgezogen. Ob das in jedem Fall hilft, weiß ich nicht.
>
> Notfalls könnte man die HD zum Test in externem USB-Gehäuse formatieren
> und betanken.

Ich habe mir gestern neuere Treiber für meinen nForce2 Chipsatz besorgt 
und installiert und versuche heute nochmal meine Festplatte damit zu 
formatieren. Was ich mich gefragt habe ist, kann mein Mainboard 
eventuell zu alt sein um diese Festplatte problemlos zu erkennen?

Würde die Festplatte sicher erkannt, wenn ich sie über den PCI SATA 
Controller anschließe?

Mit freundlichen Grüßen
student23

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Meyer schrieb:
> Was ich mich gefragt habe ist, kann mein Mainboard
> eventuell zu alt sein um diese Festplatte problemlos zu erkennen?

Wenn die BIOS-Erkennungsroutine die korrekte Kapazität anzeigt, dann 
nicht. Außerdem hast Du ja anscheinend schon mit einer 160 GB-Platte an 
diesem Board gearbeitet, hätte das BIOS Probleme mit LBA-48, dann hätte 
auch diese Platte nicht funktioniert.

> Würde die Festplatte sicher erkannt, wenn ich sie über den PCI SATA
> Controller anschließe?

Das jedenfalls ist die Erwartungshaltung, die ich hier hätte.

Was allerdings wichtig ist: Der MBR (Sektor 0) auf der Festplatte muss 
komplett gelöscht werden. Darin sind nämlich neben der eigentlichen 
Partitionstabelle auch noch weitere Geometriedaten der Festplatte 
gespeichert, und diese sorgen, wenn nicht zum verwendeten Controller 
passend, für Fehlfunktionen.

Diese Geometriedaten sind ein Relikt aus der "CHS"-Urzeit, werden aber 
immer noch zur Berechnung von die Partitionierung betreffenden Dingen 
genutzt.

Mit Tools à la s0kill sollte das komplette Löschen des MBR möglich sein, 
danach kann die Platte auf die gewohnte Weise an Deinem Board 
partitioniert und zugeritten werden.

Autor: Icke ®. (49636b65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
XP mit SP3 sollte ohne Zauberei mit der Platte umgehen können. Daß vom 
BIOS nur 128 GB "gesehen" werden, liegt an dessen altertümlicher 
Ausführung und ist in diesem Fall kein Problem. Das gelegentliche 
Verschwinden der Platte liegt aber nicht am BIOS, sondern deutet auf 
Hardwareprobleme hin. Entweder funktioniert der Adapter nicht richtig 
oder er hat Kompatibilitätsprobleme mit dem Board oder der Festplatte. 
Evtl. hilft es, die Festplatte fest auf S-ATA1 (150 MB/s) einzustellen. 
Das geht bei Hitachi leider nur per Feature Tool 
(http://www.hitachigst.com/support/downloads), da es keinen 
entsprechenden Jumper gibt. Du müßtest sie also temporär in einen 
Rechner mit S-ATA-Anschluß einbauen (Kumpel?).

Autor: Hans Meyer (student23)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hier habe ich mal die Antwort vom ASUS Support.

>Sehr geehrte Damen und Herren,
>
>leider haben wir schon öfter von Probleme mit Mainboards dieser Baurreihe
>und Festplatten über 500GB gehört. Diese lassen sich meist nicht
>störungsfrei betreiben so das wir dazu übergegangen sind Festplatten vom
>maximal 500GB für diese Boards zu empfehlen.
>
>Wenn es diese Festplatte sein muss würden wir empfehlen entweder ein SATA 2
>Controllerkarte für den PCI Slot zu verwenden oder die Platte in einen
>USB-Rahmen zu verbauen. Kontrollieren Sie aber noch ob die Platte evtl.
>über einen SATA 1.5G Jumper verfügt. Evtl. könnte dieser auch das Problem
>lösen.
>
>Mit freundlichen Grüßen
>
>Technical Support Division ASUS Germany [J10S]

Die geben mir die gleichen Hinweise wie ihr.

Icke ®. schrieb:
> XP mit SP3 sollte ohne Zauberei mit der Platte umgehen können. Daß vom
> BIOS nur 128 GB "gesehen" werden, liegt an dessen altertümlicher
> Ausführung und ist in diesem Fall kein Problem. Das gelegentliche
> Verschwinden der Platte liegt aber nicht am BIOS, sondern deutet auf
> Hardwareprobleme hin. Entweder funktioniert der Adapter nicht richtig
> oder er hat Kompatibilitätsprobleme mit dem Board oder der Festplatte.
> Evtl. hilft es, die Festplatte fest auf S-ATA1 (150 MB/s) einzustellen.
> Das geht bei Hitachi leider nur per Feature Tool
> (http://www.hitachigst.com/support/downloads), da es keinen
> entsprechenden Jumper gibt. Du müßtest sie also temporär in einen
> Rechner mit S-ATA-Anschluß einbauen (Kumpel?).

Wäre diese Einstellung einmalig oder müsste sie bei jeder neuen 
Formatierung vorgenommen werden?

> Was allerdings wichtig ist: Der MBR (Sektor 0) auf der Festplatte muss
> komplett gelöscht werden. Darin sind nämlich neben der eigentlichen
> Partitionstabelle auch noch weitere Geometriedaten der Festplatte
> gespeichert, und diese sorgen, wenn nicht zum verwendeten Controller
> passend, für Fehlfunktionen.
>
> Diese Geometriedaten sind ein Relikt aus der "CHS"-Urzeit, werden aber
> immer noch zur Berechnung von die Partitionierung betreffenden Dingen
> genutzt.
>
> Mit Tools à la s0kill sollte das komplette Löschen des MBR möglich sein,
> danach kann die Platte auf die gewohnte Weise an Deinem Board
> partitioniert und zugeritten werden.

Hättest du einen Link von s0kill für mich? Könnte das eventuell schon 
helfen, wenn ich damit die Festplatte in den Urzustand zurücksetze und 
mit den zurzeit gegebenen EInstellungen nochmal formatiere?

Mit freundlichen Grüßen
student23

Autor: Icke ®. (49636b65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Meyer schrieb:

> Wäre diese Einstellung einmalig oder müsste sie bei jeder neuen
> Formatierung vorgenommen werden?

Einmalig.

Autor: Dieter B. (debe)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Vor eineinhalb Jahren stand ich vor dem gleichen Problem. Diese Adapter 
sind nicht ganz koscher.
Habe dann einen Controller
http://www.reichelt.de/?;ACTION=3;LA=444;GROUP=E71...
genommen und es läuft problemlos.

Bei einer externen USB>SATA-Platte hatte ich auch einmal, dass die auf 
500GB begrenzt war.

Autor: Hans Meyer (student23)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich habe es geschafft, dass ich die Festplatte ohne Fehler auf NTFS 
formatieren konnte. Die Platte wird jetzt auch im Arbeitsplatz erkannt 
und ich kann Daten darauf abspeichern.
Ich habe wie gesagt gestern neuere Treiber für meinen nForce2 Chipsatz 
installiert und die Platte über den IDE Slot 1 verbunden (wobei ich 
nicht weiß ob das wichtig dafür ist). Dann habe ich heute die Festplatte 
über die Datenträgerverwaltung formatiert und es kam keine 
Fehlermeldung.
Ich bin aber trotzdem am überlegen auf eine SATA PCI Controllerkarte 
umzusteigen, da mir mit der jetzigen Konfiguration ein IDE Slot fehlt.

Ich werde das aber jetzt erstmal so testen um zu schauen ob es sich mit 
der Zeit wieder verschlechtert. Eventuell ist es beim nächsten Neustart 
wieder anders und ob das Problem mit der Erkennung der Platte im BIOS 
behoben ist weiß ich auch nicht.

Ich danke euch auf jeden Fall für eure schnelle und ausführliche Hilfe! 
Und ich werde mich melden wie es läuft.

Mit freundlichen Grüßen
student23

Autor: Dagobert Duck (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hans Meyer schrieb:
> da mir mit der jetzigen Konfiguration ein IDE Slot fehlt

1.Langsame Platten sollte man lieber als Backup in den Schrank stellen.
2.Falls noch Teiber fehlen: Sandra verrät Dir einiges

http://www.pcwelt.de/downloads/Systemanalysetool-S...

Autor: Hans Meyer (student23)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen,

ich könnte verrückt werden. Nachdem die Festplatte endlich erkannt wurde 
und ich auch mit ihr ohne Probleme arbeiten konnte, ist die Platte 
plötzlich hängen geblieben. Nach dem notwendigen "erzwungenen" Neustart 
wurde die Platte dann nicht mehr erkannt und der Rechner ist beim 
Versuch die Platte zu "installieren" immer hängen geblieben. Anscheinend 
war die Auffrischung der Treiber meines Controller Chipsatzes nicht 
ausreichend um das Problem in den Griff zu bekommen.

Ich wollte euch fragen, welche Geräte ihr mir aus den Produktgruppen
- externes SATA USB Gehäuse
- SATA PCI Controller Karte
empfehlen könnt mit denen ich die Platte alternativ an meinen Rechner 
anschließen könnte. Eventuell habt ihr gute Erfahrungen gemacht?

Mit freundlichen Grüßen
student23

Autor: Dieter B. (debe)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie ich schon oben schrieb, die Karte von DawiControl
http://www.reichelt.de/?;ACTION=3;LA=444;GROUP=E71...
läuft bei mir problemlos. Knapp 43€.
Sie hat einen zweiten SATA-Anschluss, der intern oder extern benutztbar 
ist.
Die SATA-Platte läuft bei mir nicht als Bootlaufwerk.
debe

Autor: Läubi .. (laeubi) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also wenn das Board schon so viele Probleme mit einer Platte macht würde 
ich mal über ein neues Mainboard nachdenken vor nicht all zulanger zeit 
hab ich noch unter Win98se eine 200GB Platte Problemlos nutzen können 
(da allerdings mit IDE Emulation).

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.