mikrocontroller.net

Forum: Analoge Elektronik und Schaltungstechnik Auf Masse geschalteten Kontakt verarbeiten (LOGO)


Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Leute,

habe gerade folgendes Problem.
Möchte mit meiner Siemens Logo verschiedene Zustände 
signalisieren/verarbeiten.
Die Kontakte die ich erhalte schalten alle auf Masse...wie schließe ich 
hier an?
Oder bleibt mir nur die Möglichkeit auf weitere Relais zu klemmen und 
dann weiter auf die Logo zu gehen?

Hoffe ihr könnt mir helfen, wäre dringend.

Danke schonmal ^^

Lg Dominik

Autor: Volker S. (sjv)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

Die Kontakte mit einem Pull-up Widerstand gegen + beschalten.
Der Widerstandswert muß so gewählt werden, das die LOGO-Eingänge bei 
offenen Kontakt sicher im "1" Bereich liegen. Richtwert ca 20% des Re 
der LOGO.

MfG Volker

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
DANKE für die schnelle Antwort.

Habe mich grade ein bisschen eingelesen was ein Pull Up Widerstand denn 
eigentlich ist (komme nicht aus der Elektronikbranche).

Leider ist es für mich jetzt nicht 100%ig verständlich.

Habe einen Common (12V DC) und anschließend den Kontakt, welcher auf 
Masse schaltet.. Wie genau ist das jetzt zu verschalten, hast du 
vielleicht noch einen Tipp oder vl. eine schematische Darstellung ?

Lg Dominik

Autor: Franz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
  +12V
   |
   |
   -
  | | R
  |_|
   |
   |------------- LOGO
   |
   °
    \
   |
  ___

Autor: Volker S. (sjv)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

der Widerstand geht an die +12V.
Den Re (Eingangswiderstand) der LOGO mußt Du mal im Datenblatt suchen, 
da ich die LOGO auch nur dem Namen nach kenne.

Volker

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Herzlichen Dank !!
Seid mir eine große Hilfe gewesen...

also verstehe ich das richtig, dass ich einen normalen Widerstand 
verwenden kann ? Bzw. wie groß sollte dieser denn gewählt werden ?

Lg

Autor: Franz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenne dir nicht sicher bist, dann nimm irgendweinen so zwischen 1k und 
10k - theoretisch egal...nur zuuu klein un zuuu groß sollte er nicht 
sein.

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Okay, werde ich machen..

Werde das ganze mal ausprobieren und mich wieder melden wenn ich Erfolge 
hab :-D

Danke nochmal und noch einen schönen Tag..

Lg

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habe gerade gemerkt, dass ich diesen gemeinsamen COM für 4 Kontakte 
habe, wie ist das denn nun zu verschalten ?

Lg

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
So, hab das jetzt mal so angeschlossen...ich kann auch die 12 V 
messen...mein Problem allerdings ist, dass die Logo nicht schaltet...ist 
der Strom möglicherweise zu gering ?

Lg

Autor: Franz (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dominik schrieb:
> Habe gerade gemerkt, dass ich diesen gemeinsamen COM für 4 Kontakte
> habe, wie ist das denn nun zu verschalten ?

Meinst du mit COM Masse? Masse sollte ja immer die gleiche sein.

Mal das doch mal auf, wie du es gemacht hast.

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Zeichnen geht grad eher schlecht...

Also: Hab eine Klimaplatine mit 6 Kontakten:

1: COM (12 VDC)
2: Defrost Output
3: Thermo ON
4: Cooling Output
5: Heating Output
6: Fan output

und Zustände wie Heating Cooling will ich verwenden.
Der COM ist soweit ich das verstehe die gemeinsame Spannung für diese 
Zustände...

Habe jetzt den Widerstand zwischen COM und Cooling und von Cooling gehe 
ich weiter auf I1 der Logo...

Lg

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also ich messe zwischen der Leitung die auf die Logo geht und dem COM(12 
VDC) genau 12 V.

Habt ihr noch einen Tipp, weiß echt nicht mehr weiter...

Der Widerstand hat in etwa 1k Ohm

Autor: Peter Bünger (pbuenger)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Du hast also jetzt nur eine einzelne Leitung zur Logo? Und was ist mit 
der Masse? Hast Du auf der Klimaplatine keinen Masseanschluß? Ohne den 
geht es nicht, ansonsten müßtest Du Relais oder Optokoppler verwenden.

Peter

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich meine ja, habe immer nur 2 Leitungen von der Klimaplatine weg.

Einen COM(12 VDC) und den jeweiligen Zustand bei dem in Klammer steht... 
schaltet auf Masse...jetz weiß ich halt ned  ob das die Masse sein 
soll....
Geh mal davon aus..
Wie würdest es anschließen ?

Lg

Autor: BMK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nach meinem Verständnis müsste erstmal COM(Klima) mit
COM(Logo) verbunden werden, als gemeinsamer GND Bezug.

Dann Output(Klima) nach Eingang(Logo)

Und den Widerstand von Eingang(Logo) nach Dauerplus12V(Logo)

Autor: LuXXuS 909 (aichn)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Naja also so sollte es aussehen.

Dein LOGO-Eingang ist doch ein Digital-Eingang und dein Sensor-Ausgang 
ein Digital-Ausgang, oder? Also mit "schaltet nach Masse" nehme ich das 
mal an.

Autor: lrlr (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
der Eingang ist dann invertiert, oder ?

Autor: LuXXuS 909 (aichn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Genau

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hab jetzt mal mit dem Techniker telefoniert von dem diese Platine 
stammt.

Am COM(12 VDC) liegen immer 12V an
und bei den anderen Heating, Cooling usw. wird einfach nur die Masse 
(GND) dazugeschalten.

Hab jetzt einfach mal den Com an den Eingang der Logo angelegt und 
Cooling auf Masse der Logo und es ging...kann damit aber doch nur einen 
Betriebszustand von 4 anzeigen lassen.

Danke für die tolle Zeichnung, versteh ich jetz aber auch ned 
ganz...welches GND und 12+ ist denn hier gmeint?

Lg

Autor: Peter Bünger (pbuenger)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die +12V sind der COM-Anschluß Deiner Klimaplatine. Den GND mußt Du 
irgendwo an dieser Platine abgreifen, ohne geht es nicht. Dann 
verbindest Du GND von der Klimaplatine mit GND von der Logo. Und von 
jedem Ausgang eine Verbindung zu einem Eingang der Logo. Zusätzlich 
brauchst Du an jedem Ausgang der Klimaplatine noch einen separaten 
Pullup nach COM (+12V). Fertig.

Peter

Autor: LuXXuS 909 (aichn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
"COM" wird ja für COMMON stehen...wenn das bei dir +12V ist, dann ist es 
unglücklich gewählt, aber OK.

Der gemeinsame Anschluss ist i.d.R. immer Masse, also das 
Bezugspotential - die Versorgungsspannungen können ruhig verschieden 
sein (+12V, +5V, -5V, ...)

Fakt ist, du brauchst ein gemeinsames Bezugspotential, in der Zeichnung 
GND (Masse) - oder du trennst mittels Optokoppler etc. - aber das ist 
hier ja nicht der Fall.

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Diese gemeinsame Masse von der Platine bekomm ich eben nicht,,
hab nur einzelne Massen die dann je nach Betriebszustand geschalten 
werden...

Autor: LuXXuS 909 (aichn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dominik schrieb:
> hab nur einzelne Massen die dann je nach Betriebszustand geschalten
> werden...

Nee, du hast einzelne Signale, die NACH Masse geschaltet werden.

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ok, Danke für eure Bemühungen ....werd jetz einfach mit Relais machen 
weil die andere Methode einfach ned in meinen Kopf gehn will :-S

Lg

Autor: LuXXuS 909 (aichn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dominik schrieb:
> werd jetz einfach mit Relais machen

Ja und wie dann da?

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das Dauerplus (COM) kommt bei allen Relais auf A1 (wird gebügelt) und 
der jeweilige Zustand auf A2...so funktionierts.

Dann werd ich beim Schließerkontakt wieder eine Dauerspannung 12V auf 13 
anlegen und vom 14er geh ich auf die SPS-Eingänge.

Lg

Autor: LuXXuS 909 (aichn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Dominik schrieb:
> Dann werd ich beim Schließerkontakt wieder eine Dauerspannung 12V auf 13
> anlegen und vom 14er geh ich auf die SPS-Eingänge.

Nur wenn die SPS SMOS-Eingänge hat, dann ist da hoffentlich ein 
Pull-Down-R drin ;-)

Autor: LuXXuS 909 (aichn)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
SMOS = CMOS

Autor: Dominik (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Scheint so,
grad probiert und funkt^^

Lg

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.