mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik ATMega8 an LPT Port AVR Gerät Antwortet nicht


Autor: Thomas (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

ich sitze jetzt schon lange an einem Problem.

System

AMD Athlon X2 4200+
2 GB Arbeitsspeicher

Mainboard Gigabyte MA 770 UD3

LPT Mode EPP
Myavr Board ATMega8 LPT und COM Schnittstelle
Programme avrdude aus SiSy

- ich bekomme keine Verbindung zu meinem Mikrocontroller hin. Habe schon
  einiges Probiert wie im Gerätemanager
  Druckeranschluss(LPT1)-->Eigenschaften-->Anschlusseinstellungen-->
  von Interrupt nie verwenden
  auf jedem dem Anschluss zugewiesenen Interrupt gewechselt.

- Im Bios auf EPP Mode umgestellt
- LPT Adresse ist 0x378

avrdude bringt jedes mal die Meldung

AVR-Dude: AVR-Gerät anwortet nicht.
Die Initialisierung ist nicht möglich.


Power LED von dem Board leuchtet und das vorherige Blinklichtprogramm 
ist noch drauf und läuft.

Bin langsam mit meinem Latein am Ende. Ich hoffe es kann mir Jemand 
helfen???

Vielen Dank im Voraus

Autor: Mike J. (linuxmint_user)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hab einen Athlon64 X2 4000+  und bei mir läuft es.

:)

Nein, das ist total unwichtig.

Stelle den Anschluss im Bios mal auf SPP (Standard Parallelport)

Bau dir mal einen billig STK200 Programmer nach, dazu brauchst du nur 
ein Druckerportanschluss (25 Polig) und zwei 1k ohm Widerstände.

Beitrag "Re: Beleuchtung für Modellflugzeug"

Stelle bei AVRdude auf Pony STK200 und es sollte funktionieren.

Du kannst auch PonyProg nutzen, bei mir hat es immer anstandslos seinen 
Dienst getan, bis ich zu Linux gewechselt bin und automatisch auf 
avrdude umsteigen musste.

Autor: _BT (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
hallo,

was hast denn für ein Betriebssystem? und hast du Admin-Rechte? es 
könnte auch am giveio.drv liegen... ist der korrekt geladen? was sagt 
das progtool von myavr? mag das auch nicht?

cu BT

Autor: Thomas (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hall,

Problem gelöst, hatte noch ein anderes Mainboard, damit funktionierts.

Allerdings habe ich nun folgendes Problem, ich möchte mein ATMega 8 mit 
AVR Studio programmieren, habe auch schon WinAVR und AVR-Studio 
installiert und er compiliert auch das Programm in C.
Wie bekomme ich das Programm nun auf den Mikrocontroller?
Oder wie kann ich avrdude in AVR Studio einbinden???
Ich möchte den LPT oder COM Port zum programmieren benutzen.

Ich habe folgendes Board:

myAVR Board MK1 LPT


Danke an Alle

Autor: Uwe S. (de0508)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Thomas,

ich habe diese Board auch als erstes benutzt und musste dann immer auf 
dem Programmer von

http://www.myavr.de/

zurück greifen.

Siehe hier:

http://shop.myavr.de/index.php?sp=download.sp.php

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.