mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Auto Fernbedienung VW


Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,


DA die Originale Fernbedienung kaputt war (zu geringe Reichweite) habe 
ich eine neue Besorgt.
Diese ist aber die US Version des Senders.
Die Deutsche Funkt auf 434 Mhz , die US Version auf 315Mhz.

Die Fernbedienungen sind an sich Baugleich von der Platine und vom 
Layout her.

Deshalb dachte ich es reicht wenn ich den Quarz um löte (DE Version 
13.575 D13
- US Version 9.8437 D:47)

Doch leider führte dies nicht zum erwünschten Effekt. Die Fernbedienung 
lässt sich nicht anlernen.

Also habe ich mir die andere Bauteile auf der Platine Angeguckt.

Zwei IC's

DE................ US
_________    _________
|T 50426 |    |T 80914 |
|U2741BM |    |U2741BN |
|5101    |    |5431    |
|________|    |________|

_________    _________
|T 022   |    |T 042   |
|M44C890C|    |M44C890E|
|M113037 |    |CH439007|
|________|    |________|


Leider konnte ich hierzu kein Datenblatt finden.

Wer weis einen Rat?

Inwiefern spielen die eine Rolle bei der Frequenz??

mfg

Autor: Simon (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
U2741BN  das ist der Sende-Chip: 
http://www.alldatasheet.com/view.jsp?Searchword=U2741BN

M44C890E das ist der µC: 
http://www.alldatasheet.com/view.jsp?Searchword=M44C890E

3min google (mit ein wenig Schmöckern im Datenblatt)

ABER bist du sicher, dass die beiden Baugleich sind? Kondensatoren & 
Spulen vermessen? Bin kein Fachmann in HF, aber normalerweise muss eine 
Antenne über ein Anpassungsnetzerk an den Transmitter angeschlossen 
werden. Und dieser ist Frequenzabhängig, siehe Datenblatt von U2741B 
Seite 5, Tabelle 1.

Wenn du die Sendestärke ändern willst, musst du "nur" Rpwrset 
modifizieren (oder eine frische Batterie einsetzten ;) ).
gruß
Simon

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Erstmal danke für ei schnelle antwort ;)


--Wenn du die Sendestärke ändern willst, musst du "nur" Rpwrset
--modifizieren (oder eine frische Batterie einsetzten ;) ).


Würde mich freuen wenn du mir das genauer erklärst;)

Die Platine ist (die reine Platine) absolut baugleich.
Ich setze morgen mal ein paar fotos rein, werde dann auch mal die Spule 
an der antenne vermessen.
ansonsten sehen die platinen von der bestückung absolu gleich aus (bi 
auf das die US version 2 tasten mehr hat, hat damit aber nichts zu 
tuhen.


außer halt die beschriftung der µC 's .
(oder sind das doch die gleichen??)
ich kenne mich damit noch nicht ganz so gut aus, heist al die mitlere 
eile, die die gleich ist, ist das modell, und das hat der rest zu 
bedeuten??



mfg

Autor: BerndB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hannes,

schon mal daran gedacht, dass die Sendekennung bzw. das Protükoll anders 
ist.
Wenn die Hardware gleich ist wirst Du die Software im Atmel ändern 
müssen.
Der ist Maskenprogrammiert ist.

Es wäre besser gewesen bei dem org. Key die Sendecharakteristik zu 
untersuchen.

Gruß BerndB

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also besteht so keine Hoffnung nur durch tausch des quarzes diese 
angelernt zu bekommen??
Da aufgrund der software- das Signal anders ist?

Nur verstehe ich nicht, warum nur bei einer anderen Frequenz,
(gleiche Fernbediehungn) die Software anders sein sollte??


mfG

Autor: Daniel F. (danielosna)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Taktmultiplier werden anders sein und auch die Software ist 
wahrscheinlich eine andere, da in den USA andere Richtlinien bzgl. Funk 
bestehen... Denke daher nicht dass das funktionieren wird. (Bin mir 
sogar recht sicher...)

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist jetzt ziemlich blöd. :(


Habe auch noch zwei deutsche Funkschlüssel, senden auch wie der alte auf 
434 MHZ allerdings sind diese neuer, und besitzen ein anderes platinen 
layout
(die position der tasten ist gleich, nur die ic's wiederstände und co 
sind anders angeordnet.)

Wie  funktioniert das mit der Sendeleistungsverstärkung durch 
Modifizierung der "rpwrset" den der alte schlüssel funktioniert zwar, 
lässt sich auch anlernen, doch funktioniert nur wenn man 20cm vorm wagen 
steht, auch ist die batterie (Varta, CR 2032) nach wenigen tagen leer.

mfG

Autor: BerndB (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hannes,

so langsam kommen wir dem Problem näher.
Der Ruhestrom scheint extrem hoch zu sein. Das führt zu einem Einbruch 
der Batteriespannung. Was sich dann in geringer Sendeleistung bemerkbar 
macht.

Gruß BerndB

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wäre genial, wenn der alte schlüssel rettbar wäre :)

woran kann das problem mit dem zu hohen ruhestrom liegen?

 oder heist das irgendwo ein kurzer  ??

Autor: inse (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
...vielleicht ein gebrochener Keramikkondensator?

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich denke mal ein Foto der Platine ist erst mal hilfreich, werde gleich 
eins anfertigen.

Begebe mich mal auf die suche nach dem kondensator;)

mfg

Autor: Om Pf (ompf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes Schmidt schrieb:

> Deshalb dachte ich es reicht wenn ich den Quarz um löte (DE Version
> 13.575 D13
> - US Version 9.8437 D:47)
>

Du must den Quarz und den SAW tauschen, ein paar Kondensatoren anpassen, 
und andere Firmware in den Controller flashen.

Letzteres dürfte das größte Problem sein, denn an die Hexfiles kommt man 
nicht so einfach dran.


Patrick

Autor: Bernd B. (Firma: BB) (berndb)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo Hannes,

Das Problem kann im Controller selber liegen (z.B. ESD Schaden) oder 
auch extern. Ohne den Key zu kennen schlecht zu sagen.

Der erste Schritt waere erstmal vorsichtig den Ruhestrom zu messen und 
mit dem der US Version zu vergleichen. Ueberbrueckbaren hochohmigen 
Shunt benutzen z.B. 1K, da der Key sich, nach men einlegen der Batterie, 
vermutlich erst initialisiert.


@Patrick:
Laut Datenblatt hat der Controller kein Flash....

Frohe Weihnachten aus Guam.
Gruss

BerndB

Autor: Hannes Schmidt (gfifteen)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hier ein Foto der Platinen.

Die Teilenummer des Deutschen Schlüssels ist  HLO 7D0959753 (original VW 
Nummer)
Gefertigt werden die Schlüssel von HELLA (fertigen auch Scheinwerfer 
etc..)

Autor: Wegstaben Verbuchsler (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
vielleicht ist ja bei der defekten FB einfach eine Taste hinüber und die 
meiste Zeit betätigt?

Wie ist denn die exakte Ruhestromaufnahme der  D und US Version?

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die tasten sind in Ordnung, (wenn eine taste gedrückt wäre würde man das 
an der blinkenden bestätigungs-led sehen, den sobald ich eine taste 
drücke blinkt diese, ansonsten nicht.


den Ruhestrom werde ich gleich messen, ich gehe mal davon aus das 
gemeint ist, zwischen +(Batterie) und +(Platine) oder?? denn sonst kann 
ich nirgends den Strom messen, es sei den ich würde die Platine 
massakrieren :D


mfg

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also das scheint des Rätsels Lösung über die Dauernd leere Batterie :)

Alt
Unbelastet 0,275 mA
Last 7,25 mA

Neu
Un 0,01µA
Last 7,40 mA

Nur, was führt zu der Stromaufnahme???

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes Schmidt schrieb:
> Nur, was führt zu der Stromaufnahme???

In glücklichen Fällen Schmutz/Limonade/Kaffee ?

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein ,leider. alles sauber, ist bei beiden Schlüsseln so, und kam mit 
der zeit :???:

Autor: Matze (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Anscheinend kannst du ja löten. Ich würde daher mal versuchen naeinander 
die Bauelemente der US-Fernbedienung auf deine zu löten. Dann wirst du 
ja sehen bei welchem Bauelement das Proplen ist.
Ich würde mal auf den Sendeschaltkreis tippen. Durch ESD o.ä. hat es die 
Endstufe zerlegt. Daher die sehr geringe Reichweite und der hohe 
Standbystrom. (Ist nur geraten)

Autor: Matze (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
naeinander ->nacheinander
Proplen ->Problem
:)

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nicht möglich, da die Bestückung der US Platine(Kondensatoren 
Widerstände etc) vom wert eben dieser anders ist.

Das Löten hingegen stellt kein Problem dar;)

Autor: Wegstaben Verbuchsler (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Die tasten sind in Ordnung, (wenn eine taste gedrückt wäre würde man das
> an der blinkenden bestätigungs-led sehen, den sobald ich eine taste
> drücke blinkt diese, ansonsten nicht.

was spräche denn dagegen, doch mal das Meßgerät an den Tasten dran zu 
halten, resp. die Tasten mal komplett abzulöten und dann mal den Strom 
zu messen?

Putz aber vorher mal den Flussmittel-Schmodder mit Isopromanol von der 
Platine ab (siehe Bild oben)!

Die Blinkerei kommt ja "aktiv" vom Controller. Ich könnte mir 
vorstellen, dass ein unsauberer Kontakt oder angebrochener Knackfrosch 
diesen daran hindert, in den Schlaf zu fallen, aber der Controller 
andererseits  kein "echt" gedrückte (entprellte) Taste vorfindet, um 
daraus eine Schaltanweisung herzuleiten....

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Tatsächlich O_o, habe gerade den Durchgangsprüfer an die tasten 
gehalten, und dieser zeigt kurzzeitig einen widerstand an(kein piepen) 
vllt ist irgendwie schmodder im schalltet, das hätte ich echt nie 
gedacht. ich löte den Schalter mal aus und sehe dann weiter.

Isopropanol habe ich nichtmal dar, hatte versuch damit mein Navi zu 
retten, da ist der Rest drauf gegangen :D Muss mir erst neues besorgen 
;)

Autor: mexman (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ultraschallreinigung (beim Optiker) wirkt Wunder.

Gruss

Michael

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
wie meinen??

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
nix keine Veränderung nach Ausbau der Schalter .

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Suchmaschine kennt auch
Uhrmacher, Optiker und z.B. "ultraschallreiniger für brillen"

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das ist schon klar, aber was soll das bringen??

Autor: oszi40 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Bevor Du das Ding wegwirfst, würde ich es nochmals versuchen zu reinigen 
und gut zu trocknen. Solange da hochohmige Schaltungen im Spiel, sind 
reichen schon Flussmittelreste um einen Arbeitspunkt ungünstig zu 
verändern.

Autor: Wegstaben Verbuchsler (wegstabenverbuchsler)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
bei der deutschen Platine meine ich auf der Batterie-Seite beim 
Kondensator unten rechts eine Zinnkugel zwischen der Massefläche und dem 
Kondensatoranschluß (Lötauge)  zu sehen

Autor: Matze (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>Nicht möglich, da die Bestückung der US Platine(Kondensatoren
>Widerstände etc) vom wert eben dieser anders ist.

Ich meinte auch die aktiven Bauelemente. So kann man herausfinden 
welches Bauteil für den höheren Stromverbrauch verantwortlich ist.

Autor: Hannes H. (mui)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Auf dem deutschen Schlüssel ist doch oben links neben dem Taster ein 
Kondensator schepp und ein Widerstand fehlt?! Die Ecke sieht eh ziemlich 
wüst aus, da würde ich mal nen genaueren Blick drauf werfen...

VG

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>bei der deutschen Platine meine ich auf der Batterie-Seite beim
>Kondensator unten rechts eine Zinnkugel zwischen der Massefläche und dem
>Kondensatoranschluß (Lötauge)  zu sehen

Kannst du mal genau auf dem Foto makieren, weis nicht genau wo du 
meinst.

>Auf dem deutschen Schlüssel ist doch oben links neben dem Taster ein
>Kondensator schepp und ein Widerstand fehlt?! Die Ecke sieht eh ziemlich
>wüst aus, da würde ich mal nen genaueren Blick drauf werfen...

Der Fehlende widerstand ist von nicht vorhandenen Taster der 
"panic"taste , die der Deutsche nicht besitzt, deshalb sitzt dort auch 
kein Widerstand.

Die widerstand sitzt so, weil ich beim auslöten des Quarzes, den 
ausersehen mit ausgelötet habe ;)


>Ich meinte auch die aktiven Bauelemente. So kann man herausfinden
>welches Bauteil für den höheren Stromverbrauch verantwortlich ist.

Ich kenne mich mit iC nicht so gut aus, aber sind die nicht anders?
es stimmt nur die mittlere Zeile der Beschriftung überein?



Danke für die tipps, werde auf jeden Fall gleich mal Isopropanol 
besorgen ;)

mfg

Autor: Christian H. (netzwanze) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes Schmidt schrieb:
> es stimmt nur die mittlere Zeile der Beschriftung überein?

Das ist auch die relevante Zeile.

Die der Produktnummer folgenden Buchstaben geben meist die 
Produktversion an. Die kann also auch mal variieren. Oder es ist eine 
Länderkennzeichnung (dann hier eventuell interessant).

Die letzte Zeile zeigt normalerweise die Herstellungswoche (Woche - 
Jahr) an. In diesem Fall wohl anders kodiert.

Autor: Wegstaben Verbuchsler (wegstabenverbuchsler)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
> Kannst du mal genau auf dem Foto makieren

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Nein, absolut sauber, ist nur eine Optische Täuschung. :?:

Da ich beim Auslöten des Schalters, aus versehen eine unter dem Schalter 
verlaufende Leiterbahn getrennt habe, habe ich den zweiten mit dem 
selben Effekt aussortierten Funkschlüssel zur Hand genommen,
der selbe Schlüssel, nur das hier die Stromaufnahme noch großer in 
standby ist, und nicht wie beim us  Modell gleich null.

mfg

Autor: keyguard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Läuft der µC mit internem oder externem Takt? Wenn extern, kannst du die 
US Version knicken.

Bisher hatte ich nur kalte Lötstellen bei VW Schlüsseln. Sind schon 
harte Bedingungen für die Elektronik, Wärme, Kälte, Vibration, Stoß. 
Also einfach alles nachlöten und hoffen.

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Kann ich dir nicht sagen, kenne mich in der µC Technik noch nicht so gut 
aus ;)

mit was für VW Schlüsseln hattest du es bereits zu tuhen?

Autor: David .. (david1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Also an einer Lösung des Problems wär ich auch sehr interresiert.

Bei unserm Golf V läuft der eine Schlüssel Problemlos, nur beim anderen 
lässt sich die Zentralverrieglung nur paar cm direkt am wagen bedienen.

Wie hast du denn den Schlüssel geöffnet?

Autor: keyguard (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit verschiedenen aus dem VAG Haus. Aber nur für Eigenbedarf, nicht 
komerziell, um Fragen vorzubeugen ;-)

Oben hat jemand das Datenblatt verlinkt. Es läßt sich auf der 
doppelseitigen Platine schnell nachverfolgen, ob an den OSC Pins was 
dran hängt.

Aber bevor du aufgibst: alle Lötstellen sauber nachlöten. Schaden kann 
es ja nicht.

Autor: Hannes Schmidt (gfifteen)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ich hoffe mein neuer Lötkolben kommt bald :), der dicke 5 mm breite ausm 
Aldi, ist hierfür doch gänztlich ungeeignet :D




@ david, am einfachsten, und ohne den Schlüssel zu beschädigen , gehst 
du wie folgt vor, klappe den Schlüsselbart auf (um nachher den Kopf 
besser greifen zu können) stecke einen dünnen Schraubenzieher unten 
durch die öse, fasse den oberen teil (da wo das VW logo sitzt) feste an, 
und ziehe den unteren teil am Schraubenzieher ab.
Ist etwas schwerer, aber die einzige Möglichkeit den Schlüssel gänzlich 
unbeschädigt zu öffnen ;)

den Container bekommst du auf, indem du mit beiden Daumen in die 
Vertiefung des schlüsselbarts fasst, und diesen auseinander klappst ;).


achja, das erste was ich an deiner stelle probieren würde, wäre ein 
Batterie wechsel;)

mfg

Autor: David .. (david1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hannes Schmidt schrieb:
> achja, das erste was ich an deiner stelle probieren würde, wäre ein
> Batterie wechsel;)

Ich meine die wurd schonmal von der Werkstatt gewechselt, oder ich glaub 
der hats auf die schnelle ohne Beschädigung auchnich hinbekommen, dann 
hat ers erstmal gelassen und aufs nächste mal verschoben.

Aber ich probiers die Tage auf jeden Fall mal.

Autor: Carsten Wille (eagle38106)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

bei meinem Tschechentrecker geht der Funkschlüssel schon seit über 8 
Jahren mit der selben Batterie. :-)

Schau Dir mal die großen Kondensatoren in der Versorgung an. Die ziehen 
bestimmt zuviel Leckstrom. Sprich, sie sind auf dem besten Wege zum 
Kurzschluß.

Alternativ kommt auch eine defekte Abschaltung der Sendeendstufe in 
Frage.

Carsten

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.