mikrocontroller.net

Forum: Mikrocontroller und Digitale Elektronik Magnetfeld erfassen mit Hall Sensor


Autor: Christopher K. (gbwolf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo,

mein Problem ist folgendes.
Ich möchte ein Mangnetfeld mit einem Hall Sensor erfassen. Eigentlich 
kein Problem und klappt auch. Für meinen Versuchsaufbau habe ich einen 
TLE 4905 L Hall Sensor verwendet und im Datenblatt nachgeschaut,dass der 
einen Schmitt Trigger integriert hat.
Nun das Problem.

Der Sensor schaltet nur bei jedem kommenden Mangnetfeld. Sprich wenn ich 
den Sensor das erste mal an das Magnetfeld halte, leuchtet die "LED" und 
geht erst wieder aus wenn ich den Sensor das nächste mal ans Mangnetfeld 
halte. Dies habe ich ja wahrscheinlich dem Schmitt Trigger zu verdanken.

Ich bräuchte aber einen Sensor der seinen Zustand nicht beibehält, 
sondern nach entfernen des Sensors aus dem Magnetfeldes wieder 
zurückschaltet, sodass dann auch die LED ausgeht.

Kann mir da jemand einen Tipp geben, da ich Neuling auf dem Gebiet bin.

Gruß

Christopher

Autor: TK (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie sieht denn überhaupt Deine Schaltung aus?
Und bist Du sicher, dass Du nicht den TLE4935L eingesetzt hast?

Gruß
TK

Autor: Christopher K. (gbwolf)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Entschuldigung, da hab ich mich verschrieben.

Ich benutze einen TLE 4945 L.

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> meinen Versuchsaufbau habe ich einen TLE 4905 L Hall Sensor verwendet

> Der Sensor schaltet nur bei jedem kommenden Mangnetfeld. Sprich wenn ich
> den Sensor das erste mal an das Magnetfeld halte, leuchtet die "LED" und
> geht erst wieder aus wenn ich den Sensor das nächste mal ans Mangnetfeld
> halte.

Nein.

Der Sensor hat zu schalten wenn du ihn dem Magnetfeld näherst,
und wieder auszugehen wenn du ihn weiter vom Magnetfeld entfernst.

Tut er das nicht, sondern erwartet daß du ihn in ein verpoltes 
Magnetfeld hältst, dann hast du was metallisches am Sensor 
aufmagnetisiert.

>  TLE 4945 L

Ach.
Das ist ja auch ein anderer. Den schaltest du erst mit einem verpolten 
Magnetfeld wieder aus.
Schau halt einfach mal ins Datenblatt, bevor du was kaufst.

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Ich benutze einen TLE 4945 L.

Das ist der Latch-Typ. Der schaltet erst bei umgedrehten Magnetfeld 
wieder zurück. Das kannst du aber auch mit einen zweiten, kleinen 
Magneten realisieren. An der Rückseite des Sensors befestigen.

MfG Spess

Autor: Christopher K. (gbwolf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja okay,

ich brauchte den aber ja nicht zu kaufen, hatte den noch zufällig zu 
Hause. Ansonsten ist da natürlich was wahres dran ;)

 Kannst du mir denn sagen welchen ich ansonsten benutzen kann?

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Kannst du mir denn sagen welchen ich ansonsten benutzen kann?

TLE 4905

MfG Spess

Autor: Christopher K. (gbwolf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Ja okay danke!

Autor: Christopher K. (gbwolf)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hallo nochmals,

also wir haben die Schaltung aufgebaut und bei einem normalen Magneten 
funktioniert das ganze auch super. Nur in der Praxis leider nicht.

Bei der Simulation an einer Schweißmaschine funktionierte leider gar 
nichts bzw. erst ab einem Strom von 15 KA.
Da dieser aber leider im Fehlerfall nicht fließen wird, stellt sich die 
Frage wo das Problem liegt. Der Sensor müsste schon bei einem Strom von 
500 A schalten.
Liegt das Problem daran, das das Magnetfeld was durch den Srom entsteht 
zu Schwach ist?
Kann man die Empfindlichkeit der Hall - Sensors irgendwie verstärken?
Gibt es noch andere Möglichkeiten ein Magnetfeld zu erfassen und 
auszuwerten?

Im Anhang die Schaltung die verwendet wurde. Als Hall Sensor wurde jetzt 
der TLE 4905 G verwendet. Die LED ist jetzt auf dem Bild nicht 
eingezeichnet.

Weiß einer wo der Unterschied zwischen dem TLE 4905 G und dem TLE 4905 L 
ist?

Gruß Christopher

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Habt ihr auch nur EIN MAL nachgerechnet,
welches Magnetfeld um den Draht entsteht
und welches nötig ist um den TLE4905 zu schalten ?

Keine Ahnung ob du derselbe bist, hier ändern die Leute
ja für jede Frage ihren NickName,
aber in deinem anderen Thread wurde explizit der
KMZ51B genannt um Strom in einem Leiter messen zu
können, weil der analog ist und die Schaltschwelle
somit eingestellt werden kann, zudem bekommt man
keine Probleme mit der 100Hz Brummunterdrückung.

Autor: spess53 (Gast)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Liegt das Problem daran, das das Magnetfeld was durch den Srom entsteht
>zu Schwach ist?

Kommt darauf an, wie der Sensor gekoppelt ist. Sieh dir mal den Anhang 
an.

>Weiß einer wo der Unterschied zwischen dem TLE 4905 G und dem TLE 4905 L
>ist?

Gehäuse.

MfG Spess

Autor: Christopher K. (gbwolf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Keine Ahnung ob du derselbe bist, hier ändern die Leute
> ja für jede Frage ihren NickName,
> aber in deinem anderen Thread wurde explizit der
> KMZ51B genannt um Strom in einem Leiter messen zu
> können, weil der analog ist und die Schaltschwelle
> somit eingestellt werden kann, zudem bekommt man
> keine Probleme mit der 100Hz Brummunterdrückung.

Nein ich glaube du meinst wen anders.

Ich möchte ja so gesehen keinen Leiter messen. Sondern Passiv das 
Magnetfeld erfassen und auswerten. Ein Stromzange bauen bringt mir 
nichts, weil ich keinen Leiter habe, wo ich messen kann...

Autor: Christopher K. (gbwolf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
spess53 schrieb:
> Hi
>
>>Liegt das Problem daran, das das Magnetfeld was durch den Srom entsteht
>>zu Schwach ist?
>
> Kommt darauf an, wie der Sensor gekoppelt ist. Sieh dir mal den Anhang
> an.

Mein Hall - Sensor hat aber nur 3 Anschlüsse. Vcc, GND und Q...

Autor: spess53 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hi

>Mein Hall - Sensor hat aber nur 3 Anschlüsse. Vcc, GND und Q...

Magnetisch

MfG Spess

Autor: HUT (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
ab, für die Geduld, die hier immerwieder aufgebracht wird von den 
Beantwortern!

Lieber Christopher sagst Du mal, was Du wirklich brauchst oder machen 
möchtest und möglichst ausführlich ?
Hat es irgendwie noch mit Weihnachten zu tun ?

Autor: Christopher K. (gbwolf)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
HUT schrieb:
> ab, für die Geduld, die hier immerwieder aufgebracht wird von den
> Beantwortern!
>
> Lieber Christopher sagst Du mal, was Du wirklich brauchst oder machen
> möchtest und möglichst ausführlich ?
> Hat es irgendwie noch mit Weihnachten zu tun ?


Wenn dir der Beitrag zu Blöd ist oder du meinst dafür überqualifiziert 
zu sein dann lass es einfach...

Bisher dachte ich Foren sind dafür da Probleme zu diskutieren und nicht 
blöd angemacht zu werden...

Autor: MaWin (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
> Ich möchte ja so gesehen keinen Leiter messen. Sondern Passiv das
> Magnetfeld erfassen und auswerten. Ein Stromzange bauen bringt mir
> nichts, weil ich keinen Leiter habe, wo ich messen kann...

Das war jetzt aber ein langer Satz nur um zu sagen:
"Nein, wir haben's nie nachgerechnet, sondern probieren nur mal".

Mann Leute, setzt euch auf den Hosenboden,
ein mal im Leben nicht nur rumgammeln und zusammenpfuschen
sondern ingenieursmässig recherchieren !

Autor: David .. (david1)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wie gesagt, erklär doch einfach mal was du haben willst, z.Z. scheinen 
alle Glaskugeln kapuut zu sein.

Wenn du von Strömen von 15KA schreibst, dann kann der schlecht in der 
Luft fließen. Wenn du also keinen Leiter hast wirst du wahrscheinlich am 
Trafo vom Schweißgerät messen wollen?

Das Zuaberwort heißt übrigens magnetische Flussdichte ...

Autor: Jörg M. (materia) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
spess53 schrieb:

> Das ist der Latch-Typ. Der schaltet erst bei umgedrehten Magnetfeld
> wieder zurück. Das kannst du aber auch mit einen zweiten, kleinen
> Magneten realisieren. An der Rückseite des Sensors befestigen.

Wow, ich saß gerade vor genau dem gleichen Problem, weil all meine 
Lüfter nur Latch-Typen her gaben. Auf die einfachsten Ideen kommt man 
nicht alleine. Danke! :)

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.