mikrocontroller.net

Forum: PC Hard- und Software alte RAID-Platten lassen sich nicht ansprechen


Autor: M. .D (barracuda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Hallo zusammen

folgendes Problem:

Ich hatte bis vor kurzem ein RAID10 in meinem PC und zwar mit einem 
Rocketraid 2300 Raidcontroller und 4x WD-5000AAKS (500GB) Platten.

Ich hab mir dann ne SSD und ne 1TB Caviar Black zugelegt mit der Absicht 
die alten 500 GB Platten in meinem NAS weiter zu verwenden.
Also habe ich auf dem RAID-Controller die Platten abgemeldet, das RAID 
gelöscht und die Platten "normal" (also über die Onboard 
Sata-Connectors) verbunden doch sie startetetn nicht.

Inzwischen Konnte ich die Platten ein bisschen zum laufen bringen (man 
muss sie an den Rocketraid stecken bis sie laufen und dann den 
SATA-Stecker rausziehen und an nen anderen PC anschliessen).

Am andern PC bin ich jetzt mal dran die Platten zu plätten, mit O&O 
SafeErase doch ich vermute, das der RAID-Controller an einen speziellen 
Bereich (Spur 0?) irgendwie etwas hingeschrieben hat, was dazu führt das 
die Platten nur starten wenn sie an den RAID-Controller gehängt werden.

Plausibel?

Falls ja, hat jemand ein Tool oder so mit dem ich diese Information 
wieder löschen könnte und die Platten wieder dazu bringen würde mit 
jedem PC zu starten?

$Liebe Grüsse

Marius

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marius Dubach schrieb:
> Am andern PC bin ich jetzt mal dran die Platten zu plätten, mit O&O
> SafeErase doch ich vermute, das der RAID-Controller an einen speziellen
> Bereich (Spur 0?) irgendwie etwas hingeschrieben hat, was dazu führt das
> die Platten nur starten wenn sie an den RAID-Controller gehängt werden.

dein das kann nicht sein, ein Raidcontroller kann auch nur die normalen 
Bereiche beschreiben.
Wir hatten aber mal ein Raidcontroller der ein Festplatten password 
vergeben hat, damit kann man die Festplatte nicht mehr normal verwenden. 
Erst wenn man sie im Raidcontroller das Raid gelöscht hat wurde auch das 
Passwort gelöscht. Der Hersteller sagte das es zur sicherheit ist, damit 
man nicht eine Raidfestplatte ohne den Raidcontroller betreibt und damit 
das Raid zerstört. Das Password wollte er uns aber auch nicht verraten.

Autor: M. .D (barracuda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Peter schrieb:
> ein das kann nicht sein, ein Raidcontroller kann auch nur die normalen
> Bereiche beschreiben.

okay, das heist aber das wenn ich die platten dann formatiert habe (also 
mit nullen bekritzelt) und die platten sonst in Ordnung sind sollte 
nachher alles wieder gut sein?

was ist mit dieser berühmt-berüchtigten "spur 0" (wo ja glaub ich der 
MBR und ein Dateiverzeichnis und so drin sind, oder?)

Wird die auch "genullt" wenn ich die platten nulle?

Peter schrieb:
> Das Password wollte er uns aber auch nicht verraten.

Es gibt solche HErsteller die einfach immer unkooporativ sind;)
habt ihr die platten nachher entsorgt?

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marius Dubach schrieb:
> Wird die auch "genullt" wenn ich die platten nulle?
Es gibt keine Spuren mehr, es gibt nur noch Sektoren von 0 - ...
Wenn du in jeden Sektor mit nuller überschreibst dann ist die komplette 
festplatte leer.

> Es gibt solche HErsteller die einfach immer unkooporativ sind;)
> habt ihr die platten nachher entsorgt?
nein, wir hatten ja den Controller noch da, damit konnten wir das Raid 
löschen.

Autor: Rufus Τ. Firefly (rufus) (Moderator) Benutzerseite
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es genügt übrigens, den ersten Sektor zu überschreiben, dann kann zwar 
Datenrettungssoftware den ganzen Krempel noch retten, aber einem PC 
gegenüber verhält sich die Platte "wie neu".

Autor: M. .D (barracuda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Rufus Τ. Firefly schrieb:
> Es genügt übrigens, den ersten Sektor zu überschreiben

hallo

also die null-software wurde gerade fertig aber die platte kann ich 
immernoch nicht normal anschliessen, ich krieg ne fehlermeldung beim 
booten (SATA 1 Hard Disk error) und unter win 7 pro 64bit wird sie nicht 
angezeigt.

Wie kann ich explizit den ersten Sektor überschreiben?
Mit Testdisk hab ich schon den MBR neu geschrieben, hat aber nix 
gebracht

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marius Dubach schrieb:
> also die null-software wurde gerade fertig aber die platte kann ich
> immernoch nicht normal anschliessen, ich krieg ne fehlermeldung beim
> booten (SATA 1 Hard Disk error) und unter win 7 pro 64bit wird sie nicht
> angezeigt.
dann hast du ein anderes Problem, windows ist es ziemlich egal was 
vorher auf der Platte war, er zeigt sie auf jeden Fall an. Ich hatte 
auch noch nie eine Platte die sich dann nicht formatierne lies.

Boote mal ein Linux von einer Live-CD und versuche dort mal die platte 
zu lesen.

Autor: JensM (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Das sieht so aus, als ob die Platten nicht starten.
Es ist üblich Festplatten in einem Raid nicht automatisch zu starten, 
sondern explizit mit einem Befehl, damit der Anlaufstrom der
Festplatten zeitlich versetzt wird.

Bei SCSI war es oft möglich dieses Verhalten über Jumper auf den Platten 
einzustellen.

Es kann sein, dass der Raidkontroller dies bei den Platten so 
eingestellt hat. Das kann man sicher mit einem Tool des 
Festplattenherstellers wieder
zurücksetzen. Mit solchen Tools kann man z.B. auch einstellen ob die 
platten schnell oder leise sind.

MfG JensM

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Wenn ein Passwort gesetzt ist dann nützt das Löschen von Sektor 0 gar 
nichts.

Mach mal folgendes:
1. Knoppix oder andere Linux Live CD booten
2. Konsole öffnen
3. hdparm -I /dev/sda    (sda steht für die erste Festplatte, sdb für 
die zweite und so weiter)
4. Anschauen was nach Punkt 3 bei "Security" steht (ist zeimlich weit 
unten.

Bei einer Festplatte ohne Passwort sieht das so aus:

        Master password revision code = 65534
                supported
        not     enabled
        not     locked
        not     frozen
        not     expired: security count

Gruss,
Tobi

Autor: M. .D (barracuda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
JensM schrieb:
> Das kann man sicher mit einem Tool des
> Festplattenherstellers wieder

ich hab mal auf der WD-Homepage geschaut aber keines gefunen.

Hast du gerade eines parat?

Meine Platten sind caviar blue 5000aaks

@tobi

mach ich ma, danke

Autor: M. .D (barracuda)
Datum:
Angehängte Dateien:

Bewertung
0 lesenswert
nicht lesenswert
hallo zusammen, hallo tobi

ich hab jetzt mal das von tobi gepostete Kommando in knoppix eingegeben, 
dabei kam heraus das offenbar kein passwort gesetzt ist (habe den 
kompletten bericht angehängt, könnte vielleicht jemandem helfen?).

Es ist mir aber gerade in den sinn gekommen, dass die Festplatte zum 
zeitpunkt des Tests über den RAID-Controller angeschlossen war, könnte 
das einen Einfluss haben?

Und noch ein anderer Gedanke:

In dem Bericht steht doch auch die Angabe von heads, cylinders und 
sectors.

Könnte es was bringen wenn ich diese informationen mit testdisk mit dem 
Punkt "Change disk geometry" neu auf die Platte schreibe?

Autor: Peter (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marius Dubach schrieb:

> Es ist mir aber gerade in den sinn gekommen, dass die Festplatte zum
> zeitpunkt des Tests über den RAID-Controller angeschlossen war, könnte
> das einen Einfluss haben?
das kann schon etwas ausmachen, aber da sogar der Herstellen und die 
Seriennummer auslesbar ist scheint der Raidcontroller die Daten 1:1 
durchzureichen.

Wo du es unter windows getestet hast, wo hing die Platte da dran?

> Könnte es was bringen wenn ich diese informationen mit testdisk mit dem
> Punkt "Change disk geometry" neu auf die Platte schreibe?
nein, weil diese informationen noch noch als Kompatibilität vorhanden 
sind. Es gibt kein aktuellen System was das noch verwendet. Es werden 
nur noch Sektoren genutzt.

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marius Dubach schrieb:

> ich hab jetzt mal das von tobi gepostete Kommando in knoppix eingegeben,
> dabei kam heraus das offenbar kein passwort gesetzt ist (habe den
> kompletten bericht angehängt, könnte vielleicht jemandem helfen?).

Was kommt im Knoppix bei
  fdisk /dev/sda
  p
  q
raus? Wenn nicht leer, dann mit
  dd if=/dev/zero of=/dev/sda count=1
löschen. Für /dev/sda unbedingt die korrekte Disk einsetzen, wie von 
Tobi erwähnt!

Autor: g457 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Schaug Dir mal die (vollständige) Doku zur Option '-s' an vom hdparm.

HTH

Autor: A. K. (prx)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Yep, das wirds sein, da steht
 powers-up in standby;

Autor: M. .D (barracuda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
A. K. schrieb:
> Was kommt im Knoppix bei
>   fdisk /dev/sda
>   p
>   q

also er meldet dann einfach nichts, also wie keine antwort, aber auch 
kein fehler^^ ist glaub ich richtig?

g457 schrieb:
> Schaug Dir mal die (vollständige) Doku zur Option '-s' an vom hdparm.

also eine "vollständige" Doku hab ich nicht egfunden, aber ich hab 
rausgefunden, das man damit glaub ich einstellen kann ob die Platte vom 
Controller an und aus geschaltet wird? oder wie muss ich mir das 
vorstellen?

A. K. schrieb:
> Yep, das wirds sein, da steht
>  powers-up in standby;

aus dem kommentar schliesse ich, dass ich mit hdparm -s die einstellung 
auf das gegenteil dessen einstellen sollte von dem was es jetzt ist, 
oder nicht? aber was ist es jetzt?;)

Autor: g457 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
>> Schaug Dir mal die (vollständige) Doku zur Option '-s' an vom hdparm.
> also eine "vollständige" Doku hab ich nicht egfunden, aber ich hab
> rausgefunden, das man damit glaub ich einstellen kann ob die Platte vom
> Controller an und aus geschaltet wird? oder wie muss ich mir das
> vorstellen?

aus man hdparm:
       -s     Enable/disable the power-on in standby feature, if supported  by
              the  drive.   VERY  DANGEROUS.   Do not use unless you are abso‐
              lutely certain that both the system BIOS (or firmware)  and  the
              operating  system  kernel  (Linux >= 2.6.22) support probing for
              drives that use this feature.  When enabled, the drive  is  pow‐
              ered-up  in the standby mode to allow the controller to sequence
              the spin-up of devices, reducing the instantaneous current  draw
              burden when many drives share a power supply.  Primarily for use
              in large RAID setups.  This feature is usually disabled and  the
              drive  is  powered-up  in  the active mode (see -C above).  Note
              that a drive may also allow enabling this feature by  a  jumper.
              Some  SATA  drives support the control of this feature by pin 11
              of the SATA power connector. In these cases, this command may be
              unsupported or may have no effect.

Das Fiehdscha nennt sich übrigens 'staggered spinup' [1]

HTH

[1] http://en.wikipedia.org/wiki/Staggered_spinup

Autor: M. .D (barracuda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
okay das heisst ich geb jetzt ma

hdparm -s 0 /dev/sda

ein?

danke für den link

edit:

wenn ich jetzt hdparm -s 0 /dev/sda schreibe bekomme ich den Fehler:

spin up: setting power-up in standby to 0 (off)
HDD_DRIVE_CMD(power_up_in_standby) failed: Input/Output error


bitte, wer kann mir zum schluss helfen;)

Autor: Jens G. (jensig)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
mal an anderen SATA-Anschluß anbinden, oder anderes SATA-Kabel nehmen.

Autor: A.H. (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Es könnte sein, dass du Pech hast, wenn man diesem FAQ-Eintrag #17 
glauben darf:

http://www.hdat2.com/hdat2_faq.html#q17

Durch einen Firmware Bug kann angeblich ein einmal gesetztes Power-Up In 
Standby (PUIS) nicht mehr zurückgesetzt werden. Das wird auch im 
WD-Forum so besprochen:

http://community.wdc.com/t5/Desktop/WD3200AAJS-320...

Zum Eingrenzen: Wenn bei deinem "hdparm -s 0 /dev/sda" der IO-Error 
kommt, kannst du mit dem Befehl "dmesg" vorher und nachher mal 
nachsehen, ob der Kernel irgendetwas Erhellendes sagt. Die Differenz 
zwischen vorher und nachher bitte hier posten.

Eventuell hilft Folgendes als Plan B: Wenn die Platten sowieso in ein 
NAS reinkommen sollen, und das NAS nicht von diesen Platten booten muss, 
dann kann man das NAS evtl. dazu überreden, die magischen Kommandos zum 
Hochfahren der Platten selbst abzusetzen.

Autor: g457 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Mit etwas Klück hat die Platte auch einen extra Jumper (wies in der 
Manpage von hdparm angedeutet wird) [1].

HTH

[1] http://www.wdc.com/en/library/eide/2579-001037.pdf

Autor: g457 (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
(Nachtrag: Obiges PDF ist im von A.H. verlinkten Fred verlinkt - ich 
will mich hier nicht mit anderer Leute Lorbeeren schmücken)</ingrid>

Autor: Tobi (Gast)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Moin,

was sagt "hdparm -C /dev/sda" ?

eine aktive Festplatte meldet z.B. das hier:

/dev/sda:
 drive state is:  active/idle

Autor: M. .D (barracuda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
A.H. schrieb:
> Es könnte sein, dass du Pech hast, wenn man diesem FAQ-Eintrag #17
> glauben darf:

ich glaub ziemlich sicher das das bei mir der fall ist: Ich konnt das 
staggered-spin up feature auf dem controller, nachdem es aktiviert war 
nie mehr deaktivieren, jetzt weis ich auch wieso nicht... (bzw. auf dem 
controller war es deaktiviert, auf den platten nicht)

A.H. schrieb:
> Eventuell hilft Folgendes als Plan B: Wenn die Platten sowieso in ein
> NAS reinkommen sollen, und das NAS nicht von diesen Platten booten muss,
> dann kann man das NAS evtl. dazu überreden, die magischen Kommandos zum
> Hochfahren der Platten selbst abzusetzen.

hab ich mir auch überlegt

g457 schrieb:
> Mit etwas Klück hat die Platte auch einen extra Jumper (wies in der
> Manpage von hdparm angedeutet wird) [1].

Nein, leider haben meine platten das nicht (bzw. der jumper der das 
eigentlich bewirken sollte entfaltet keine wirkung^^)

Tobi schrieb:
> was sagt "hdparm -C /dev/sda" ?

hab ich noch nicht angeschaut, vielleicht guck ich das noch nach

ALLERDINGS:

Ich habe das Ganze mit meinem vater besprochen (er ist auch der der das 
neue NAS will) und er hat gesagt ich soll entweder den controller mit 
Platten mit einer eindrücklichen Warnung auf Ebay verkaufen (nämlich das 
die platten nur mit dem Controller laufen)

und

eine neue Platte fürs NAS kaufen. Das wird wohl ne Caviar Black

oder

schauen ob die platten im neuen NAS anspringen

Ich denke ich werde die erste lösuing durchführen da die platten eh 
schon ein bisschen älter waren.

Ich danke euch allen für eure Mithilfe, jetzt weis ich das nächste mal 
wie ich mir selbst helfen kann;)

Ich finde es einfach schade, dass WD den bug nicht behebt (Zitat aus 
einem Fred: Western Digital said on the phone the KS line of drives are 
not a high-enough priority for them to fix the firmware. )

weil jetzt muss ich etwas austauschen (Umweltschutz und so...) das 
eigetlich noch funktionieren könnte...

Auf jeden fall nochmal: Vielen Vielen Dank für die konstruktive Hilfe

Autor: Icke ®. (49636b65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marius Dubach schrieb:

> eine neue Platte fürs NAS kaufen. Das wird wohl ne Caviar Black

Die Green-Serie wäre eine erheblich bessere Wahl. Aufgrund der engen 
Bauweise von NAS-Gehäusen kommt jedes Watt weniger der Kühlung (und 
damit der Lebensdauer) sehr entgegen. Gegenüber der Black verbrauchen 
die Green nur halb soviel Energie und die Geschwindigkeit ist immer noch 
hoch genug, damit die Platte nicht zum Engpaß wird.

Autor: M. .D (barracuda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
@icke

ich habe eher deshalb an die black gedacht, weil die 24x7 zertifiziert 
sind und 5 jahre garantie haben

oder gibts greens mit 5 jahren garantie? (das wär ideal:))

Autor: Icke ®. (49636b65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Die Black sind m.E. NICHT 24/7 zertifiziert. Dafür hat WD andere Serien, 
i.d.R. mit einem "Y" in der Bezeichnung und gelbem Typenschild. Für den 
Preis kannst du aber auch zwei normale kaufen (MTBF 1,2 Mio h) und im 
RAID1 verschalten. Das kommt der Datensicherheit mehr zugute als ein 
24/7-Kuckuck. Kauf auch keine Platten >1,5 TB (die 2 TB sind anfälliger) 
und wenn die Green, dann die mit "EADS".

Autor: M. .D (barracuda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Icke ®. schrieb:
> Die Black sind m.E. NICHT 24/7 zertifiziert. Dafür hat WD andere Serien,
> i.d.R. mit einem "Y" in der Bezeichnung und gelbem Typenschild.

muss ich dich leider korrigieren.

Ich habe erst gerade für meinen PC ne Caviar Black 1TB gekauft und die 
IST 24/7 zertifiziert (hab sie aber nicht deswegen gekauft;))

Icke ®. schrieb:
> Für den
> Preis kannst du aber auch zwei normale kaufen

mach ich jetzt auch^^

Icke ®. schrieb:
> 24/7-Kuckuck.

einfach noch so by the way: Ein Freund von mir im Büro der viele 
Festplatten verkauft sagt für ihn sei es eindeutig das die Caviar Black 
länger hielten als die Caviar Green. Inwiefern das wirklich stimmt kann 
ich nicht beurteilen, das sagt er zumindest so;)

Hast mich aber trotzdem überzeugt, es gibt noch ne zweite Caviar Green 
zu der dazu die wir in unserem alten NAS bereits haben und die 2TB 
reichen für uns momentan auch.

Nochmals danke

Autor: Icke ®. (49636b65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marius Dubach schrieb:

> Ich habe erst gerade für meinen PC ne Caviar Black 1TB gekauft und die
> IST 24/7 zertifiziert

Bei WD findet sich jedenfalls kein Hinweis darauf, sondern nur auf 5 
Jahre Garantie. Explizite 24/7-Zertifizierung ist nur bei den RE3/RE4 
(die mit dem "Y") angegeben.

> einfach noch so by the way: Ein Freund von mir im Büro der viele
> Festplatten verkauft sagt für ihn sei es eindeutig das die Caviar Black
> länger hielten als die Caviar Green.

Wieviele hat er denn schon verkauft? 10, 100, 1000? Und unter welchen 
Einsatzbedingungen wurden die betrieben? Gehen soviel von ihm 
vertriebene Platten kaputt, daß sich ein repräsentatives Bild ergibt? 
Ich verkaufe zwar keine einzelnen Platten, aber ich verbaue eine Menge 
davon. In den letzten 1,5 Jahren hatte ich nur einen einzigen Defekt 
einer WD-Platte und das war eine Raptor.

Autor: M. .D (barracuda)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Icke ®. schrieb:
> Bei WD findet sich jedenfalls kein Hinweis darauf, sondern nur auf 5
> Jahre Garantie. Explizite 24/7-Zertifizierung ist nur bei den RE3/RE4
> (die mit dem "Y") angegeben.

hast recht, sorry
aber immerhin 5 Jahre Garantie;)

Icke ®. schrieb:
> Wieviele hat er denn schon verkauft? 10, 100, 1000?

Zahlen kann ich keine nennen, aber eher im Bereich 100+

Icke ®. schrieb:
> Gehen soviel von ihm
> vertriebene Platten kaputt, daß sich ein repräsentatives Bild ergibt?

ich habe ja einfach gesagt das "er das so sagt";)

Icke ®. schrieb:
> In den letzten 1,5 Jahren hatte ich nur einen einzigen Defekt
> einer WD-Platte und das war eine Raptor.

na dann einigen wir uns doch einfach darauf das WD tolle Festplatten 
herstellt;)

Autor: Icke ®. (49636b65)
Datum:

Bewertung
0 lesenswert
nicht lesenswert
Marius Dubach schrieb:

> na dann einigen wir uns doch einfach darauf das WD tolle Festplatten
> herstellt;)

Sollte eher lauten: "ZUR ZEIT tolle Festplatten herstellt". Qualität ist 
leider keine statische Größe, auf die man sich dauerhaft verlassen kann. 
Aber solange WD sein derzeitiges Niveau hält -> klare Empfehlung.

Antwort schreiben

Die Angabe einer E-Mail-Adresse ist freiwillig. Wenn Sie automatisch per E-Mail über Antworten auf Ihren Beitrag informiert werden möchten, melden Sie sich bitte an.

Wichtige Regeln - erst lesen, dann posten!

  • Groß- und Kleinschreibung verwenden
  • Längeren Sourcecode nicht im Text einfügen, sondern als Dateianhang

Formatierung (mehr Informationen...)

  • [c]C-Code[/c]
  • [avrasm]AVR-Assembler-Code[/avrasm]
  • [code]Code in anderen Sprachen, ASCII-Zeichnungen[/code]
  • [math]Formel in LaTeX-Syntax[/math]
  • [[Titel]] - Link zu Artikel
  • Verweis auf anderen Beitrag einfügen: Rechtsklick auf Beitragstitel,
    "Adresse kopieren", und in den Text einfügen




Bild automatisch verkleinern, falls nötig
Bitte das JPG-Format nur für Fotos und Scans verwenden!
Zeichnungen und Screenshots im PNG- oder
GIF-Format hochladen. Siehe Bildformate.
Hinweis: der ursprüngliche Beitrag ist mehr als 6 Monate alt.
Bitte hier nur auf die ursprüngliche Frage antworten,
für neue Fragen einen neuen Beitrag erstellen.

Mit dem Abschicken bestätigst du, die Nutzungsbedingungen anzuerkennen.